Results 1 to 8 of 8

Thread: In Search of Patches for TS2009 and TS2010 EE

  1. #1
    Join Date
    Dec 2011
    Location
    Dearborn, Michigan
    Posts
    65

    Default In Search of Patches for TS2009 and TS2010 EE

    I downloaded all of the patches I could find at http://support.auran.com, which took some time, and none of them applied to my particular builds. TS2010 says that it is out of date, and the "In Cab" controls don't work at all. What should I do?

  2. #2
    Join Date
    Nov 1999
    Location
    Stevens Point, Wisconsin, USA.
    Posts
    14,626

    Default

    Whole smash here;

    http://www.auran.com/servicepacks/

    TS2009 is a pain because you have to do all four in sequence, there's no single patch to take you all the way up. If you have the STEAM version you're SOL since the patch for that has to come from STEAM whenever they get around to making it available.



    Look in the lower right corner of the launcher for the current build number, for this I would download the Build 40040 -> 41844 patch then get the last Build 41844 -> 44653 patch next. I have plenty of free disk space so when I patch, I copy the entire TS2009 or TS2010 folder to a backup first in case the patch fails halfway through. Which happens to a lot of people patching TS2010, one of the patches appears to be frozen after the first hour, so they cancel it and have to reinstall. Leave it alone for several hours, the progress bar stops moving for an hour or two in the middle, but it's verifying the database at that time so don't interrupt it.

  3. #3
    Join Date
    Dec 2011
    Location
    Dearborn, Michigan
    Posts
    65

    Default

    I tried installing every service pack patch listed for TS 2009 at http://www.auran.com/servicepacks/ and all of them reported that they did not apply to my version (build 38869.) How can I find out what service pack I have, and why can't I apply any of the patches? I deleted my "trash" folder, disarmed my antivirus, and disconnected my internet cable.
    ed catterall

  4. #4

    Default

    That build is listed as:

    Build 38869 PROTECTED UK Retail

    meaning you cant patch it.




    Now my only other question is. How did a guy from Michigan end up with a UK retail version? hmm?

    Alienware m18R2, Intel i7, 2xGeforce 680M, 12gb Ram, Win 7 Ult 64 bit

  5. #5
    Join Date
    Dec 2011
    Location
    Dearborn, Michigan
    Posts
    65

    Default

    I bought it from a Michigan company, P.I. Engineering in Williamston, the maker of the RailDriver desktop controller! I think I shall ask for an RMA! Where can I purchase the USA version?
    Ed Catterall

  6. #6
    Join Date
    Nov 1999
    Location
    Stevens Point, Wisconsin, USA.
    Posts
    14,626

    Default

    Probably best bet is the official Auran forums;

    http://forums.auran.com/trainz/index.php

    Register there and look for the help desk link. They might be able to help, might not, but at the top are links to the Auran N3V shop where you can buy directly from them. I have nothing against STEAM or Just Trains, but for patch compatibility it's best to buy directly from Auran.

  7. #7
    Join Date
    Dec 2011
    Location
    Dearborn, Michigan
    Posts
    65

    Default

    I just uninstalled TS2009 (UK Edition) and downloaded/installed TS2009 World Builder Edition directly from Auran. Thank you so much for your help.
    Ed Catterall

  8. #8
    Join Date
    Dec 2011
    Location
    Dearborn, Michigan
    Posts
    65

    Default

    My PC configuration is:
    Intel Core 2 Duo 3.06 GHz
    Serial ATA Hard Drive 500 Gigabytes
    12 Gigs of Ram
    100 Megabyte AMD Radeon HD 6670 Video Card

    I just tried to patch TS2009 from Build 38411 to 40040 and it crashed my system and rendered my system unbootable! Of course I had run a complete backup prior to this attempt and have restored my system. What am I doing wrong
    now?
    Ed Catterall

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •