Results 1 to 8 of 8

Thread: Please help with my Railworksproc2.exe crash

  1. #1

    Default Please help with my Railworksproc2.exe crash

    Hi there, first post.

    This place is bigger than I imagined :-D

    I bought Train Simulator 2012 De-luxe edition retail copy last week.

    All did not start off well when it wanted to download the 6something gigabytes of data before it installed. All this after the steam activiation.

    Now i have the sim installed, but it wont run.

    Ive never had the game up and running. After clicking start trainsim on the settings config launcher type window, the game loads to the menu where it immediately stops working and an alt-tab, brings up another window with 'something went bad' and then the game crashes.

    My system spec is.

    I5 2500k @ 3.6ghz
    8GB corsair Vengeance ram
    GTx570SC evga

    I have scoured the internet for solutions and possible fixes and tried many of them. I would of posted on the steam forums however they havent activated my forum account yet.

    But if this place is anything like flightsim.com then im sure its the better place to be!

  2. #2

    Default

    Welcome to TS-2012 and SBHH (Something Bad Has Happened) you will get more of over time !

    The install and download seems to be faulty and there is something missing or has been corrupted. Running the VERIFY INTEGRITY OF CACHE function as shown below should fix it.

    Run TS-2012 on-line to STEAM and when it's opening screen shown in the first picture displays then RIGHT-CLICK on the STEAM icon in the Task Bar, then click on Library and then do what is indicated in the following pictures.

    This will take some time and when finished EXIT TS-2012 then run it again and you should be able to select a route and play one it's Scenarios.

    O t t o






  3. #3

    Default

    Thanks for the reply, however steam wont let me verify the cache when its running the initial start screen. Ive tried in both online and offline modes.

    EDIT

    Ive just run two integrity checks in a row, both times it says the files where successfully validated.

    Upon getting to the main menu it crashed again, with the usual crash info

    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: RailWorksProc2.exe
    Application Version: 0.0.0.0
    Application Timestamp: 4f354add
    Fault Module Name: GameManager.dll
    Fault Module Version: 1.0.0.1
    Fault Module Timestamp: 4f354b6f
    Exception Code: c0000005
    Exception Offset: 001874f0
    OS Version: 6.1.7601.2.1.0.768.3
    Locale ID: 2057
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Read our privacy statement online:
    http://go.microsoft.com/fwlink/?link...8&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
    C:\Windows\system32\en-US\erofflps.txt
    Last edited by Jack19262; 03-05-2012 at 02:05 PM.

  4. #4

    Default

    Quote Originally Posted by Jack19262 View Post
    Ive just run two integrity checks in a row, both times it says the files where successfully validated. Upon getting to the main menu it crashed again, with the usual crash info
    Appears that you are running WIN-7 64-bit ?

    Not sure whether the RailWorksProc2.exe has to be run as Administrator ?

    All failing then contact either STEAM or [email protected] you paid for something which does not work.

    O t t o

  5. #5
    Join Date
    Oct 2004
    Location
    Spokane, Washington, USA.
    Posts
    861

    Default

    Using the same technique as Otto is showing, but looking at the GENERAL tab, click the item that lets you "Create a Desktop Shortcut". Once you get the desktop shortcut, right click it and do "preferences". Go to "Advanced" and select "Run as Administrator". I have found it best to start from the desktop shortcut than directly from inside Steam.

    Your system is a very capable game machine, so I see no problems with your setup. Give it a try and let us know how it goes. Good luck.

    Doug

  6. #6

    Default

    Might be easier in the Railworks folder to Right-Click on the RailWorksProc2.exe and RailWorks.exe and click on their Properties which should have an option to run them as Administrator.

    O t t o

  7. #7

    Default

    At one time I had a proc2.exe crash. Changing my computer's screen resolution eliminated the problem. Perhaps the will help you.

    Alamoman


    Quote Originally Posted by Jack19262 View Post
    Hi there, first post.

    This place is bigger than I imagined :-D

    I bought Train Simulator 2012 De-luxe edition retail copy last week.

    All did not start off well when it wanted to download the 6something gigabytes of data before it installed. All this after the steam activiation.

    Now i have the sim installed, but it wont run.

    Ive never had the game up and running. After clicking start trainsim on the settings config launcher type window, the game loads to the menu where it immediately stops working and an alt-tab, brings up another window with 'something went bad' and then the game crashes.

    My system spec is.

    I5 2500k @ 3.6ghz
    8GB corsair Vengeance ram
    GTx570SC evga

    I have scoured the internet for solutions and possible fixes and tried many of them. I would of posted on the steam forums however they havent activated my forum account yet.

    But if this place is anything like flightsim.com then im sure its the better place to be!

  8. #8

    Default

    Hi, I'm a first time buyer and I decided to get the Game and the USA Hauling pack and I got it installed, the issue is pretty much like the first posters' as i am having the exact same issue

    Here are My spacs on my comptuer,

    Windows 7 Home Premium / 64 bit.
    AMD Phenom II X4 , 945 processor @ 3.0ghz
    8GB RAM
    ATI Radeon HD 5570, Driver version 8.892.0.0 9/8/11

    I did what has been pointe dout here (verify cache, clean,) and it still crashes.
    Have Steam running as Administrator, so that's not the issue either..
    Edit: I have even reduced the resolution from 1920x 1200 down to 1440 x900 no difference
    and yes I have even tried the last idea (Checking in the railworks folder and clicking and checking "Run as Administrator" for both Railworks.exe, and RailWorksProc2.exe


    So then, next idea guys? Cause I've used everything useful and actually have gotten no where with it..

    RailCoyote
    Last edited by Railcoyote; 07-18-2012 at 05:57 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •