Announcement

Collapse
No announcement yet.

A tiny graphics issue

Collapse
This topic is closed.
X
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    A tiny graphics issue

    The frames per second (FPS) is not the issue here. I have a real fast, great running computer that can commonly run this simulation near the max. 60 FPS.

    The issue is a tiny ever-so-slight jerk in the simulation every about 1.5 seconds.

    There could be some sorta graphics setting that could fix this, but I dont know what it is. If anyone knows what this setting is, that would be appreciated. If its something deeper and you need more details, I will gladly provide you with those. thanx.

    I use ATI video cards using the Catalyst Control Center software.
    Cheers! -Pete

    anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

    #2
    One of two things likely involved, MSTS can stutter on data reads off a HD. This will be more of a problem on 7200 rpm drives with a small cache. A 10,000 rpm drive and larger cache will minimize this.
    Second thing, I have heard that there may be some problems running MSTS under some of the later Catalyst drivers? I use Nvidia, so can't comment on a solution?
    sigpic

    Comment


      #3
      Whats Running on the System?

      An anti-virus or a program running in the background can do that
      ............Vince ..............
      ...... Author NECv4 .......
      .... LIRR BUILD PHOTOS ....
      ...... Eschew Obsfucation ......

      On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
      "Give me your tired, your poor, your huddled masses yearning to breathe free,
      the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
      I lift my lamp beside the golden door!"

      Comment


        #4
        Since you have an ATI card drop down your AF setting until the jerk stops.

        Comment


          #5
          More likely to be

          "10ms # On-track solver timestep"
          "1 # Off-track solver"
          "30ms # Off-track timestep"

          From default.wag

          Try reducing the "off track timestep" and see what you get.

          Derek

          Comment


            #6
            Try turning off the switch display (F8?).
            Regards,

            Eric

            Comment


              #7
              Make sure the indexing service isn't running. Make sure you don't have any extraneous programs running as well. I had a similar problem come up with a BIN version that was fixed in a subsequent release. However, it will still show up, just a bit, if I've done a lot of stuff on my computer and then run MSTS. A reboot to clear out the memory will fix it right up.

              Comment


                #8
                Originally posted by Vince View Post
                An anti-virus or a program running in the background can do that

                I disabled the anti-virus (Avast!), and this did not have any effect.
                Cheers! -Pete

                anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

                Comment


                  #9
                  Originally posted by snootnose View Post
                  Since you have an ATI card drop down your AF setting until the jerk stops.

                  I kept dropping the AF setting till I couldnt drop it no more, no effect. I tried with the "High Quality AF" selected/deselected, no effect. I tried with "Application Settings" selected, still no effect.

                  Still have some other options to try out, so I'll post back.
                  Cheers! -Pete

                  anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

                  Comment


                    #10
                    Originally posted by plainsman View Post
                    One of two things likely involved, MSTS can stutter on data reads off a HD. This will be more of a problem on 7200 rpm drives with a small cache. A 10,000 rpm drive and larger cache will minimize this.
                    Second thing, I have heard that there may be some problems running MSTS under some of the later Catalyst drivers? I use Nvidia, so can't comment on a solution?


                    I hope it would be some other problem than this as I cant afford to replace any hard drives right now. However, I WILL be replacing hard drives in the future as I'm trying to do away with my IDE hard drives and make a complete switch over to Serial ATA drives as they have a faster transfer rate (and also it seems they are phasing out IDE connections on newer motherboards). So this would be a very important tip for when I do replace my hard drives. It would make sense that a hard drive with faster rpm's, larger cache, and a faster transfer rate would definitely help out with graphically intense applications such as MSTS.

                    I still got some options here to try, but thank you very much fer the tip. This will be very helpful for me in the future.
                    Cheers! -Pete

                    anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

                    Comment


                      #11
                      Originally posted by ChrisS68 View Post
                      Make sure the indexing service isn't running. Make sure you don't have any extraneous programs running as well. I had a similar problem come up with a BIN version that was fixed in a subsequent release. However, it will still show up, just a bit, if I've done a lot of stuff on my computer and then run MSTS. A reboot to clear out the memory will fix it right up.


                      This didnt work. I went to my Microsoft Management Console, and turned off the indexing service. No effect. Restarting my computer is always a common practice for me anyway before starting MSTS due to another graphics issue that I may post another topic on. But that never has any effect on the "jerking".
                      Cheers! -Pete

                      anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

                      Comment


                        #12
                        Originally posted by buttercup View Post
                        Try turning off the switch display (F8?).

                        WOW! Whoopi!! this actually worked!!! Thanx alot man!! What I really did was that I went into my "options" on MSTS, and deselected the switching aid on the menu. I havent tested Derek's solution yet. I thought I would test the "easier" ones first before I have to start modifying files. But this solution from buttercup was the last one, and rather simple, but seems to work well for me. The jerk is not there anymore with the switch monitor turned off.

                        This was a common practice for me to have my switching aid visible, but if I got a green light on my track monitor, then I dont need to have the switch aid up.
                        Last edited by plainsman; 10-14-2009, 03:57 AM. Reason: language
                        Cheers! -Pete

                        anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

                        Comment


                          #13
                          The problem is solved here, but this leads to more questions that I just thought of right now. Was the simulation jerking cuz the switch aid was selected on my options menu, or cuz the switch aid was up period? If I have the switch aid deselected on my options menu, then I press F8 during my activity, will the simulation start jerking? If I press F8 during my activity, then leave it up while I exit my activity, will it show up as selected on my options menu? I will test this and be back shortly.
                          Cheers! -Pete

                          anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

                          Comment


                            #14
                            The switch aid display seems to cause the "jerking" in some routes and not others. It appears that the sim hesitates when switch aid window is updated. It is probably computer resource related (memory, cpu speed, etc.).
                            Regards,

                            Eric

                            Comment


                              #15
                              Originally posted by punkrok77 View Post
                              The problem is solved here, but this leads to more questions that I just thought of right now. Was the simulation jerking cuz the switch aid was selected on my options menu, or cuz the switch aid was up period? If I have the switch aid deselected on my options menu, then I press F8 during my activity, will the simulation start jerking? If I press F8 during my activity, then leave it up while I exit my activity, will it show up as selected on my options menu? I will test this and be back shortly.



                              I would press the F8 button to put up the switch aid, and the jerking starts. Then I would press F8 to take off the switch aid, and the jerking stops, regardless of the switch aid selected on the options menu.
                              Cheers! -Pete

                              anarchy + peace = FIGHT FOR YOUR RIGHT!!!!!

                              Comment

                              Working...
                              X