Announcement

Collapse
No announcement yet.

Fresh install opens to black screen, then shuts down

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Fresh install opens to black screen, then shuts down

    Hello All

    Sorry to trouble with what appears to have been a fairly popular issue, but I've tried all the solutions I've found on this site and others and still have no luck getting MSTS past the blackscreen at startup before it shuts back down.

    Background info; I have a 10 year old HP Pavilion Slimline with a stock AMD Atheron Processer and recently swapped out NVidia Quadro FX380 card I had to install to support dual monitors as the GEForce stock version failed to function properly. The computer was also upgraded to Windows 10 for compatibility with work systems. Following the upgrade MSTS ran OK but had some monitor alignment issues I couldn't figure out how to resolve, so I left the issue alone and moved away from regular use for about 6 months.

    I just got back into running the sim again and whenever I start it, the sim loads up to the black screen which would usually precede the mpeg video, hangs there and then drops back to desktop. No error message, no errors logged on the computer error report. Strangely enough, the Editor software works without a hitch. All the routes are in there and working "as normal", but I couldn't get to them via the sim.

    I decided since my last install had some buggy issues with sounds and texturs and soforth to do a clean reinstall from the start and after following the msts.steam4me tutorial to the letter including all updates/upgrades I'm still having the same problem. I dumbed down the resolution on the monitor to MSTS levels and below, am running everything as an Administrator, deleted the start.mpeg and nothing seems to do the trick.

    So before I pull the plug one last time on the old sim, and frankly this not-gracefully-aging desktop, I figured I'd ask to see if there was any recent insight to this issue or how to resolve it. Thanks in advance!

    #2
    I'm not really technically minded but my suggestion would be for you to try running MSTS thru Open Rails.
    Regards,

    Nick

    ( boffin0_reprised on TikTok )




    Cyberpower Desktop with AMD Ryzen 5 CPU. 16GB RAM. ATI AMD Radeon RX6700 12GB graphics. Windows 11 Home 64bit. RailDriver. Partridge in a pear tree....​

    Comment


      #3
      Originally posted by niknak View Post
      I'm not really technically minded but my suggestion would be for you to try running MSTS thru Open Rails.
      To be pedantically correct...MSTS does not run through Open Rails They are two separate and distinct execute files...Open Rails is backward compatible with legacy trainset equipment, routes, built for MSTS and with MSTS files...con, act, pat, eng, wag etc etc.

      Apologies if you merely typographically misspoke...so to speak.
      Cheers, Gerry
      "A mind is like a parachute. It doesn't work if it is not open." Frank Zappa
      It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
      Forever, ridin' drag in railroad knowledge.
      Audi, Vide, Tace, Si Vis Vivere In Pace

      Comment


        #4
        Apology typographically accepted Gerry...
        Regards,

        Nick

        ( boffin0_reprised on TikTok )




        Cyberpower Desktop with AMD Ryzen 5 CPU. 16GB RAM. ATI AMD Radeon RX6700 12GB graphics. Windows 11 Home 64bit. RailDriver. Partridge in a pear tree....​

        Comment


          #5
          Hm, so it would seem that MSTS as a platform is a no go anymore. Very unfortunate but I guess all good things must come to an end.

          Comment


            #6
            While the days of MSTS are grinding to an end OpenRails/TSRE has picked up the ball and made a freaking touchdown.

            Comment


              #7
              Once you try Open Rails you will never go back. It is much better than the original MSTS.

              Jon

              Comment


                #8
                Open Rails is a far better experience.

                If you're set on running MSTS, having issues on launch might be related to your Trains\Trainset and Trains\Consists folder. It reads this on start, and can crash to the desktop when there are too many, even if it seemed to be stable earlier, or perhaps it's encountering some unknown ORTS-only parameters...

                Easy test for that is to create backup copies of your Trainset and Consists folders, and thin the originals out to a bare minimum.
                If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                Comment


                  #9
                  How'd I get My copy of MSTS to work on W10 ( before I'd took it off in favor of ORTS ) was to first, right-click & Run As Admin. THEN head down to where it'd said, "Properties". Here, you'd click Compatibility. Because certain W10 ( Graphic Card problem ? ) installs doesn't like a certain file type needed to run the launch,..you "tone-down" the screen res. to the default, ( 512x512? ). This helped my problem without needing to install the default needed file Manually.

                  Comment


                    #10
                    If work needs forced you to go to a Win 10 upgrade, that PC looks like fairly low level hardware to even bother with any OS upgrade. Shoulda bought a new box and gotten the whole slate of current features (UEFI, PCIe v3, DDR5, M.2 SSD, etc)
                    My Open Rails videos https://www.youtube.com/channel/UClc...1kBPO2A/videos

                    Comment


                      #11
                      Originally posted by eric View Post
                      If you're set on running MSTS, having issues on launch might be related to your Trains\Trainset and Trains\Consists folder. It reads this on start, and can crash to the desktop when there are too many, even if it seemed to be stable earlier, or perhaps it's encountering some unknown ORTS-only parameters...

                      Easy test for that is to create backup copies of your Trainset and Consists folders, and thin the originals out to a bare minimum.
                      Yeah I figured some add-ons might be causing the issue as the bug has been a recent appearance but I'm starting with just the stock consists sets, I figured if I could get the sim running again I'd go back and re-download all the rolling stock and routes again from scratch.

                      Originally posted by geepster775 View Post
                      If work needs forced you to go to a Win 10 upgrade, that PC looks like fairly low level hardware to even bother with any OS upgrade.
                      Pretty much, it was on its last leg before COVID but it worked with the DOS-based systems her company still uses. I'm frankly surprised it even made it through the upgrade!

                      Originally posted by marklester01 View Post
                      How'd I get My copy of MSTS to work on W10 ( before I'd took it off in favor of ORTS ) was to first, right-click & Run As Admin. THEN head down to where it'd said, "Properties". Here, you'd click Compatibility. Because certain W10 ( Graphic Card problem ? ) installs doesn't like a certain file type needed to run the launch,..you "tone-down" the screen res. to the default, ( 512x512? ). This helped my problem without needing to install the default needed file Manually.
                      I'll try this and keep fiddling with settings on the card and display and see if that makes a difference. If not I'll have to take another look at Open Rails but as its been said here, the computer I'm working with is probably not worth much effort at this point.

                      Comment


                        #12
                        Originally posted by yeppers View Post
                        I'll try this and keep fiddling with settings on the card and display and see if that makes a difference. If not I'll have to take another look at Open Rails but as its been said here, the computer I'm working with is probably not worth much effort at this point.
                        Hi

                        my apologies if this has been said but if your PC does not handle MSTS then OR is your only option.

                        I currently have to travel a bit and I take a 10 year old laptop with my MSTS installed
                        and it will not even load as I have way too many Routes and too much stock.

                        BUT it does run with OR, FPS between 20 - 30 which sounds low but somehow the result is much
                        better than MSTS where 20 - 30 was jerky with lots of moiré.

                        Cheers

                        Daniel
                        Daniel - Sydney (Glad I'm not in Townsville)
                        It used to be my favourite place in the world.

                        Comment

                        Working...
                        X