Announcement

Collapse
No announcement yet.

MSTS fails to start

Collapse
Only viewable if you're a logged in user
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MSTS fails to start

    start screen comes on, you go to drive trains it freezes then goes to desktop. after using MSTS_Check v2.1 all of the many files were corrected. so many files so much time wow.
    I do not know how to tell this in more detail.
    bigjohn

    #2
    Unfortunately this happens with MSTS for a lot of reasons.

    You can check the rolling stock with working activities.
    You can check the route with other activities.

    This is a large reason, most of us have moved to OR.

    Comment


      #3
      Hi,
      derek : I think you mean "many of us have moved to OR"!! I still run MSTS for those routes designed for it, although in many cases I have to admit that, generally, OR runs them better!

      John : which route/activity are you trying to run? There are many reasons why MSTS won't run, not all associated with activities and/or stock!

      Cheers,
      Ged

      Comment


        #4
        Hi; After the start screen, it shuts off when you toggle the drive trains icon, no activity or anything else (I use OR myself but the kids use MSTS )
        Thanks
        bigjohn

        Comment


          #5
          Hi John,
          Sorry, mate, but you've not directly answered my question. From your comments, it looks as if MSTS is not installed correctly. Just a guess, but it could be that you don't have the full GLOBAL folder - it's as if you're trying to run a route set up for Open Rails with MSTS. There are several files in the default GLOBAL folder which MUST be present for MSTS to run.

          Cheers,
          Ged

          Comment


            #6
            Did you install Bin? Did you perform this step of the install process?
            From new "DLLs" subfolder in root of game choose your language folder and copy string.dll and dialog.dll and copy them into root of game. Confirm replace original ones.
            Charles

            Comment


              #7

              hey guys
              The installation has worked for years and it was working, bin yes, oem global, this problem just started a week ago, and no OR route but put route SoCal in and then moved it to OR a mistake on my part.I am going to test a backup MSTS and see if that works then I'll tell you guys if I find the problem if possable thanks
              bigjohn

              Comment


                #8
                Hi John,

                There is no need to move anything to OR, OR can find it where it is installed for MSTS?

                Comment


                  #9
                  this has nothing to do with OR just MSTS it fails to go past the start screen

                  Comment


                    #10
                    On the start screen see if you can go to options. Maybe the kids changed something like textured skies?
                    Jim

                    Comment


                      #11
                      I am going to research everything tomorrow after Thanksgiving football eating and whatever happens.
                      everybody have a good Thanksgiving

                      Comment


                        #12
                        If you are getting a crash to desktop then normally, but not always, an event is generated in the Event viewer. Open the event viewer (Start > Run > eventvwr.msc) and go to Windows Logs > Application. On clicking the Application icon it may appear blank for several minutes, just wait for it to populate.

                        See if there are any Error or Warning event generated at the same time of the MSTS crash.

                        Cheers,

                        Marek.

                        Comment


                          #13
                          will do thanks Merek

                          Comment


                            #14
                            we ended up changing the train set to an old saved one and then fixed all the errors that we could haha there turned out to be quite a few errors in that train set.
                            thanks for you guys help
                            big john

                            Comment


                              #15
                              Interesting... I've run into similar issues in the past -- removed half the trainset folders, and it would work. Gradually added batches back until I could narrow down what it was barfing on.
                              If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                              Comment

                              Working...
                              X