Announcement

Collapse
No announcement yet.

New made Consists made in ConBuilder or TSRE are not showing in MSTS

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New made Consists made in ConBuilder or TSRE are not showing in MSTS

    I didn't have that issue before. I recently installed MSTS again and new made consists are not showing in game. I can only see them in OpenRails but I don't want to play it throught OR. Any advice? Also it only happens with official trains. If I make new Consist with mods they show without any issue.
    Click image for larger version

Name:	image.png
Views:	3175
Size:	86.4 KB
ID:	2290976Click image for larger version

Name:	image.png
Views:	226
Size:	1.7 KB
ID:	2290977​​

    #2
    only way to do that create a new consist with new cars and new bnsf dash 9 this can be done on trse 5 consist builder. save consist and will overwrite yard_one_traffic2.con Jdark34 same for the other consist

    Comment


      #3
      it will run better on open rails

      Comment


        #4
        Originally posted by Maksha View Post
        I didn't have that issue before. I recently installed MSTS again and new made consists are not showing in game. I can only see them in OpenRails but I don't want to play it throught OR. Any advice? Also it only happens with official trains. If I make new Consist with mods they show without any issue.
        ​​
        Are we understanding you correctly? You create a drivable consist (one with a drivable loco leading) with either ConBuilder or TRSE-CE and it does not appear in the MSTS menu but does appear in the OR menu.

        Questions:
        Do you have more than one Installation?
        What is the path to your installation? Or paths if more than one.
        What do you mean by "official trains"?

        What version of ConBuilder are you using? Appears to be the freeware version.
        Charles

        Comment


          #5
          Originally posted by crstagg View Post

          Are we understanding you correctly? You create a drivable consist (one with a drivable loco leading) with either ConBuilder or TRSE-CE and it does not appear in the MSTS menu but does appear in the OR menu.

          Questions:
          Do you have more than one Installation?
          What is the path to your installation? Or paths if more than one.
          What do you mean by "official trains"?

          What version of ConBuilder are you using? Appears to be the freeware version.
          I actually installed one MSTS but made second copy to keep one vanilla

          My path is my 3rd HDD, which is E:\Gry\MSTS\MSTS.

          Official I mean the ones that come with game. If install for example F7 from your site and make consist with it, it works but when I make consist with for example default dash9, it's saved in folder but doesn't show in game. If I overwrite one of the existing that were made by devs, it also doesn't show in game.


          I used ConBuilder 2.4.9 and and TSRE 0.6958. Both fail in MSTS (OpenRail works fine)

          I just don't understand why it is an issue when a year ago I didn't have that issue with the game.
          Last edited by R. Steele; 11-30-2023, 03:31 PM.

          Comment


            #6
            Hi Maksha,
            As you have (at least) two MSTS installations, have you 'told' ConBuilder which installation to use?

            Cheers,
            Ged

            Comment


              #7
              Originally posted by slipperman View Post
              Hi Maksha,
              As you have (at least) two MSTS installations, have you 'told' ConBuilder which installation to use?

              Cheers,
              Ged
              lol ofc I did, I literally see where it is putting consists

              Comment


                #8
                In MSTS one chooses Drive a Train, then choose the route, then choose either Explore or an Activity (If you have not placed the consist Dash9 test in an activity, you should be choosing Explore), next one chooses the locomotive. I assume you are choosing the Dash9. So the pull down for consist should be showing the Dash9 Test consist. Does the Consist pulldown have a scroll bar when the Dash 9 is selected for the locomotive?
                Charles

                Comment


                  #9

                  Seems odd, as I use Conbuilder for both OR and MSTS. My only thought is have you checked the Consist Folder in the MSTS install you are trying to run it in and seen the file there?

                  Also thinking, have you checked the engine folder and file names being correct in the consist file for what is in the Train folder of the install you are trying to use if there are not an exact match it won't show up.
                  Last edited by oper190; 11-30-2023, 08:50 PM.
                  Owner and CEO of Hart Rail Lines & Hart Commuter Railways, and Hart Rail Cars.
                  It's my Train Sim world so I run HART RL anywhere I want.

                  Comment


                    #10
                    Open Windows Explorer to E:\Gry\MSTS\MSTS\Trains\Consists. Locate Dash9 Test.con and open it with a text editor.
                    The third line (with text) should be:
                    TrainCfg ( "Dash9 Test"
                    Does it look exactly as I have written?

                    Does the first Engine lines look like this:
                    Engine (
                    UiD ( 0 )
                    EngineData ( dash9 DASH9 )
                    ?

                    Now ​open E:\Gry\MSTS\MSTS\Trains\Trainset
                    In the Dash9 folder all caps? As in DASH9?
                    Open the folder is the dash9.eng file all small characters?

                    Or if the EngineData line in the CON file is not exactly as I have written above do the filename and folder names match?
                    FYI format is EngineData ( filename FOLDER )
                    Charles

                    Comment


                      #11
                      Another possibility: Have you checked to make sure your MSTS shortcut is pointing to the NEW install?
                      Charles

                      Comment


                        #12
                        Originally posted by crstagg View Post
                        Open Windows Explorer to E:\Gry\MSTS\MSTS\Trains\Consists. Locate Dash9 Test.con and open it with a text editor.
                        The third line (with text) should be:
                        TrainCfg ( "Dash9 Test"
                        Does it look exactly as I have written?

                        Does the first Engine lines look like this:
                        Engine (
                        UiD ( 0 )
                        EngineData ( dash9 DASH9 )
                        ?

                        Now ​open E:\Gry\MSTS\MSTS\Trains\Trainset
                        In the Dash9 folder all caps? As in DASH9?
                        Open the folder is the dash9.eng file all small characters?

                        Or if the EngineData line in the CON file is not exactly as I have written above do the filename and folder names match?
                        FYI format is EngineData ( filename FOLDER )
                        Click image for larger version

Name:	image.png
Views:	469
Size:	6.9 KB
ID:	2291072That's the consist file​

                        Comment


                          #13
                          Originally posted by crstagg View Post
                          Another possibility: Have you checked to make sure your MSTS shortcut is pointing to the NEW install?
                          Click image for larger version

Name:	image.png
Views:	477
Size:	7.3 KB
ID:	2291074
                          Yes it is, I usually run it from the game folder anyways

                          Comment


                            #14
                            Originally posted by oper190 View Post
                            Seems odd, as I use Conbuilder for both OR and MSTS. My only thought is have you checked the Consist Folder in the MSTS install you are trying to run it in and seen the file there?

                            Also thinking, have you checked the engine folder and file names being correct in the consist file for what is in the Train folder of the install you are trying to use if there are not an exact match it won't show up.
                            There should't be an issue with that since I already reinstalled the game twice to make sure it is fully vanilla. I thought some of the patches breaks it

                            Comment


                              #15
                              [QUOTE]That's the consist file​[QUOTE] OK Now answer the other questions:

                              Now ​open E:\Gry\MSTS\MSTS\Trains\Trainset
                              Is the Dash9 folder all caps? As in DASH9?
                              Open the folder is the dash9.eng file all small characters?

                              Charles

                              Comment

                              Working...
                              X