Announcement

Collapse
No announcement yet.

Slovenska Strela M290 Slovakia Arrow... need help .eng

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    >MaxPower ( 601 )

    601 is in watts, so that explains the no power!!

    Comment


      #17
      HI,
      derek : Thanks, mate
      RUDY : Maybe you've not removed line 628. As Derek pointed out, that sets MaxPower as 601 watts; it overrides the previous MaxPower line which sets it at 246 kilowatts.

      Cheers,
      Ged

      Comment


        #18
        Removing line 628 DOES help. It takes a long time to fully relax the train brake (EQ 503 kPa BC 0 kPa PB 503 kP), but once that's done the locomotive will move - I've got it going ~ 27 mph @ 15% throttle and > 76 mph @ 90% throttle on some of the flat bits of Tehachapi Pass (running in Open Rails).

        HOWEVER the whees do not turn or show any signs of animation. Something to do with the *.s file?

        Peace,

        Sam
        Last edited by CurlSnout; 01-31-2024, 12:07 PM.

        Comment


          #19
          Hi,
          As supplied, the Strela .eng file uses shape CSD_M290_Slovenska_Strela4 with which the wheels do rotate, although one of the wheelsets is very 'wobbly'!!
          The wheels in shape file CSD_M290_Slovenska_Strela do not rotate because it has no BOGIE or WHEELS elements.

          Open Rails reports a number of missing cabview texture files and many invalid sound .wav files together with 3 .sms file errors which are listed below :

          M290Strelacab.sms - (1) line 21 - change to 'Streams ( 17' (2) line 201 - add quotes before 'Strela'
          M290StrelaPas.sms - lines 41 & 42 - remove the ')' from each.

          My utility sms_Checker may be used to identify the locations of invalid .wav files.

          Cheers,
          Ged

          Comment


            #20
            When I load the shape file CSD_M290_Slovenska_Strela4.s into Shape Viewer I can see that the wheels are capable of animation (the wobbly wheels are notable), but when running the model in Open Rails none of the wheels appear to spin, wobbly or otherwise - despite the model cruising along on the rails at good speed.

            ?

            Comment


              #21
              Hi Sam,
              That's odd!! I've just had two runs of CSD_M290_Slovenska_Strela.eng using CSD_M290_Slovenska_Strela.s and CSD_M290_Slovenska_Strela4.s in Open Rails and the wheels did not revolve with either of them!!

              I noticed, at the beginning of the .eng file, the entry WheelRadius ( 920mm/2 ). I'd not seen that type of entry before, so changed it to WheelRadius ( 0.5m ), to match the entry in the Engine section. NOW, when using the CSD_M290_Slovenska_Strela4 shape file, the wheels revolve correctly.

              Trying it with the other shape file results in the vehicle moving but without the wheels revolving. - which is what I'd expect!

              The brakes take a very long time to release so I think they need 'looking at' by somebody who knows how OR brakes work!

              Cheers,
              Ged

              Comment


                #22
                Hello Ged,

                Good work, getting the wheels to spin! I noticed, however, that now the locomotive accelerates MUCH more slowly than before (with frozen wheels). Out of curiosity, I tried keeping the first entry for WheelRadius as is and changing the second entry (in the Engine section) to match that one - that is, WheelRadius ( 920mm/2 ). In this case the wheels also spin - but the locomotive still accelerates slowly so that's not an improvement.

                I admit freely that I don't know anything about any of this stuff. This is the first time I have ever really looked inside any *.eng file other than to assign/reassign cabs, sounds, or names. I don't mind the empirical approach (trial-and-error with lots of error), but the fact that it takes so long to free the brakes is a bit off-putting.

                Sam

                Comment


                  #23
                  UPDATE: I changed BOTH of the WheelRadius entries to this:

                  WheelRadius ( 0.46m )

                  And, now the acceleration is good again. Don't ask me why. But for now I'm going with this.

                  Hi-Ho,

                  Sam

                  Comment


                    #24
                    >WheelRadius ( 920mm/2 )

                    Could not possibly work, it would need to be ( 920/2 mm )

                    Comment


                      #25
                      In the CABVIEW directory there are 2 different *.cvf files:

                      StrelaCab.cvf
                      StrelaCab2.cvf

                      StrelaCab.cvf seems to be non-functional. On the first page of this thread Ged rightly indicates that he commented out the CabView entry on line 564 of the *.eng file. That leaves StrelaCab2.cvf - specified on line 625 - and which IS functional, but references left and right views that don't exist (KIHA31Left.ace and KIHA31Rgt.ace, respectively). Rather, the directory includes left and right views from the MSTS Dash9 - dash9lft.ace and dash9rgt.ace (these are specified in StrelaCab.cvf).

                      Copying over the missing KIHA31Left.ace and KIHA31Rgt.ace files from MSTS (if you have it) will give you working left and right cab views. Or, you can edit StrelaCab2.cvf to reference the Dash9 files. None of these seem particularly good fits.

                      Do those left and right views (the *.ace files) exist for the Slovenska Strela?

                      Peace,

                      Sam
                      Last edited by CurlSnout; 02-02-2024, 07:49 PM.

                      Comment


                        #26
                        Correction: StrelaCab.cvf does work, but the graphics are odd - multiple disconnected control handles appear to be floating above the console.

                        Still trying to find more suitable left and right cab views. Do the 'REAL' ones (i.e., views from inside the Slovenska Strela) exist?

                        Comment


                          #27
                          Open Rails NewYear MG 2024-02-02 07-17-57.jpg Here's a cabview I've been playing with. The notch indicator does not work though. I got the throttle notches working with the lever now.
                          Last edited by lineman; 02-03-2024, 12:14 PM.

                          Comment


                            #28
                            Thank-you for your feedback. Getting help with this on other sites has been painfull so here is what I have and I am not a math person. The train is powered by 2 Gas/electric motors each producing 165 hp. 165HP * 2 is 330hp. I put that in the converter and it wrote 330HP = 242715 Wats. Does that sound right for a single car train built in 1936? How should I correct the issue based on these numbers.

                            Comment


                              #29
                              ok I am changing the value to 243KW and see what happens. Thanks for the help. I really appreciate it. I really want to get this built.

                              Comment


                                #30
                                Thank-you! You are the first to actually fire it up in open rails. My dedicated project laptop does not run OR very well. It is my goal to get this this up and running in both. Did you get my sound set to work in OR? The animation I will have to get my friend to look at his work.. Any idea what the issue might be?

                                Comment

                                Working...
                                X