Announcement

Collapse
No announcement yet.

Slovenska Strela M290 Slovakia Arrow... need help .eng

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #91
    You guys are awesome. Besides the great changes from SAM. My friend and I are stuck on a few items. Can any one help with the following

    1. Get the speedometer working
    2. Create another working speedometer on the left side in the circular spot..( I think the spot was made to fit a pocket watch) The way the dashboard is positioned it makes the regular one a little hard to read (once it is working). I'd like something nice and easy to read
    3. I need some help getting the brake gauge to work
    4. Is there a way to make the Fwd and Back lights come on when the train is in FWD or Reverse?
    5. Is there any way to get the two rows of red lights to come on when the prestart is pressed?
    6. Get the motor switch or switches to turn on the engine?
    7. The two red buttons next to speedo are sander and dead man switch I will have to double check

    This is my dream list to make this thing fully functional. The 6 gauges at the top would be great but from our angle (not this one) they can hardly be seen. We plan to animate the wheel to be an e brake. I know I am asking a lot but this is the stuff we are struggling with at the moment.

    Click image for larger version

Name:	strela dashboard with notes.jpg
Views:	506
Size:	176.4 KB
ID:	2297227

    Comment


      #92
      Originally posted by slipperman View Post
      Hi Rudi,
      Thanks for the re-upload, but the .eng contains some errors which I thought we'd already covered!
      I list the corrections below :
      Line 16 - WheelRadius ( 920/2 mm ) - change to WheelRadius ( 0.46m ) - reason = I don't believe MSTS accepts mm as a UoM
      Line 557 - As above
      Line 628 - MaxPower ( 242715 ) - entry removed - Reason = Duplicate - there's already a MaxPower entry on line 547
      Line 690 - NumNothes ( 0 ) - change to NumNotches ( 0 ) - Reason - MSTS ignores this and all following lines.
      Line 708 - EngineVariables ( 150 ) - entry removed - Reason = Duplicate - there's already EngineVariables entry on line 705
      Line 755 - Remove final '+' from line - Reason = after correcting line 690, MSTS 'sees' the '+' as indicating there's further text and reports an error.

      The following haven't caused any problems with MSTS, but I suggest that they are considered for deletion :
      Lines 72 - 77 - 'Inside' section uses a non-existent shape file. A second 'Inside' section is on lines 501 - 507 which uses an existing shape file.
      Line 509 - duplicated 'Sound' section (First is on line 499.

      Cheers,
      Ged


      Sorry for all the posts today. The sounds are a little better but not sure if they are my sounds. I found the horn sounds like a steam engine and nothing like any of the horn sounds I have in my folder. We also noticed that in the cab whatever file we attach the horn to is played at higher speed..like chipmonk speed. We did a test where we put in a song that was the right file size and it played it faster than it should be. Is there some setting?

      Comment


        #93
        Regarding playback speed:

        Are your sound files stereo or mono? If mono, this might have something to do with it:

        If a Stereo() line is present within a ScalabiltyGroup, and a mono .wav sound is called, MSTS will play the sound at double speed. In order to have it play at the correct speed, a frequency curve halving the speed has to be inserted. OR behaves the same as MSTS in this case.

        (from the Open Rails online manual):

        14. Open Rails Sound Management — Open Rails Manual (open-rails.readthedocs.io)

        In your M290strelacab.sms you do have a Stereo() line (Line 19) within ScalabiltyGroup( 5.
        ​​​
        Last edited by CurlSnout; 03-07-2024, 01:13 AM.

        Comment


          #94
          Hi Rudi,
          Apologies for the late reply!
          Originally posted by rudedog97 View Post
          Originally posted by slipperman View Post
          Line 16 - WheelRadius ( 920/2 mm ) - change to WheelRadius ( 0.46m ) - reason = I don't believe MSTS accepts mm as a UoM



          Tonight I am making the corrections. I am not a math guy at all but shouldn't it be 92m? Did I miss something on the 46m? There are two wheels did you devide by half?
          No! The parameter is WheelRadius. You have entered it as 920/2 mm which makes me think that 920mm is the wheel diameter - it has nothing to do with the number of wheels. As MSTS doesn't accept mm as a UoM, your entry should be 0.92/2m or 0.46m.

          Also, in the latest version of the M290 .eng file, one of the lines has not been corrected (sorry I missed it off my last list!) :
          Line 67 - EnergencyResChargingRate ( 1 ) should be EmergencyResChargingRate ( 1 )

          Sorry I can't help with the cabview, but I'm sure somebody will be able to advise on how to achieve your requirements

          Cheers,
          Ged


          Comment


            #95
            A couple more:

            Line 65 - EmergencyResValumeMultiplier should be EmergencyResVolumeMultiplier

            Line 163 - Azimuth ( 0.0 -5.0 5.0 ) should be Azimuth ( 0 0 0 )

            Comment


              #96
              Hi Sam,
              Well done for spotting line 65 - I'd completely missed it!!

              I can't comment on line 163 because it depends on the author's requirements.

              In the Lights section, many of the Light entries are shown as 'Dim+Full' but the Headlight value is ( 0 ) which means that light is always ON - I suggest that Headlight ( 4 ) should be used then, if the headlight switch is OFF, that light is not illuminated. I should point out that Headlight ( 4 ) requires that the MSTS Bin Patch is installed otherwise, MSTS will report an error. Open Rails accepts all the Bin Patch light values.

              Cheers,
              Ged
              Last edited by slipperman; 03-07-2024, 11:16 AM.

              Comment


                #97
                Originally posted by CurlSnout View Post
                I replaced the 'P' and 'Z' textures which define the way the 'Reflectors' (the central lamps above the windscreen, fore and aft, respectively) appear in the sim. Again, using photos of the restored railcar on display at Kopřivnice ​for inspiration.

                Click image for larger version

Name:	53560401210_3d98821462_b.jpg
Views:	795
Size:	142.1 KB
ID:	2296908

                Click image for larger version

Name:	53560157383_7579863477_b.jpg
Views:	151
Size:	139.4 KB
ID:	2296909

                Peace,

                Sam
                Hey Sam how would you like to do this? Do you want my friend to finish his part or do you want to send over the changes you made. Eather way is appriciated.

                Comment


                  #98
                  Originally posted by slipperman View Post

                  In the Lights section, many of the Light entries are shown as 'Dim+Full' but the Headlight value is ( 0 ) which means that light is always ON - I suggest that Headlight ( 4 ) should be used then, if the headlight switch is OFF, that light is not illuminated. I should point out that Headlight ( 4 ) requires that the MSTS Bin Patch is installed otherwise, MSTS will report an error. Open Rails accepts all the Bin Patch light values.

                  Cheers,
                  Ged
                  I noticed early on that, although 'head' lights (front - left and right) and 'tail' lights (back - left and right) are not modeled or implemented in controllable fashion, that they are constantly on - and so it appears that light (white on the front and red on the back) is chronically 'leaking' through the chassis. In the version I'm currently running (in Open Rails) I have removed all of the lights except for the reflector (dim and bright) and the 2 accompanying light cones. I don't know if Rudy is planning to model/ install actual working lights on the front or the back in the future. For now, all of the lights except for the reflectors share the same solid black texture that is used for the bumpers. Maybe Rudy can share his thoughts on any changes to the lights that might be in the pipeline (?).

                  Sam

                  Comment


                    #99
                    Originally posted by rudedog97 View Post

                    Hey Sam how would you like to do this? Do you want my friend to finish his part or do you want to send over the changes you made. Eather way is appriciated.
                    Hello Rudi,

                    Here is a list of the *.ace (texture) files that I have modified (I'm not certain all of these - 'Body', for example - are actually used in the model):

                    Body
                    CheckerFloor
                    Cream
                    MainRed
                    P
                    Shield
                    TrainBody
                    Wall
                    Wheel
                    WindowFrame
                    Z

                    I sampled the primary red (main body, etc.) and cream (exterior roof) colors from one of the TATRA museum sites dedicated to the Slovenska Strela restoration project. Likewise for the checkerboard pattern for the interior floor and the door graphics. As is, the shield is a little bit off in terms of aspect ratio. I attempted to change that, but discovered that it's impossible due to the way the 3D model is built, and the way textures are mapped. A lot of this is, of course, subjective and a matter of personal preference. In any case, you are welcome to have all of these and use what you like. How do you want for me to get them to you? Can I just zip them up and post them here?

                    Sam

                    Also: Do you have a version in which the windows are transparent (from the outside, that is - they are already transparent from the passenger view)? I experimented with this, but so far have not been able to figure out how the alpha channel works for the windows from the outside. Thanks.
                    Last edited by CurlSnout; 03-14-2024, 04:33 PM.

                    Comment


                      Sam my friend Michael the 3d modeler for this plans to join this group. It shoukd make it easier to build a superior train with Sam's help.

                      Comment


                        Hi Rudi,
                        As the M290 has a cab at each end, I created a 'Reverse' cabview file.
                        The vehicle wouldn't move when using that cabview!

                        Checking all the parameters, I found that the cause of the problem is that the Brake_Train section has two entries for 'TrainBrakesControllerReleaseStart'.

                        I made the following changes :
                        Line 673 - NumNotches ( 6 changed to NumNotches ( 5
                        Line 676 - Notch ( 0.4 0 TrainBrakesControllerReleaseStart ) - line deleted

                        This solved the problem of using the 'Reverse' cabview PLUS, the vehicle can now be controlled from an external view.
                        The brakes still take an extended time to release but I think that can be solved by changing the release and charging rates.

                        In the last version of the vehicle I downloaded, on Line 67, EnergencyResChargingRate had NOT been corrected to EmergencyResChargingRate.

                        Cheers,
                        Ged

                        Comment


                          Originally posted by slipperman View Post
                          Hi Rudi,
                          As the M290 has a cab at each end, I created a 'Reverse' cabview file.
                          The vehicle wouldn't move when using that cabview!

                          Checking all the parameters, I found that the cause of the problem is that the Brake_Train section has two entries for 'TrainBrakesControllerReleaseStart'.

                          I made the following changes :
                          Line 673 - NumNotches ( 6 changed to NumNotches ( 5
                          Line 676 - Notch ( 0.4 0 TrainBrakesControllerReleaseStart ) - line deleted

                          This solved the problem of using the 'Reverse' cabview PLUS, the vehicle can now be controlled from an external view.
                          The brakes still take an extended time to release but I think that can be solved by changing the release and charging rates.

                          In the last version of the vehicle I downloaded, on Line 67, EnergencyResChargingRate had NOT been corrected to EmergencyResChargingRate.

                          Cheers,
                          Ged
                          Ged,
                          Thanks for the corrections. They are now implemented in the new version. Can I see that reverse cabvew file? I am still spinning wheels on the cab sounds. Like I said the horn for one is not working right. We put in a test file and it seems it is changing the pitch..we think. The sounds are still not working in the cab. I am also wondering what to do to get some help on my wish list of final items for this project. Any tips? As always thanks for the great advice thanks to you we are making some real progress. Here is the new version


                          Comment


                            Originally posted by rudedog97 View Post
                            You guys are awesome. Besides the great changes from SAM. My friend and I are stuck on a few items. Can any one help with the following

                            1. Get the speedometer working
                            2. Create another working speedometer on the left side in the circular spot..( I think the spot was made to fit a pocket watch) The way the dashboard is positioned it makes the regular one a little hard to read (once it is working). I'd like something nice and easy to read
                            3. I need some help getting the brake gauge to work
                            4. Is there a way to make the Fwd and Back lights come on when the train is in FWD or Reverse?
                            5. Is there any way to get the two rows of red lights to come on when the prestart is pressed?
                            6. Get the motor switch or switches to turn on the engine?
                            7. The two red buttons next to speedo are sander and dead man switch I will have to double check

                            This is my dream list to make this thing fully functional. The 6 gauges at the top would be great but from our angle (not this one) they can hardly be seen. We plan to animate the wheel to be an e brake. I know I am asking a lot but this is the stuff we are struggling with at the moment.

                            Click image for larger version

Name:	strela dashboard with notes.jpg
Views:	506
Size:	176.4 KB
ID:	2297227
                            All, any tips on how to get these final changes in? I know it is a lot but documentation is very limited on light indicators and so forth. Any help would be great.

                            Comment


                              All, I am still waiting for Michael my graphics guy to jump on here and work on the views and other graphical adjustments. We need a good push to get to the finish line. I am still looking to make sure I did not miss any recommendations outside of some of the graphics elements. Your help is awesome. I hope you guys can help us get this completed. Here is the latest version.

                              Comment


                                The model still has those wobbly wheels especially wheels21 where the whole axle has a wobble. Apart from that, looking good.
                                Beer is not a matter of life or death, it is much more serious than that.

                                Comment

                                Working...
                                X