Announcement

Collapse
No announcement yet.

Sound Issues Causing Crashes?

Collapse
Only viewable if you're a logged in user
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sound Issues Causing Crashes?

    First of all, thank you for your great contribution to MSTS and the community.
    I am addressing this issue to you because you obviously know "there is something going on" with the sound, having included the sound improvement option in the installer.
    Also I won't insist much as I've transitioned to TSC... but that doesn't mean I would abandon MSTS.

    The popping sound I will be referring is the following the kind you get with buffer underruns in a digital audio workstation i.e. when you set the size of the audio buffer a bit too low. A series of close pops will sound like a dropout (momentary sound cut-out).
    It also sounds like the very subtle pop you get every time you start and stop the playback of a sound. It's more obviousl on headphones.

    Observations made on "Winter Evening Run" activity on the Settle & Carlisle Line (a good testbed).
    a.1. stuttering/popping appears when the train to goes over a bridge, go under a bridge, and go over a level crossing; the first pop is as you exit the curve that leads to the sign just before the first bridge you cross.

    Observations made on "Dawn Tank Train" activity on Marias Pass
    b.1 Occasional pops every few seconds (2 to 5) in the right channel; seems to be linked to track sound but but when I have dynamic brake engaged it isn't apparent
    b.2 The first bridge you come over stutters/pops although less than on the Settle & Carlisle Line
    b.3. the brake compressor sound on the Dash 9 has a pretty obvious rhythmic popping; this is easy to hear as it's engaged when the activity starts

    Observations on other places
    c.1. once my MSTS crashed (with the usual "train.exe stopped working" dialog box from windows) but I was able to alt-tab back into it and drive for another 30 seconds, controls responsive and all that, till it crashed "again", this time for good. Between the two crashes the sound was looping an approximately 0.3 to 0.5s long sequence
    c.2. most crashes took place where stuttering/popping is common
    c.3. one crash occurred on Marias Pass while the combined power lever sound was looping (as it always does after you push it repeatedly)
    c.4. pop also occurs when changing camera views

    What does not make a difference:
    - if I set quantity of sounds low, medium, high
    - if I use camera 1 & 4 or other camera views (I read this on an other forum, with sound issues)
    - change bit depth and sampling frequency
    - raising minimum power state for sound card from D3 to 0
    - disabling power management for USB hubs in Windows
    - disabling HDMI audio stuff (two places in Device Manager)
    - set affinity to a single processor (as per noli's tip)
    - updated me drivers
    - tried with generic windows drivers

    My system: Windows 10 64bit, 8gb ram, i7 processor, nVIDIA video card, onboard sound card (Realtek HD Audio)
    My file: Either 1.4 or Bin 1.8 (doesn't seem to make a difference), command line option "-mem:4096"
    File options: "High DPI Scaling managed by Application", "Disable Full Screen Optimizations"; compatibility mode doesn't matter (MSTS runs fine without, but to be on the safe side I tried XP Sp2)

    #2
    Morning,

    Might be worth your time to have a look at this thread, scroll down to reply #6... https://www.trainsim.com/vbts/showth...n+rails+folder

    I still build my routes using MSTS Route Editor. Back when Open Rails was fairly new I was testing in MSTS but started testing the route in Open Rails. In MSTS I was getting frame rates of as low as 8 fps in heavily populated areas. As I went along the route I could see every object spawn in front of me. Testing the same area in Open Rails, the frame rate in the area that was getting 8 was getting 23, instead of the average area getting 25 it was getting in the 50s. I had the viewing distance set to 3300 meters and Everything was already spawned before I got to it... sort of like real life.

    One thing OR does that MSTS never did, if you crash or just end a session it put a log on your desktop and lists everything thing including all errors. It does indicate what the problem is or at least you could post it here and someone will be able to suggest what to look for.

    Paul

    Comment


      #3
      Please refrain mentioning OpenRails in this topic. Thank you.

      Comment


        #4
        There are tools available to help fix these problems.
        I suggest you use them.

        Randy

        Comment


          #5
          Check you have the modified soundcfg file for bin

          Comment


            #6
            Originally posted by ragtimer View Post
            Check you have the modified soundcfg file for bin
            Yes, it's one with 200 instead of 40 for the second parameter of the third item of the next to last "skip" (and no other change).
            I changed it to 2000 but apart from some very long loading times it didn't solve anything.

            Originally posted by rdayt View Post
            There are tools available to help fix these problems.
            I suggest you use them.

            Randy
            Well if somebody has those tools I just saved him an hour's work didn't I? Winter Evening Run crashes once for two full runs so it's pretty reliable. Otherwise I will look into it with Process Explorer or whats'isname but I have absolutely no clue about the Windows API.

            Comment


              #7
              You are trying to be far too clever for your own good!

              If you've installed the Bin patch, I hope you also selected the sounds enhancement. That is all you need to do.

              For details, referring to lines like : SoundSystem ( 5, 40, 20, 31457280, the recommended values are SoundSystem ( 5, 400, 100 ). Omitting the last parameter has proved to be beneficial. The first parameter will be in the range 0 to 5, indicating the Scalabilty level entered in .sms files. These changes must be applied to all the SoundSystem lines.

              You would learn a lot about MSTS if you read the tutorials on Steam4Me (https://msts.steam4me.net/).

              Process Explorer won't be of any help to you.

              If your MSTS crashes when running the default routes, then the problem, almost certainly, is due to the (in)capabilities of your PC. Why don't you give us some information, like its specifications and what OS you're running.

              Ged

              Comment


                #8
                Dear Ged,
                Your reply kind of reminded me of an '80s recording of a Formula 1 race I saw few years ago; there where two British commentators, and they were constantly describing other things happening than we were seeing on the screen.

                Anyway, I applied the Williamson & Santucci procedure, orthodox and variants

                trial: omitting the last parameter
                result: no sound

                trial: setting the last parameter to 0
                result: no change from stutter/pop as usual

                trial: setting the last parameter to 67108864
                result: no change from stutter/pop as usual

                trial: setting the last parameter to 134217728
                result: no change from stutter/pop as usual

                PC specifications are listed in the first post. It can run RailWorks without issue at 60fps minimum.

                Comment


                  #9
                  Your PC specifics are incomplete as to PC model, CPU and GPU version. Is that intentional?
                  My Open Rails videos https://www.youtube.com/channel/UClc...1kBPO2A/videos

                  Comment


                    #10
                    steamonly,
                    My apologies, but as geepster775 has pointed out, your PC specifications are incomplete.
                    Notwithstanding that, if you can run other 'games' at fantastic rates, there is no logical reason why your PC should not run MSTS very easily.

                    Your comments regarding the sound problems are, frankly, rubbish.
                    For at least 10 years, I have been running MSTS successfully, with the SoundSystem parameters as shown in my last post.
                    As has been mentioned by others, the problem is with your PC or, with respect, yourself.

                    By the way, you should NOT have "High DPI Scaling managed by Application" set for MSTS.

                    I suggest that you study the tutorial on Steam4Me regarding installing MSTS into Win 10 - https://msts.steam4me.net/tutorials/...sts_win10.html
                    The only action missing is that train.exe (and launcher.exe) must be set to "Run this program as an administrator".

                    I fail to see the relevance of your criticism of the Formula 1 commentary - everything I posted was pertinent to your current problem ie MSTS!

                    If you want help from this (or any other) Forum, it will pay you to show a little courtesy.

                    Ged

                    Comment


                      #11
                      Originally posted by geepster775 View Post
                      Your PC specifics are incomplete as to PC model, CPU and GPU version. Is that intentional?
                      The critical item missing that could affect FPS is GPU memory.
                      Charles

                      Comment


                        #12
                        Originally posted by slipperman View Post
                        For at least 10 years, I have been running MSTS successfully
                        That means that you are running Windows 7 while it is obvious I am running Windows 10. Jokes aside, and with all due respect, I can't show courtesy to somebody who intentionally gives bad advice. But I don't blame you, but I can't have respect for the greengrocer's apostrophe either.

                        Comment


                          #13
                          steamonly,
                          You are very good at assuming things!! FYI, I've been running MSTS under Windows 10 since it was introduced in 2015.

                          Bad advice?? If that's the way you feel, I'll not waste my time replying to any more of your posts, in whichever Forum they may appear.

                          I'd wish you "Good luck", but, unless you change your attitude, you won't have any!!

                          Ged

                          Comment


                            #14
                            Shades of user "LetsGoRailfanning" whose unstoppable (pun intended) concern for 3DTrains F-units landed him in forever-moderated purgatory whose posts are on track to be approved sometime in the year 2052.
                            My Open Rails videos https://www.youtube.com/channel/UClc...1kBPO2A/videos

                            Comment


                              #15
                              In a non-virtual neighborhood bar, this character would be getting the bums rush out the back door. I suppose the calculation is short-term amusement factor vs. irritation to paying customers.
                              Cheers, Gerry
                              It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
                              Forever, ridin' drag in railroad knowledge.
                              Audi, Vide, Tace, Si Vis Vivere In Pace

                              Comment

                              Working...
                              X