Announcement

Collapse
No announcement yet.

Cabcar Lighting

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cabcar Lighting

    Hi Everyone,

    I'm working on a project for a future release. But I've run into a snag,

    My consist is a push-pull passenger train with locomotive and cabcar. Both are setup as locomotives to work with MSTS BIN.

    But for some reason, when the locomotive is in the lead position, the red rear lights don't want to light up?

    I copied the coding from a German ICE set in the Wupper Express 11 route. It works fine on the ICE in the set.

    But my cabcar doesn't have the same effect?

    I have positioned the red lights in the correct place using SView and the measuring tool.

    This is the section for the red rear lights.

    Light (
    comment( Red light right back dim )
    Type ( 0 )
    Conditions (
    Headlight ( 2 )
    Unit ( 3 )
    )
    FadeIn ( 0.5 )
    FadeOut ( 0.5 )
    Cycle ( 0 )
    States ( 1
    State (
    Duration ( 0.0 )
    LightColour ( ffff0000 )
    Position ( 3.15 1.06 -11.79 )
    Azimuth ( -180 -180 -180 )
    Transition ( 0 )
    Radius ( 0.25 )
    Elevation ( 0.0 0.0 0.0 )
    )
    )
    )
    Light (
    comment( Red light right back bright )
    Type ( 0 )
    Conditions (
    Headlight ( 3 )
    Unit ( 3 )
    )
    FadeIn ( 0.5 )
    FadeOut ( 0.5 )
    Cycle ( 0 )
    States ( 1
    State (
    Duration ( 0.0 )
    LightColour ( ffff0000 )
    Position ( 3.15 1.06 -11.79 )
    Azimuth ( -180 -180 -180 )
    Transition ( 0 )
    Radius ( 0.25 )
    Elevation ( 0.0 0.0 0.0 )
    )
    )
    )
    Light (
    comment( Red light left back dim)
    Type ( 0 )
    Conditions (
    Headlight ( 2 )
    Unit ( 3 )
    )
    FadeIn ( 0.5 )
    FadeOut ( 0.5 )
    Cycle ( 0 )
    States ( 1
    State (
    Duration ( 0.0 )
    LightColour ( ffff0000 )
    Position ( 3.15 -1.02 -11.79 )
    Azimuth ( -180 -180 -180 )
    Transition ( 0 )
    Radius ( 0.25 )
    Elevation ( 0.0 0.0 0.0 )
    )
    )
    )
    Light (
    comment( Red light left back bright)
    Type ( 0 )
    Conditions (
    Headlight ( 3 )
    Unit ( 3 )
    )
    FadeIn ( 0.5 )
    FadeOut ( 0.5 )
    Cycle ( 0 )
    States ( 1
    State (
    Duration ( 0.0 )
    LightColour ( ffff0000 )
    Position ( 3.15 -1.02 -11.79 )
    Azimuth ( -180 -180 -180 )
    Transition ( 0 )
    Radius ( 0.25 )
    Elevation ( 0.0 0.0 0.0 )
    )
    )
    )

    Robert
    Last edited by NW 2156; 03-27-2023, 10:27 AM.

    #2
    Hi Robert,
    You seem to have edited your post since I first looked! I assume that the lights still don't display as you require? It appears that you have added 2 Light sections - did you increase the Lights value correspondingly?

    I've looked at several cabcar downloads and the kindest thing I can say about most of them is that their lighting system is incomplete!!

    Please let me know the exact model you are using and I'll see if I can configure it to displsy correctly.

    In the meantime, have you had a look at lights-tutorial.zip? It's a translation of a Spanish document I obtained permission to upload here. You might find it helpful/useful.

    Cheers,
    Ged

    Comment


      #3
      Hi Ged,

      I edited my post because I left out some information. I clip these things from the eng/wag into text documents for editing. But I grabbed the wrong snipbit when I posted.

      I did increase the valve. But it doesn't work still. I am trying to get my lighting code to mimic the ICE Trainset in the Wupper Express for a lack of a better way to explain it. But the red lights lights on the rear of the cabcar doesn't want to light up?

      The model isn't available in a ready state. My work is a mishmash of different things put together to make a set for an upcoming route update.

      I did look at the Tutorial. But lighting isn't my strong point still. Neither is SMS for that matter!

      I will send along the project for your investigation.

      Thanks.
      Robert

      Comment


        #4
        Hi Robert,
        Thanks mate - I'll reply to your PM.

        Cheers,
        Ged

        Comment


          #5
          Hi Robert,
          I've created a consist like yours with, in my case, a diesel locomotive at one end and a drivable carriage ( cab car) at the other.


          When the cab car is leading and the diesel is doing the "pushing" the cab car has two white marker lights on. When the cab car is being
          "pushed" (at the rear thus) it has two red marker lights on. I have the lights for the cab car configured as follows:

          Lights ( 4
          Light (
          comment( White marker light right )
          Type ( 0 )
          Conditions (
          Unit ( 2 )
          )
          FadeIn ( 0.5 )
          FadeOut ( 0.5 )
          Cycle ( 0 )
          States ( 1
          State (
          Duration ( 0.0 )
          LightColour ( FFFFFFFF )
          Position ( 1.4369 2.79 9.41521 )
          Azimuth ( 0.0 0.0 0.0 )
          Transition ( 0 )
          Radius ( 0.375 )
          Elevation ( 0.0 0.0 0.0 )
          )
          )
          )
          Light (
          comment( White marker light left )
          Type ( 0 )
          Conditions (
          Unit ( 2 )
          )
          FadeIn ( 0.5 )
          FadeOut ( 0.5 )
          Cycle ( 0 )
          States ( 1
          State (
          Duration ( 0.0 )
          LightColour ( FFFFFFFF )
          Position ( -1.4369 2.79 9.41521 )
          Azimuth ( 0.0 0.0 0.0 )
          Transition ( 0 )
          Radius ( 0.375 )
          Elevation ( 0.0 0.0 0.0 )
          )
          )
          )
          Light (
          comment( Red marker light right )
          Type ( 0 )
          Conditions (
          Unit ( 4 )
          )
          FadeIn ( 0.5 )
          FadeOut ( 0.5 )
          Cycle ( 0 )
          States ( 1
          State (
          Duration ( 0.0 )
          LightColour ( ffff0000 )
          Position ( -1.4369 2.91 9.41521 )
          Azimuth ( 0.0 0.0 0.0 )
          Transition ( 0 )
          Radius ( 0.275 )
          Elevation ( 0.0 0.0 0.0 )
          )
          )
          )
          Light (
          comment( Red marker light left )
          Type ( 0 )
          Conditions (
          Unit ( 4 )
          )
          FadeIn ( 0.5 )
          FadeOut ( 0.5 )
          Cycle ( 0 )
          States ( 1
          State (
          Duration ( 0.0 )
          LightColour ( ffff0000 )
          Position ( 1.4369 2.91 9.41521 )
          Azimuth ( 0.0 0.0 0.0 )
          Transition ( 0 )
          Radius ( 0.275 )
          Elevation ( 0.0 0.0 0.0 )
          )
          )
          )
          )

          NOTE... The lights positions on your consist will of course be different so ignore my settings. My cab car has two white marker lights when it is in the lead and two red marker lights when it is at the rear. Hope this helps. Regards - Robert Wouters.

          Comment


            #6
            Hi Mr Wouters,

            I've gotten my consist setup and working.

            Been chasing another issue though. Got a new post on that.

            Thanks.

            Robert

            Comment

            Working...
            X