Announcement

Collapse
No announcement yet.

Missing Number Boards

Collapse
Only viewable if you're a logged in user
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Missing Number Boards

    Hello all,

    I have the N&W Geep Pack from 3D Trains. I am trying to figure out why the number boards does not show when running in Open Rails. They do appear when running MSTS.

    Now, since all I use these days is Open Rails, is there some way to fix this?

    Thanks
    Kenny Open Rails 2024-01-31 06-35-42.jpg

    #2
    Don't know the answer, but checked and have the same issue. Appears a problem is with how the alpha on the A#_Alpha1.ace files are drawn, Note small windows on cab not transparent as well, and both using the same texture. It appears to me that the main shape using the A#_Main1.ace is a solid piece with the alpha added over it, and in MSTS and Shape Viewer they appear transparent over the solid, but in OR they don't ( note the red tint to the number boards and windows from the background texture, they should appear as a transparent blueish color ). I have seen similar issues with other transparencies on other models where one is placed over a solid. Don't know who to fix.
    Owner and CEO of Hart Rail Lines & Hart Commuter Railways, and Hart Rail Cars.
    It's my Train Sim world so I run HART RL anywhere I want.

    Comment


      #3
      Here is similar issue with the GG-1

      In MSTS: cab windows appear transparent over the main solid texture ( Left ) and in OR do not ( Right ):

      grg1041.jpg Open Rails 2021-04-22 05-00-39.jpg
      Owner and CEO of Hart Rail Lines & Hart Commuter Railways, and Hart Rail Cars.
      It's my Train Sim world so I run HART RL anywhere I want.

      Comment


        #4
        Thank you for the reply.

        I have a few models from 3D Trains but it seem's that these N&W Geep's are the only ones I have this problem with. Anyhow, after getting frustrated with these units, I decided to repaint a few of Gaétan Bélanger's Geep 9's. These turned out pretty decent.

        Still, I'd like to figure out the fix for the 3D Trains models.

        Kenny
        Open Rails 2024-02-03 09-09-13.jpg
        Open Rails 2024-02-03 09-08-00.jpg

        Comment


          #5
          I have the BN set with the same problem but only with one of the locomotives.
          I haven't figured it out.

          Randy

          Comment


            #6
            I was looking for a tutorial on prim_states and found this, which has the solution you're looking for

            I just got the 3DTrains GP7 / GP9 set. All the A#_Number.ace files have the number tran's out. I corrected the ace, but the engine number still does not show in Open Rails, It does show in shape viewer and it does show in MSTS though. Also, the front and rear cab windows do not see through into the cab also, but the side

            Comment


              #7
              Hi Yellowdog,

              I went into the shape file and changed all the prim state's as you have shown. I'm still not getting numbers. Im not quite sure about how I I did the ace files. I sent all three back to the TGA form then using aceit I used the format RGB +alpha (8bit alpha), MIP filter box, and to the right, the three boxes has use ZLib compression is checked.

              Have I done the ace's wrong?

              Kenny​

              Comment


                #8
                You have to edit the alpha channels in the tga files in image editing software (photoshop, paint shop pro, Gimp, etc). If something isn't showing, you probably need to change that part of the alpha channel to white

                Comment


                  #9
                  Here are the results of a semi-fix I did. Can't make the windows transparent, but was able to add the number boards to the A#-Main1.ace files so you see numbers. Not a perfect fit or size.
                  Open Rails 2024-02-05 08-20-57.jpg Open Rails 2024-02-05 08-59-53.jpg
                  Found the GP7s from Feather River used the same basic textures but with an alpha so the number board showed, and the window were transparent.. By pasting the alpha texture (B&W) over the A#_Main1 textures as transparent left the black marks, ( had to white-out two places where there were alphas for vents first ), Then I had to make a slight adjustment in placement to get the black spots centered,. Then added the white numbers and filled in the window white so they don't stand out as much being solid. Not in to trying to mess with the shape files.
                  Owner and CEO of Hart Rail Lines & Hart Commuter Railways, and Hart Rail Cars.
                  It's my Train Sim world so I run HART RL anywhere I want.

                  Comment


                    #10
                    Hey guys,

                    First of all, thanks for the suggestions on how to fix this problem. Yellowdog shared a thread from a couple years ago that I tried but was unsuccessful. I don't know if I did something wrong with the ace files or not. After a day or two I went back into the word pad edit to look at the required images for the shape and found this. Is there anything wrong with this?

                    images ( 23
                    image ( A1_Main2.ACE )
                    image ( A1_Alpha1.ACE )
                    image ( A1_Main1.ACE )
                    image ( A1_Cab.ACE )
                    image ( A1_Engineer.ACE )
                    image ( A1_Fireman.ACE )
                    image ( A1_Number.ACE )
                    image ( A1_Plate1.ACE )
                    image ( A1_Alpha3.ACE )
                    image ( A1_Fans5.ACE )
                    image ( A1_Alpha2.ACE )
                    image ( A1_Plate3.ACE )
                    image ( A1_Chain.ACE )
                    image ( A1_Fans2.ACE )
                    image ( A1_Wire2.ACE )
                    image ( A1_Flag.ACE )
                    image ( A1_Fans1.ACE )
                    image ( A1_Fans3.ACE )
                    image ( A1_Ring.ACE )
                    image ( A1_Plate2.ACE )
                    image ( A1_Fans4.ACE )
                    image ( A1_Plate4.ACE )
                    image ( A1_Wire1.ACE )
                    )
                    textures ( 24
                    texture ( 0 0 -1 ff000000 )
                    texture ( 1 0 -1 ff000000 )
                    texture ( 2 0 -1 ff000000 )
                    texture ( 3 0 -1 ff000000 )
                    texture ( 4 0 -1 ff000000 )
                    texture ( 5 0 -1 ff000000 )
                    texture ( 6 0 -1 ff000000 )
                    texture ( 7 0 0 ff000000 )
                    texture ( 8 0 0 ff000000 )
                    texture ( 9 0 0 ff000000 )
                    texture ( 10 0 -1 ff000000 )
                    texture ( 11 0 0 ff000000 )
                    texture ( 12 0 0 ff000000 )
                    texture ( 13 0 0 ff000000 )
                    texture ( 14 0 0 ff000000 )
                    texture ( 15 0 0 ff000000 )
                    texture ( 6 0 0 ff000000 )
                    texture ( 16 0 0 ff000000 )
                    texture ( 17 0 -3 ff000000 )
                    texture ( 18 0 0 ff000000 )
                    texture ( 19 0 0 ff000000 )
                    texture ( 20 0 -1 ff000000 )
                    texture ( 21 0 0 ff000000 )
                    texture ( 22 0 0 ff000000 )
                    )


                    Kenny

                    Comment


                      #11
                      ok guys, I did the L&N Geeps

                      Send me a private pm please who needs help with windows or number boards...............
                      Rick

                      http:\\mononrr.com

                      MONON-2

                      sigpic

                      Comment


                        #12
                        Here you go

                        Last edited by Rick-MONON; 02-08-2024, 10:30 PM.
                        Rick

                        http:\\mononrr.com

                        MONON-2

                        sigpic

                        Comment


                          #13
                          That's what we were looking for. Thank you. Checks in the mail.

                          Comment


                            #14
                            If any one else wants me to fix them for you, pm me.
                            Rick

                            http:\\mononrr.com

                            MONON-2

                            sigpic

                            Comment

                            Working...
                            X