Announcement

Collapse
No announcement yet.

MSTS Activity Editor problem

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    MSTS Activity Editor problem

    It has been some considerable time since I used the editor, and I have forgotten so much! I downloaded the Penzance to Plymouth route but I wanted to create my own consist. I chose a locomotive and duly proceeded to add passenger vehicles, only to be told that the couplings are incompatible. If I choose different passenger vehicles then I am told that I do not have a player driveable loco.

    Anyone please tell me where I'm going wrong?

    #2
    Hi 72Glory,
    You're not really going wrong anywhere, just not following the rules!
    MSTS expects all vehicles in a consist to have the same types of coupling, although it's not essential. If you're using ConBuilder, you can ignore the "wrong coupling" warning BUT you won't be able couple/uncouple any vehicles from the consist within the Sim.

    Also, you can't drive a loco which doesn't have a cabview. Perhaps you selected an AI loco (ie one with # as the first character in its name or contains 'AI' within its name)?

    Cheers,
    Ged

    Comment


      #3
      "MSTS expects all vehicles in a consist to have the same types of coupling, although it's not essential."

      Seems to me that it does; I have tried to build a consist of A Class 52 Western with Mk1 blue/grey coaches but the only coaches I can successfully build is only by using maroon Mk1 coaches. Also, a consist using a Class 50 with Mk 2 coaches results in incompatible couplings.

      It would be nice to use Conbuilder, but that program appears to be unavailable.

      Comment


        #4
        Originally posted by 72Glory View Post
        ...
        It would be nice to use Conbuilder, but that program appears to be unavailable.
        Available in the File Library ( two versions if you search for ConBuilder ) latest version:
        Microsoft Train Simulator - Utilities
        MSTS Utility--ConBuilder v2.4.9
        [ Download | View ]

        Name: cb249.zip
        Size: 12,939,922 Date: 05-13-2019 Downloads: 1,432

        MSTS Utility--ConBuilder v2.4.9. This version of ConBuilder is uploaded with the knowledge and agreement of Joe Smith. As such there is ABSOLUTELY NO SUPPORT. Unpack zip file to tempy folder and follow the instructions in Install_ReadMe.rtf. Uploaded by G. Saunders.
        Cheers, Gerry
        It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
        Forever, ridin' drag in railroad knowledge.
        Audi, Vide, Tace, Si Vis Vivere In Pace

        Comment


          #5
          There is a way to fix the different coupler in the .eng or .wag files without using Conbuilder,

          Coupling (
          Type ( Automatic )
          Spring (
          Stiffness ( 5e6N/m 5e6N/m )
          Damping ( 1e6N/m/s 1e6N/m/s )
          Break ( 5.4e7N 5.4e7N )
          r0 ( 20cm 30cm )
          )
          Velocity ( 0.1m/s )
          )

          Under coupling "Type" make sure you have the word Automatic for both locomotive and wagon couplers. The other 2 options "Bar" is used for permanently coupled cars like 3 & 5 unit doublestacks. But remember, the front of the A and rear of the B end must show Automatic so they can couple to the next car.. The other cars, C, D, & E should have Bar. The third option I never use is "Chain." Also, if your model has just 1 of the above example, either Bar or Automatic may be used as long as it is the same as the car you are coupling to. If your model has 2 of the above examples, remember the first example is the rear coupler and the second is the front coupler.

          To drive a non-driveable loco, install a Cabview file.

          AJ

          Comment


            #6
            After firing up AE after some considerable time, I find that certain features no longer work running under windows 10. Namely editing existing or creating new events (Action, time and location). AE just freezes and locks up. Is there a work around for this?
            Everything else seems to work ok.
            Cheers
            T
            Last edited by terryc; 04-13-2023, 01:58 PM.

            Comment


              #7
              Hi Terry,
              You haven't given much information!!

              Where is MSTS installed? If it's in the default location (C:\Program Files or C:\Program Files (x86)) you will have many problems.
              Is train.exe (and launcher.exe, if you use it) set to "Run as an administrator" (Properties > Compatibility). NO other Compatibility entries are required!

              Cheers,
              Ged

              Comment


                #8
                What version of Windows?

                Paul :-)

                Comment


                  #9
                  Thanks Paul and Ged,
                  As already mentioned, it's windows 10. msts is installed in C:Train Simulator.
                  The sim runs fine (administrator settings, and XP compatibility settings), and AE is fine for creating paths, services and new activities. The problem is only when trying to add or edit 'events'. All other aspects are ok. At the moment I'm transferring activities to an old XP machine, editing / adding location events there and then transferring the modified .act file back to my Win 10 machine, where the activity runs as intended. A bit long winded, but was trying to ascertain whether anyone else a) had come across this W10 issue, and b) found a simpler solution.
                  Cheers
                  T
                  Last edited by terryc; 04-13-2023, 04:36 PM.

                  Comment


                    #10
                    Problem solved (Thanks Ged!)
                    It was all down to my msts tools set to run in XP compatibility mode. Removed that constraint, and all is now fine!
                    Cheers
                    T

                    Comment

                    Working...
                    X