Announcement

Collapse
No announcement yet.

Error not seen before

Collapse
Only viewable if you're a logged in user
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error not seen before

    Friends,

    I have had the version 2 of Donner Pass for several years, i.e. the freeware version in the library. One thing bugs me about this route and that is, it does not include the original line over the pass which was abandoned by either UP or D&RGW (Anchutz) back iin the 1990s and I wished to add it, which was going well until today. I had to remove a few signals, mileposts, etc. and several forest objects and all through the editing process the editor frequently crashed. I assumed it was probably due to a high density of forest objects.

    Then today I noticed that when I would save, things seemed to go fine, but when I then exited, the editor would crash. This does not occur in TSRE and while a few errors are seen in the errors & messages, I cannot locate any of them. Then I find that MSTS crashes on startup before it ever gets to the selection pages. Again, ORTS works fine. I have completed all the track & 90% of the roads so future editing will involve mostly static objects. Since MSTS never gets to the selection pages, I do not know if the issue is a single route or something of a global nature.

    Increasingly I think my future routes are going to be ORTS/TSRE only.

    Any thoughts? I notice that my cloned installs work fine except that the crash on exit occurs on those with Donner Pass.

    J. H. Sullivan

    #2
    Have you run the route through Route-Riter?

    Paul :-)

    Comment


      #3
      Yes, Paul,, I have, several times and it turns up several missing .ace files etc., mostly for night or winter times. After allowing the copying of alternate files, here is the really short l ist.

      Texture file snow\footballfield1.ace was missing from your route, an alternative was used instead - K:\1MSTS\Routes\GMO IC CN\Textures\snow\footballfield1.ace
      Texture file snow\footballfield2.ace was missing from your route, an alternative was used instead - K:\1MSTS\Routes\GMO IC CN\Textures\snow\footballfield2.ace
      Texture file snow\fb_field.ace was missing from your route, an alternative was used instead - K:\1MSTS\Routes\GMO IC CN\Textures\snow\fb_field.ace
      Texture file snow\woodfarmhouse.ace was missing from your route, an alternative was used instead - K:\1MSTS\Routes\AU_NSW_SW_SS\Textures\snow\woodfar mhouse.ace
      Texture file snow\barntex.ace was missing from your route, an alternative was used instead - K:\1MSTS\Routes\AU_NSW_SW_SS\Textures\snow\barntex .ace




      ERRORS WERE NOTED, DO NOT COMPACT ROUTE UNTIL ANY MISSING FILES ARE REPLACED.

      Looks like these are all missing.ace file errors. TSRE turned up a number of signals not linked to world files and
      so I deleted those. Also a number of level crossing items which look okay and are working correctly.

      ICHK turned up a gazillion errors none of which mean anything to me, but I will forward you the error report
      which may have some meaning to you. There are a lot of missing shape files that appear to be some kind of
      track but I can't tell from the file name.

      Jerry
      Last edited by landnrailroader; 01-31-2023, 12:39 PM.

      Comment


        #4
        You use to be able to Google the missing files and find out what route they were in to try to find them but Google is much more interested in sponsored ads then searching.

        One thing you could so is to go into the SD file of the shapes you're having trouble with and change the Alternat Texture field from 252 to 0. That means the football field will still look like summer year round but it will eliminate the error.

        Could take a copy of the ace files and look for areas that should be snow covered and just place a snow texture over them in a photo editor, no different then changing the road number on an engine. Save it to the TEXTURES>SNOW file under the same name and lever the 252 in the SD file. You wound have to save the changed files as TGAs and then run them through AceIt.

        Paul :-)

        Comment


          #5
          I just let RR copy the existing daytime .ace file into the snow or night area but the error persisted.Usually when MSTS crashes before you select an activity there is an issue in the TRAINS directory but ICHK does not turn up any errors there, and I use the same Trains directories and files in other clone inistalls without an issue. I have all of my "under construction) and other routes backed up to an external drive so it may come down to reinstalling my main install where I do most of my new route creating or in this case "altering". I found TSRE to be useful, i.e. the error messages when I needed to do a rebuild on one of my own route, but first remove all interadtives etc. After looking around an manually deleting a dozen or so signals, I used TSRE to find the rest, quite easily.

          Comment


            #6
            Before you do any reinstalling...

            Cut and paste the Activities, Paths, Services, and Traffic folders from your route onto your desktop. Make new folders in your route's folder. Create a new test activity, make it simple, just an engine running the length of the mainline. See if there will work.

            Paul :-)

            Comment


              #7
              Paul,

              Just saw this tonight. I tried it but problem still exists, so then I thought I could simply move the whole
              donner route to a holding pen so to speak and see what happens. Did that and now MSTS does what it is
              supposed to do, so there is some issue not related to activities etc. that is the problem. RE and AE still
              do fine and so when the route is released, I will point out these issue and claim it to be ORTS only as far
              as operating it.

              Jerry

              Comment


                #8
                Strange thing happen with MSTS. I'm working on a route that I stated years ago. I can do whatever I need to do in MSTS RE and as I go along I can open the route and do a TDB rebuild. A few days ago I moved the starting tile. Once I was finished working I tried a TDB rebuild before making a backup copy and it wouldn't visit every tile. I check the error messages in TRSE and there were 19. I ran the route through Route-Riter and it said there were no errors. Took me three days of trying to figure out what was wrong with the route and just happened to move the starting tile back to were it was and was able to to a TDB rebuild and TSRE showed no errors. How can that be... I have it down to being a Microsoft product!

                Paul :-)

                Comment


                  #9
                  HI Paul,
                  I am not a route builder so most of this goes above my head, but have you checked Steam4Me?


                  It may help you!

                  Cheers,
                  Ged

                  Comment


                    #10
                    Thanks Ged,

                    I did look at this the other day but it's really just how to change starting tile locations and which I've been doing regularly while route building since the FJ&G days back about 14 years. Vince said way back then that doing this could cause problems and it never did until this route. So now I have a copy of the TRK on my desktop and have to remember to change the starting tile every time I want to run a TDB rebuild and say the route to an archive, then go back and change my starting tile to my work area.

                    I did a Google search to see of there was an explanation and solution but never found anything. I was hoping someone here had the same problem and knew what to do.

                    Paul :-)

                    Comment


                      #11
                      Ged,
                      Paul,

                      The good news in all this, is that including me, there are still a few of us that are deranged some way, or who drink some
                      strange KoolAide, that just keeps us insanely creating new routes. Guess it will continue until either we move to our next
                      life, or some operating systems comes along that just will not allow legacy software. I did my first route in 2003, very
                      crude by my standards now, and there are things in this Donner route that I would never do now. Plenty of gradient
                      changes of .15 and in one case .3 between track pieces for example.

                      Jerry
                      aka landnrailroader

                      Comment

                      Working...
                      X