Announcement

Collapse
No announcement yet.

Active Environment Work for Open Rails

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Active Environment Work for Open Rails

    Hi Folks,

    RE: http://www.elvastower.com/forums/ind...me-terragen-2/

    Just a heads up for those that don't go over to Elvas often.

    For the past couple weeks - James Ross - has been actively working on improving the environment in Open Rails. He's corrected the skydome distortion that makes clouds painted on the skydome wavy - very noticeable on the 10K skydome I shared. He's flattened the clouds01 hemisphere which adds to the perception of distance if you use a clouds01 layer. He's working on cleaning up the code - addressing the lighting/sunrise/sunset - etc etc etc. It's the first major overhaul the environment has had in many years and his planned work seems very promising.

    If you want to try any of this - you can simply load the latest "Unstable" version of ORTS to see the work in progress.

    The link above is where the changes are being actively discussed.

    Regards,
    Scott
    <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

    #2
    Hi Scott,

    I certainly hope that James Ross extends the cloud layer to well below the horizon. As it sits now it is unacceptable. I am running the latest OR unstable version.

    Peter

    Comment


      #3
      Thank you for the heads up.

      Comment


        #4
        Originally posted by peterman View Post
        Hi Scott,

        I certainly hope that James Ross extends the cloud layer to well below the horizon. As it sits now it is unacceptable. I am running the latest OR unstable version.

        Peter
        Hi Peter,

        IIRC - James mentioned extending the "skydome" like 6 degrees further than they were. I haven't noticed any issues. Can you post a pix and route so he has a better idea of what's happening. Is this the "skydome" or the "clouds01" giving you an issue?

        Regards,
        Scott
        <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

        Comment


          #5
          Originally posted by gammaray84 View Post
          Thank you for the heads up.
          Happy to help.

          Regards,
          Scott
          <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

          Comment


            #6
            I hope this get integrated into MG, as that is all I have been using. I am still unclear as to how the two jive together with ongoing developments.
            Neil

            Chicago Railroading Fan

            Comment


              #7
              Originally posted by scottb613 View Post
              Hi Peter,

              IIRC - James mentioned extending the "skydome" like 6 degrees further than they were. I haven't noticed any issues. Can you post a pix and route so he has a better idea of what's happening. Is this the "skydome" or the "clouds01" giving you an issue?

              Regards,
              Scott
              Hi Scott,

              This image should be self-explanatory. Double click to enlarge it.

              Peter

              Open Rails 2023-01-18 12-49-16.jpg

              Comment


                #8
                Originally posted by qballbandit View Post
                I hope this get integrated into MG, as that is all I have been using. I am still unclear as to how the two jive together with ongoing developments.
                Hi Neil,

                I'm with you - I've been running the "Unsupported" version for the past few weeks for testing and I miss Monogame/ReShade - and all the extra enhancements in Carlo's version. One of the most glaring issues for me is they haven't incorporated Carlo's fix for flashing "Transfers" - but like you - I don't know what determines which features are passed back and forth.

                Regards,
                Scott
                <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

                Comment


                  #9
                  Originally posted by peterman View Post
                  Hi Scott,

                  This image should be self-explanatory. Double click to enlarge it.

                  Peter

                  [ATTACH=CONFIG]83947[/ATTACH]
                  Hi Peter,

                  Thanks - I'll pass it along.

                  Regards,
                  Scott
                  <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

                  Comment


                    #10
                    Hi Scott,

                    After reading the thread that you posted the link for, it seems to me that Open Rails uses more of the Environ files than we thought. Perhaps there is a parameter in the sky layers in those files that could be altered. I'll have to check it out tomorrow.

                    Peter

                    Comment


                      #11
                      Howdy,

                      Just a quick up-date... I ran a few activities today in Open Rails with the MSTS Environment checked and all looked as it should with no gaps between the cloud layer and horizon, which seems to tell me that Open Rails does read the parameters in the Environ files correctly. I have to admit, I was highly impressed with the positives of having MSTS Environment checked as compared to 7-8 years ago when it looked like crap. Another test I did was to run with MSTS Env unchecked and the weather randomization set to zero and it produced the gap again. This gap issue is not new and has been around for quite a while. I hope the OR development team digs into their coding for a solution.

                      Peter

                      Comment


                        #12
                        Hi Peter,

                        Thanks for the update. Yeah - the few times I checked "Use MSTS Environment" - I didn't notice anything helpful and it looked bad. I haven't tried that option in years - I'll have to take a look again. I don't think James is looking over here (I'm just happy he's looking) - it seems everyone is using that thread on Elvas to work on this - I'd suggest posting any feedback over there - so he sees it.

                        Regards,
                        Scott
                        <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

                        Comment


                          #13
                          Good morning Scott,

                          I'm going to retract my statement about "highly impressed with the positives". I tried other .ace files that had heavy clouds and they still look like crap, however those with few clouds were still pretty good. Use "check MSTS Environment"?... take a pass on it.

                          Peter

                          Comment


                            #14
                            Originally posted by peterman View Post
                            Good morning Scott,

                            I'm going to retract my statement about "highly impressed with the positives". I tried other .ace files that had heavy clouds and they still look like crap, however those with few clouds were still pretty good. Use "check MSTS Environment"?... take a pass on it.

                            Peter
                            Hi Peter,

                            Hah - understood. I was never really impressed with any MSTS environment. The only one I liked and used for everything was the one from the "Badlands Project" - I used it for many years.

                            Regards,
                            Scott
                            <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

                            Comment

                            Working...
                            X