Announcement

Collapse
No announcement yet.

Protrain pantograph in ORTS

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Robkeb
    replied
    Thanks Uli, for your link to the tssf forum. It's been a while since I visited that forum, but Jan helped me out with the pantograpf issue.

    Leave a comment:


  • Robkeb
    replied
    Thanks all of you for helping me out. I’m not at home yet, so can’t login at the tssf forum, but will have a look later.

    Leave a comment:


  • uli2
    replied
    @Robkeb

    Anomalies regarding the pantograph animation in Open Rails have been reported for some vintage Protrain models (some versions of BR 143, BR 185): https://tssf.eu/forum/thread/11297-b...?postID=184592 . They are caused by wrong (misnamed) entries in the model's shape file and are not specific for the OR version you are using. You are more likely to find concrete solutions for your problem if you post it on the German forum and refer to the specific model(s) you are having a problem with. They speak English.

    Leave a comment:


  • gammaray84
    replied
    Moving pantograph is one of the "anomalies" that are present when using MSTS legacy files. The older the product is, more chances are these "anomalies" will be present.

    Solutions to these different "anomalies" are diving into animation and shape files, either try to fix it or disable animation...

    For your specific problem about pantographs moving while driving, the solution would be to disable that animation completely. Pantos need to be always up anyways while operating engine.

    Good Day

    Leave a comment:


  • R. Steele
    replied
    That bug ( reported fixed in June 2013 ) appears to describe what you are observing in ver 1.5.1. I would report your experience as a bug, attaching a log and also referencing the bug fix in 2013.

    My stable Ver 1.5 shows as ver. 1.5-rc1 -- which I believe is the same as stable version 1.5.1 ( honestly sometimes I have trouble keeping all the OR branches/versions and how they are organized straight in my mind ).

    You can download the newest unstable ( automatic builds ) here >>> https://james-ross.co.uk/projects/or/builds

    Monogame builds here ( site is good despite various virus program warnings ) >> http://www.interazioni-educative.it/Downloads/index.php

    Organizational chart of various versions of Open Rails >> http://openrails.org/download/versions/

    Leave a comment:


  • Robkeb
    replied
    Thanks for replying. Do I understand correctly that version 1.5.1 isn't a stable version?

    I know how to uncompress a shape file and edit it with a text editor. I'd hoped to find a solution there. I found this: https://bugs.launchpad.net/or/+bug/1187880, but am not sure this is what I mentioned. The item on that link was solved in an earlier version of ORTS.

    Leave a comment:


  • R. Steele
    replied
    Understand, this is not something I know anything about...but from what I've read in the forums -- because the pantograph movement seemingly is tied to the speed of the train --- that it may have something to do with how the pantograph animation is modeled in this particular instance.

    Just in case, to test if the problem is with OR, you should see if you observe this behavior in the Unstable, Monogame version or a previous Stable version.

    Leave a comment:


  • Robkeb
    started a topic Protrain pantograph in ORTS

    Protrain pantograph in ORTS

    Could anyone tell me something about the fact that (especially) Protrain electric engines have their pantograph moving up and down while driving? The faster you drive, the faster the pantograph moves. I'm using ORTS 1.5.1

    Thanks,
    Rob
Working...
X