Announcement

Collapse
No announcement yet.

All my Track is Gone !!!

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    All my Track is Gone !!!

    I must have screwed up somewhere. Most of my routes have lost their track. The trains are sitting on grey stripes where roadbed, etc. should be. All the routes that are missing track reside in the ORTS root “Route” folder. The only routes unaffected are Trainsimulations Seligman payware and the free starter route.
    In a desperate attempt to fix the issue I ran the Open Rails installer (In hopes there was a corrupt/missing fie) and put the latest tsection.dat file in the Global directory. NO LUCK.
    What do you guys think is wrong??

    Freeware
    No track Surfliner 2.2
    No track SOCAL
    No track Monon
    No track Milwaukee Road-Coast Division = First Sub
    No track Milwaukee Road Mountain Div East: Subs 1&2
    No track Milwaukee Road Mountain Div East: Subs 3&4
    No track Norfolk Southern Route (Horseshoe Curve)

    Track visible TS - StarterRoute
    Payware
    Track visible WP3 Feather River Route (installed in separate folder)
    Track visible TS - BNSF Seligman for Open Rails

    No track Maple Leaf Tracks Willamette Pass Cascade Route

    Last edited by lvlender; 05-26-2024, 10:40 PM.

    #2
    Sounds like whatever route you installed, more than likely a TS route, overwritten the original global folder for the shape files to search for .DDS textures directly, versus .ace files.

    A sort of easy fix for this, is to reinstall the FRC route, it won't cure it all, but it will help, and is sort of an easier solution.
    ​​​​​​
    -Shawn K-
    Derby Rail Shops
    Maine Central Mountain Division: 20% Track, 10% Scenery.

    Comment


      #3
      Download my replacement tracks (ATracks). That should fix Surfliner and the Milwaukee routes.

      There's a discussion going over at Elvas on this, but I thought I'd share some of what's going on... a few of us are tackling replacement default track shapes for the A1T's commonly used with XTracks and the default routes. This replacement project will come out to a couple thousand shapes by the time all is said and done.
      If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

      Comment


        #4
        Originally posted by lvlender View Post
        I ran the Open Rails installer (In hopes there was a corrupt/missing fie)
        No need to do this, the Open Rails installer only installs the current stable basic version of Open Rails ( as of this date ver 1.5.1 ) and any operating system dependencies needed to run the OR executable file. No tracks, or anything else is installed.

        NOTHING else should be installed - or - kept in the same folder as the Open Rails exe files....NO TRAINSETS, ROUTES, NOTHING. If you automatically update OR it will erase everything in the folder.
        Cheers, Gerry
        "A mind is like a parachute. It doesn't work if it is not open." Frank Zappa
        It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
        Forever, ridin' drag in railroad knowledge.
        Audi, Vide, Tace, Si Vis Vivere In Pace

        Comment


          #5
          Originally posted by R. Steele View Post
          NOTHING else should be installed - or - kept in the same folder as the Open Rails exe files....NO TRAINSETS, ROUTES, NOTHING. If you automatically update OR it will erase everything in the folder.
          No worries R.Steele,

          I am aware that the Open Rails directory is separate from the TrainSimulations directory. Thanks, friend, for reminding me, though 😁

          Comment


            #6
            Originally posted by lvlender View Post
            Thanks, friend, for reminding me, though
            No worries, you'd run out of fingers and toes counting the number of times folks have installed stuff in the OR program folder, only to have it wiped out when they auto update. Happy to know you've got it covered.
            Cheers, Gerry
            "A mind is like a parachute. It doesn't work if it is not open." Frank Zappa
            It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
            Forever, ridin' drag in railroad knowledge.
            Audi, Vide, Tace, Si Vis Vivere In Pace

            Comment


              #7
              Originally posted by eric View Post
              Download my replacement tracks (ATracks). That should fix Surfliner and the Milwaukee routes.
              Hi Eric,
              Thanks for your suggestion of ATracks but, I'm not real techie on train simulations, yet. I still don't know what I did today to erase the track for so many routes. Everything was fine until about five pm this afternoon and then, BLEWEY !


              As an experiment, I chose one of the affected routes, Monon-2. I completely deleted my Monon-2 Ver.17 route and reinstalled it. The instructions said to install X-track. I did and tested the route. The area where the tracks were supposed to be display show up mostly grey with a bit spotty track sections. Funny the yard has some track but, the main line is blank. Apparently, an erase and full reinstall is not the answer.

              I then installed Scalerail Ver1.77 along with the common textures inserted into the Mono-2/textures folder. Started route again but, it showed no improvement.

              If I attempt an install of your ATrack system I can pre-delete ScaleRail (if recommended) but, I don’t have a way to delete X-track. Do you think your ATrack system will work if X-Track is still in the Global folder?

              I don’t know what I’m doing or how things got screwed up.


              Click image for larger version  Name:	Open Rails 2024-05-27 01-02-27.jpg Views:	0 Size:	52.4 KB ID:	2304070

              Comment


                #8
                No need to uninstall tracks, but install the replacement tracks. According to the screenshot there are textures for the tracks missing in the route. OpenRails substitutes missing textures with default textures, there in gray. Install the track textures you like. See also the OpenRailsLog.txt file that will tell you anything about missing things.

                Comment


                  #9
                  Question. Are your freeware and TS routes in separate folders? In other words, they are not all in the same root folder?
                  Beer is not a matter of life or death, it is much more serious than that.

                  Comment


                    #10
                    Your OpenRailsLog will show what textures are missing if they're indeed missing.
                    Last edited by eric; 05-27-2024, 10:10 AM.
                    If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                    Comment


                      #11
                      Originally posted by lvlender View Post
                      If I attempt an install of your ATrack system I can pre-delete ScaleRail (if recommended) but, I don’t have a way to delete X-track. Do you think your ATrack system will work if X-Track is still in the Global folder?
                      ATracks is not a ScaleRail replacement --- it's a drop-in XTracks replacement. The new shapes replace the 2001-2004 era Kuju and XTracks shapes.
                      If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                      Comment


                        #12
                        Originally posted by baldwin View Post
                        Question. Are your freeware and TS routes in separate folders? In other words, they are not all in the same root folder?
                        My first route install was the freeware TS-Starter Route. I installed to my D drive. It installed as follows... d:/Trainsimulations

                        Being ignorant of train sims I installed every other route, be it payware or, freeware into the Trainsimulations directory. The only exception was WP3 Feather River V1.6. That I installed in a dedicated folder totally separate from the other routes ( only just learned this install method a few days ago).

                        What do you recommend?

                        Comment


                          #13
                          Originally posted by eric View Post

                          ATracks is not a ScaleRail replacement --- it's a drop-in XTracks replacement. The new shapes replace the 2001-2004 era Kuju and XTracks shapes.
                          Replacement for X-tracks? Sounds promising. I'll try it and report back.

                          Comment


                            #14
                            Originally posted by lvlender View Post
                            Being ignorant of train sims I installed every other route, be it payware or, freeware into the Trainsimulations directory.
                            That's the root of your problem there --- you cannot mix non-TrainSimulations routes with anything other than TrainSimulations routes.

                            Take all of those others, including any that were from Streamlines, and put them in the same parent folder as your WP3 (Feather River) route.
                            If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                            Comment


                              #15
                              Originally posted by eric View Post
                              and put them in the same parent folder as your WP3 (Feather River) route.
                              Okay Eric,
                              I'll reinstall all the non-Trainsimulations routes into WP3.I'll let you know the results later. This is going to take all day...

                              Comment

                              Working...
                              X