Announcement

Collapse
No announcement yet.

New rail section issue

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New rail section issue

    Hi, just coming back to experimenting with new tracks but have a small(?) issue.

    Click image for larger version

Name:	tsre_1.jpg
Views:	2601
Size:	115.8 KB
ID:	2305186
    The (TDB reference?) extends past the 5m section when placed.

    Click image for larger version

Name:	tsre_2.jpg
Views:	180
Size:	114.0 KB
ID:	2305187
    When selecting the section to place the bounding box seems ok.

    Click image for larger version

Name:	tsre_3.jpg
Views:	189
Size:	105.4 KB
ID:	2305188

    I'm sort of learning by starting with a blank and simple tsection.dat and adding pieces as I go. I've posted it in case something is wrong there.

    If anyone knows how to solve, please enlighten me, thanks!

    #2
    Nothing has ever been tested with a blank tsection.
    I would suggest that you start with the original msts tsection as a minimum.

    Comment


      #3
      The values in the sectionIdx are both referring to your 10m section.

      I believe the values in the sectionIdx should be:
      • Path count
      • x offset
      • y offset
      • z offset
      • angle
      • section ID
      • additional section IDs when path count greater than 1

      For the 5m section try: sectionIdx (1 0 0 0 0 1)
      Last edited by eric; 06-08-2024, 09:31 PM.
      If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

      Comment


        #4
        Hola:

        Pienso que el error esta en las lineas SectionIdx.
        Te adjunto las corregidas:

        TrackShapes ( 2
        TrackShape ( 0
        FileName ( al_ballast-h1_10m-str.s )
        Numpaths ( 1 )
        SectionIdx ( 1 0 0 0 0 0 )

        TrackShape ( 1
        FileName ( al_ballast-h1_5m-str.s )
        Numpaths ( 1 )
        SectionIdx ( 1 0 0 0 0 1 )

        Un saludo​

        Comment


          #5
          Yep, that's done it, now I see I haven't referenced the corresponding TrackSection through the TrackShape. Cool, thanks! Now a few straights done, now to attempt curves in Blender.

          Originally posted by derekmorton View Post
          Nothing has ever been tested with a blank tsection.
          I would suggest that you start with the original msts tsection as a minimum.
          I just wanted to experiment and try my hand at a clean slate and add my track sections as I make them in Blender and have a testing version, makes testing in TSRE little simpler also.

          Comment

          Working...
          X