Announcement

Collapse
No announcement yet.

Consists created in TSRE tend to crash the MSTS Editors & Tools

Collapse
Only viewable if you're a logged in user
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Consists created in TSRE tend to crash the MSTS Editors & Tools

    This is just SO strange. I created a consist in the MSAE, it works fine in OR and doesn't crash MSAE. The same consist, every single engine/coach unchanged, when created with TSRE crashes the MSAE every time.

    #2
    Post then both here

    Comment


      #3
      Here they are: CONSISTS.zip

      Comment


        #4
        SIMISA@@@@@@@@@@JINX0D0t______

        Train (
        TrainCfg ( "Consist using TSRE"
        Name ( "Consist using TSRE" )
        Serial ( 1 )
        MaxVelocity ( 34.72160 0.25000 )
        NextWagonUID ( 27 )
        Durability ( 1.00000 )
        Engine (
        UiD ( 4 )
        EngineData ( HowrahWAM4 VijayLocos )
        )

        Remove the name line at line 5 above and the tsre con file will work with MSTS.

        Comment


          #5
          I do not have the rolling stock so I created a Consist with TSRE using the same file name and description name. No Problem. Consist appeared in the MSTS AE consist editor.

          What version of TSRE are you using?

          I was using TSRE v0.698
          Upgraded to version v0.7001

          NOW I can duplicate your problem.

          It is verion .7 of TSRE CE

          Posted problem on TSRE Support forum
          Last edited by crstagg; 08-07-2021, 10:02 AM.
          Charles

          Comment


            #6
            I would not have thought the Name line would have anything to do with it?
            Cheers, Gerry
            It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
            Forever, ridin' drag in railroad knowledge.
            Audi, Vide, Tace, Si Vis Vivere In Pace

            Comment


              #7
              Originally posted by crstagg View Post
              I do not have the rolling stock so I created a Consist with TSRE using the same file name and description name. No Problem. Consist appeared in the MSTS AE consist editor.

              What version of TSRE are you using?
              Using the latest version, v0.7.002 x64.
              [NEW] If I create a consist with the MSAE, and modify the same using using TSRE, it works fine.

              Comment


                #8
                Originally posted by Hidetoshi6721 View Post
                Using the latest version, v0.7.002 x64.
                [NEW] If I create a consist with the MSAE, and modify the same using using TSRE, it works fine.
                No offense, but it sounds as if you like running down rabbit holes...why even bother with the MSTS AE or comparing it to TSRE-CE just use the TSRE-CE or try the ConBuilder version that was uploaded to the library.
                Cheers, Gerry
                It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
                Forever, ridin' drag in railroad knowledge.
                Audi, Vide, Tace, Si Vis Vivere In Pace

                Comment


                  #9
                  Originally posted by R. Steele View Post
                  No offense, but it sounds as if you like running down rabbit holes...why even bother with the MSTS AE or comparing it to TSRE-CE just use the TSRE-CE or try the ConBuilder version that was uploaded to the library.
                  The only reason is, I struggle with the TSRE Activity Editor. Routes having a lot of objects when loaded in the TSRE Route Editor, lag like hell. Also, I've noticed many bugs, e.g. sometimes stations appear twice. Sometimes when I select to stop at certain stations, they are different when I load the same act again. So, I still use the MSAE. Bad or broken consists are a curse to the MSTS E&T, which we all know

                  Comment


                    #10
                    Originally posted by Hidetoshi6721 View Post
                    The only reason is, I struggle with the TSRE Activity Editor. Routes having a lot of objects when loaded in the TSRE Route Editor, lag like hell. Also, I've noticed many bugs, e.g. sometimes stations appear twice. Sometimes when I select to stop at certain stations, they are different when I load the same act again. So, I still use the MSAE. Bad or broken consists are a curse to the MSTS E&T, which we all know
                    Sorry, my reply was nonsensical ... You are talking about the activity editor, I was off topic referring to the Consist Editor...apologies.

                    You know you can make activities manually using an Editor ( Notepad++ or Context ) and an existing activity as a template. You can make paths using the OR TrackViewer.

                    I've made activities like that for some time...for placing loose consists ( static consists ) --- if the route has an Activity Template you make up an activity using "Activity Generator" and then copy the Activity Objects from that activity to your template. It's not all that hard.
                    Cheers, Gerry
                    It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
                    Forever, ridin' drag in railroad knowledge.
                    Audi, Vide, Tace, Si Vis Vivere In Pace

                    Comment


                      #11
                      Originally posted by Hidetoshi6721 View Post
                      The only reason is, I struggle with the TSRE Activity Editor. Routes having a lot of objects when loaded in the TSRE Route Editor, lag like hell...........................snip............... ...
                      I've found that this TSRE setting set to 1 shadowsEnabled = 0 caused noticeable lag on my system. I don't know if it applies to the Activity though.

                      regards,
                      ............Vince ..............
                      ...... Author NECv4 .......
                      .... LIRR BUILD PHOTOS ....
                      ...... Eschew Obsfucation ......

                      On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
                      "Give me your tired, your poor, your huddled masses yearning to breathe free,
                      the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
                      I lift my lamp beside the golden door!"

                      Comment


                        #12
                        Originally posted by Vince View Post
                        I've found that this TSRE setting set to 1 shadowsEnabled = 0 caused noticeable lag on my system. I don't know if it applies to the Activity though.

                        regards,
                        Did it way long ago. shadowsEnabled when set to 0, does not display shadows in TSRE. That improved performance massively. Even with shadows turned off, TSRE lags a lot. I'll be following Gerry's idea for my acts. Works well

                        Comment


                          #13
                          Originally posted by R. Steele View Post
                          I would not have thought the Name line would have anything to do with it?
                          Actually it looks like it's the traincfg line which should be that same as the filename, is actually "Consist using TSRE" as above.
                          But the OP have not answered my post.

                          Comment


                            #14
                            I have found out some months ago that MSTS Activity Editor cannot handle railroad stocks using only DDS textures while there is no such issue with TSRE. If you have such rolling material with only DDS textures, If you need to use the MSTS AE, make sure to convert DDS textures to ACE ( works with AceIt) and remove the DDS textures from your folder before opening the MSTS AE (make backups of these folders before deletion). Once the work done with the MSTS AE, you can re-install these folders for running your activities.

                            This is how I have done the Trainsimulations' CN Ruel sub template for Activity Generator (AG). It was a long process but it worked.

                            Hope this helps

                            Denis

                            Comment


                              #15
                              Originally posted by dgionet View Post
                              I have found out some months ago that MSTS Activity Editor cannot handle railroad stocks using only DDS textures while there is no such issue with TSRE. If you have such rolling material with only DDS textures, If you need to use the MSTS AE, make sure to convert DDS textures to ACE ( works with AceIt) and remove the DDS textures from your folder before opening the MSTS AE (make backups of these folders before deletion). Once the work done with the MSTS AE, you can re-install these folders for running your activities.

                              This is how I have done the Trainsimulations' CN Ruel sub template for Activity Generator (AG). It was a long process but it worked.

                              Hope this helps

                              Denis
                              I appear to have a problem getting the new consist editor to work at all, with any of my installations (I have 4). I can get Conbuilder to work fine, but the NAVS and rolling stock created for OR only doesn't show up. I'd like to get the TSRE based consist editor working, but it freezes when I start it, regardless of the Open Rails install I'm using,
                              Steve Burr, PE - Clinton, MD
                              Southern Serves the South

                              Comment

                              Working...
                              X