Announcement

Collapse
No announcement yet.

TSRE5 Consist Editor not Loading Properly

Collapse
Only viewable if you're a logged in user
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    TSRE5 Consist Editor not Loading Properly

    Hello, I am having an issue with the TSRE5 Consist Editor. It opens to the input screen, but when "Load" at the bottom is clicked it does nothing, then says "Not Working" and eventually closes. I have Version 0.7.002 from the Koenig Site.
    It was working fine before I had to do a purge on my desktop, now only the Route Editor portion works properly. There is certainly something amiss, with the one portion working and the other not.
    After downloading this latest version, now I click on Consist Editor, the DOS Screen shows up (Says ....Conedit) but it now opens the Route Editor! How do I get it to point to the Consist Editor?? The Route Editor works as it should and opens and functions properly.
    I really like the Consist Editor and would like to have it back.

    #2
    Originally posted by Don6218 View Post
    Hello, I am having an issue with the TSRE5 Consist Editor. It opens to the input screen, but when "Load" at the bottom is clicked it does nothing, then says "Not Working" and eventually closes. I have Version 0.7.002 from the Koenig Site.
    It was working fine before I had to do a purge on my desktop, now only the Route Editor portion works properly. There is certainly something amiss, with the one portion working and the other not.
    After downloading this latest version, now I click on Consist Editor, the DOS Screen shows up (Says ....Conedit) but it now opens the Route Editor! How do I get it to point to the Consist Editor?? The Route Editor works as it should and opens and functions properly.
    I really like the Consist Editor and would like to have it back.

    Quoting from the TSRE manual (the file named "Book.pdf") in your folder where TSRE5 is installed:
    The Consist Editor is a built-in part of the TSRE5 application. It is enabled by supplying a command line
    option to TSRE5 when the program is started. This option contains the value of "--conedit". This is step
    that is accomplished by the supplied ConsistEditor.bat file.
    • To use the Consist Editor you must have a version of TSRE5 that is V0.6124 or higher.
    • You need to edit the settings.txt file and set the path to your MSTS/OR routes/trains directory,
    Example: gameRoot = F:/train simulator
    • You run the ConsistEditor.bat file from the command line or you can use Windows Explorer to copy
    the ConsistEditor.bat file and then use "Paste Shortcut" to save it to your desktop. You can then use
    the new desktop icon to start the Consist Editor.
    Charles

    Comment


      #3
      Here is a Screen shot of what I have and the result of clicking on that Consist Editor line. It brings up the Route Editor even though the dos window says ConEdit.
      Con Editor Issue.jpg

      Comment


        #4
        Yes the entry menu is the same as the one for the RE. Just choose which mini-install to use and click load.
        Charles

        Comment


          #5
          Mini-install??? I go to the bar above the listing and Consists or ConEdit are not an option.

          Comment


            #6
            Originally posted by crstagg View Post
            Yes the entry menu is the same as the one for the RE. Just choose which mini-install to use and click load.

            The CE opening menu looks just like the RE menu except the CE menu lists, below the default install, all your Installs of MSTS/OR content. Where as the RE lists the Routes in the selected Install.

            I did not have version 7.002 EXE file so I had to download and replace the 7.001 EXE just to test to see that the ConsistEditor.bat file worked correctly. After renaming TSRE5_v0.7.002.exe to TSRE5.exe. I ran the BAT file and it opened the CE correctly.

            Note I renamed the EXE from TSRE5_v0.7.002.exe toTSRE5.exe
            because the Bat file has as its contents:
            TSRE5.exe --conedit

            I also always rename the replaced EXE as "TRSRE5_previous ver #.exe So I can go back if i find problems.
            Note this Thread and my post #5: https://www.trainsim.com/vbts/showth...87#post1989587
            A bug created between V0.698 and v0.7 causes this problem. Will have to check if 0.7002 corrected this.

            FYI the Lists of MSTS/OR content installs is maintained by TSRE in a text file named cerecent.txt
            Easiest way to populate the list is just create the cerecent.txt file with Notepad.
            Mine looks like this:
            a:\msts
            a:\sh-orts
            a:\msts-test
            a:\wp3
            a:\wp3-raw
            a:\3dtrains test bed
            a:/orts-mini - test
            a:\wp3 - copy
            a:/siskiyou
            a:\trainsimulations
            (Blank line with carriage return)
            Charles

            Comment


              #7
              Hey, I am not sure what I did, but I uninstalled what I had just installed, except for the Icon folder that came from somewhere. I reinstalled another download, this time using Microsoft-Bing instead of Google and with the minor change of renaming TSRE5 everything is now working.
              Thank you all for your prompt responses. I find that the "Manual" is not really easy to use in that any search must be very accurate to get to where you need to be. But with that said, great job all on a great program that IS easy to use.

              Comment


                #8
                Consist editor error

                My consist editor is not loading, I have selected the directory but I have no option to load.

                Comment


                  #9
                  Originally posted by brandond100 View Post
                  My consist editor is not loading, I have selected the directory but I have no option to load.

                  Is the selected folder displayed in Green or Red in the line above the line that says "Choose Folder that contains 'Trains' above...."?
                  Charles

                  Comment


                    #10
                    The selected folder is displayed in green. I have no options like load or exit showing at the bottom.

                    Comment


                      #11
                      Originally posted by brandond100 View Post
                      The selected folder is displayed in green. I have no options like load or exit showing at the bottom.
                      Cannot help you then. Experimenting I have found that if the selected folder has a Trains sub-folder then it displayed in green and there was a LOAD button. But when the selected folder did not have a Trains sub-folder then the folder displayed in red and there was no Load button. So there must be some other criteria. Does the Trains sub-folder of your selected folder have sub-folders of Consists and Trainset?
                      Charles

                      Comment


                        #12
                        My train folder has consists and trainset. I am getting a very weird error as the entire bottom portion of TSRE5 is black and there is no option to load or exit.

                        Comment


                          #13
                          Hi brandond100,
                          if you've got the 'root' folder displayed in green, look towards the bottom of the screen.

                          There you should see a line "Consists:" showing the number of consists found and, below it, a line "Rolling Stock:" showing the number of stock folders (dirs). Below that should be a long green bar with "Load" at its centre and a short red bar with "Exit" at its centre.

                          Maybe if you've got the screen resolution set to some 'odd' value, you may not see the bottom of the display, in which case, you'll need to scroll up! If that's not the case, exactly what do you see as the bottom 3 lines of the screen? Also, which version of TSRE are you using (it's shown at the very top left of the screen)?

                          Cheers,
                          Ged

                          Comment


                            #14
                            The screen is just black at the bottom. I have a screenshot too, but I have no idea how to share it here. I have tried using the latest version of TSRE5 as well as some older version too, but same issue persists.

                            Comment


                              #15
                              Thanks for the advice. I changed the resolution and now I am able to load the route. I have created and saved consists using TRSE5 ,but unable to view them in open rails.

                              Comment

                              Working...
                              X