Announcement

Collapse
No announcement yet.

New Route Editor

Collapse
This topic is closed.
X
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Tried downloading this new file, and AVAST came up with a possible malware detection. Is this file safe?
    Rory

    Comment


      yes.
      Neil

      Chicago Railroading Fan

      Comment


        For some reason loading the map files as tertex files crashes the route editor.. did I done goof somehow? I have the key and required url added in the settings.txt

        Comment


          See end of the log.txt after crash.

          Comment


            Originally posted by GokuMK View Post
            See end of the log.txt after crash.
            I have gotten this, does it mean the url is wrong?:

            wait [I] QUrl("http://maps.googleapis.com/maps/api/staticmap?center=50.6365,6.2249&zoom=17&size=640x6 40&maptype=satellite&key=AIzaSyAH9W1lPHbYqEWx-Oa3uIv0WkxdZ7KwocQ")
            [I] wait
            [I] QUrl("http://maps.googleapis.com/maps/api/staticmap?center=50.6365,6.2305&zoom=17&size=640x6 40&maptype=satellite&key=AIzaSyAH9W1lPHbYqEWx-Oa3uIv0WkxdZ7KwocQ")
            (wait is multiple times)
            [I] data 270004
            [I] 640 640
            (multiple times again)
            [I] -5857 14882
            [I] "makeTileTextureTool"
            [I] -5857 -14882 -11.9809 -580.402
            [I] -58584882
            [I] "-58584882.:maptex"
            [I] -58584882
            [I] -5857 -14882 -5.35261 -657.635
            [I] -58584882


            I have another small question; will it be possible to lower or highten an entire tile? I have the google hgt files included but the route gets to a height point that msts and the msts RE might glitch so I might want to revert to only use a few parts for the distance of the route, but this would require lowering the ground of the tiles while keeping the mountains.

            Edit I also found a glitch, somethings when plancing tracks in an incline they don't seem to snap in perfectly. not sure if this has been reported before or if I made a mistake but still might be interesting.Click image for larger version

Name:	glitch.jpg
Views:	1
Size:	115.2 KB
ID:	2194941
            Last edited by railrunner112; 02-11-2017, 08:14 AM.

            Comment


              [I] "makeTileTextureTool"
              [I] -5857 -14882 -11.9809 -580.402
              [I] -58584882
              [I] "-58584882.:maptex"
              [I] -58584882
              [I] -5857 -14882 -5.35261 -657.635
              [I] -58584882
              Aren't missing something here? It should look like this:
              [I] "mapTileShowTool"
              [I] -5385 -15370 966.797 877.648
              [I] -53865370
              [I] "-53865370.:maptex"
              [I] -53865370
              [I] "makeTileTextureTool"
              [I] -5385 -15370 903.478 898.795
              [I] -53865370
              [I] zapis .ace "F:/train simulator/routes/aaa/terrtex/-112ea898_map.ace"

              Comment


                that is all I had in the log file, guess it crashed before it got there.Will try it once I restored the backup (the route crashed and the tdb got killed)
                I did notice as posted below some of the tracks don't really seem to match up. either the height has a difference but also in curves they sometimes are too far to the left or right at the attach point of the snapped piece; the route I was working on has large hill like areas. The height difference is solvable with the CTRL+scroll button but tracks not matching on any other way I have not yet found a workaround for.

                Comment


                  New update: http://koniec.org/tsre5/data/TSRE5_v0.686.exe

                  0.686

                  - critical tdb bug fix
                  - new auto palcement (use lmb, ctrl+lmb or shift+lmb)
                  - speedpost properties fix
                  - X key: flip objects
                  - carspawner simulation
                  - simple activity editor




                  Activity editor is like TSRE5 v0.5. Most of the things does not work, but you can create playable OR activity.
                  - create empty activity or open existing one
                  - edit activity settings
                  - create service and select player service
                  - place new loose consists
                  Last edited by GokuMK; 02-12-2017, 02:32 PM.

                  Comment


                    New update: http://koniec.org/tsre5/data/TSRE5_v0.687.exe

                    - fixed carspawner "expand" button.
                    - fixed level crossing placing. Broken level crossing placed in previous versions of TSRE has to be replaced.

                    Enable Track Items in View Menu to find broken level crossings.
                    Left (only black boxes) - bad.
                    Right (black and gray) - ok.

                    Comment


                      I must be doing something wrong. When I select a route, the editor crashes.

                      I have not played with it is some time and early versions would open OK. This latest version (0.687) will not load the routes.

                      Thanks
                      Basil

                      Comment


                        Can I see the log? New versions are loading Activity data (act, pat etc.), so it might be something wrong here.

                        Comment


                          I have no problems with v687. It loaded the large PRR East Region route including activities but the log does have several items like
                          [E] QObject::connect: No such signal QLineEdit::edited(QString)
                          Beer is not a matter of life or death, it is much more serious than that.

                          Comment


                            It's just unfinished user interface component. Nothing wrong.
                            Last edited by GokuMK; 02-13-2017, 05:23 PM.

                            Comment


                              New update: http://koniec.org/tsre5/data/TSRE5_v0.688.exe
                              (32 bit): http://koniec.org/tsre5/data/TSRE5x32_v0.688.exe

                              0.688

                              - "Save" is now Shift+Ctrl+S. Ctrl+S was colliding with slow camera movement.
                              - edit all speedpost properties
                              - fixed speedpost bugs ( TSRE had a bug in Speedposts that it always put Speed_Digit_Tex and Speed_Text_Size, even if Sepost_Digit_Tex and Milepost_Text_Size is required instead. Also, wrong angle in Speed_Sign_Shape .W file entry )
                              - fixed signal bug when TrSignalType Flags had wrong value. If route is used only in Open Rails, this bug don't need to be fixed, because Open Rails doesn't use this value. But if signal has wrong TrSignalType Flags, it may not work properly in MSTS. To fix it, check your signals and use "Fix Flags" button:

                              1. Press "Hacks".
                              2. Press "Fix TrSignalType Flags".
                              3. See, if there are any errors.
                              4. Press "OK" and fix them.
                              Last edited by GokuMK; 02-13-2017, 11:10 PM.

                              Comment


                                New update: http://koniec.org/tsre5/data/TSRE5_v0.6881.exe
                                (32 bit version): http://koniec.org/tsre5/data/TSRE5x32_v0.6881.exe

                                0.6881

                                - fixed Huge UNDO memory leak!
                                - fixed bug when adjusting terrain to very small tracks.
                                Last edited by GokuMK; 02-14-2017, 02:11 PM.

                                Comment

                                Working...
                                X