Announcement

Collapse
No announcement yet.

Activity Editor - Issues Loading Traffic in Simulation

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by scottb613 View Post
    NOTE: What Goku was speaking of - is the VERY LAST thing you want to do before saving your activity - ANYTIME you mess with traffic - is reselect the traffic file from the dropdown list where the RED ARROW is pointing - and SELECT the traffic file you are working on... If you don't do this your changes will be ignored... Then SAVE the Activity immediately after...
    Hey Scott,

    This step might have hung me up in the past. Will keep this in mind going forward. Thank you!

    EK

    Comment


      #17
      Originally posted by ekeating View Post
      Hey Scott,

      This step might have hung me up in the past. Will keep this in mind going forward. Thank you!

      EK
      Hi EK,

      Don’t feel alone - had me stumped for a bit as well... Good luck...

      Regards,
      Scott


      Sent from my iPhone using Tapatalk
      <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

      Comment


        #18
        THANK YOU SCOTT! It took a while & numerous unsuccessful attempts, but I finally mastered the process. Now have multiple AI consists enroute from multiple origination points all converging on a central, designated end point. Only 2 arrivals as yet but more expected! Thank you again for your expert assistance. Hawk

        Comment


          #19
          Originally posted by Winterhawk76 View Post
          THANK YOU SCOTT! It took a while & numerous unsuccessful attempts, but I finally mastered the process. Now have multiple AI consists enroute from multiple origination points all converging on a central, designated end point. Only 2 arrivals as yet but more expected! Thank you again for your expert assistance. Hawk
          Hi Hawk,

          Very happy to help...

          You guys are aware that’s there’s a ton of new features in with Advanced AI Shunting in ORTS - right ? This is all done in Track Viewer with [Wait Points]... You can have AI switchers working the yards grabbing strings of cars to assemble and break down trains - the main power trundles out from the service facility to grab its train and heads off to its destination - locals picking up and leaving cars at various sidings along its route - you can have helpers joining the end of the train for a shove over the hill then detaching at the top to head back down to its staging point - horns at crossings - play WAV files at events - - - doing real work - - - all WITHOUT user intervention... It’s pretty incredible when you take the time to set it up...

          Regards,
          Scott


          Sent from my iPad using Tapatalk
          <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

          Comment


            #20
            Oh Scott! What have you done!!! H

            Comment


              #21
              Originally posted by Winterhawk76 View Post
              Oh Scott! What have you done!!! H
              Hah - yeah - playing with AI can be addictive - sometimes I don’t even run a train - just sit back and watch AI go about their assigned tasks...

              In Track Viewer when creating a [Path] - there’s a menu when placing [Wait Points] that allows you to select these advanced features - you can specify how many cars you want to grab or drop from a string... It’s not rocket science - just takes some playing around to get the hang of it...

              There’s also an option in ORTS Settings that needs to be turned on [Advanced AI Shunting] or something like that...

              Regards,
              Scott


              Sent from my iPhone using Tapatalk
              <a href=https://www.trainsim.com/forums/filedata/fetch?filedataid=80663&type=full title=thumb_80663.png >thumb_80663.png</a>​ My Blender Models

              Comment


                #22
                I have used a variation on that in the past where I would load up the activity w/a good number of AI traffic pieces & park the PT @ some centralized location like a siding or divergent main track, & just sit there & watch the traffic pass by. If no siding is available, you can also send the PT on its merry way to its end point, freeze the camera, & accomplish the same thing. Adds variety to the sim from time to time. H

                Comment


                  #23
                  I'd love to assign the AI more involvement in my scenarios. However, I have a lot of learning to do. I followed the steps, but my AI traffic simply don't show. This isn't an TSRE issue. I had the same problem with this particular map, NS Piedmont Corridor. You can run small paths, but anything over twenty miles or so won't work. I posted a link to the warning symbols I see when I load the game as well as the AI pathAI_Charlotte_Pomona.zip

                  Any help would be greatly appreciated. this has been stomping me for years.
                  Attached Files

                  Comment


                    #24
                    If you have the 'LOGGING' box ticked on the OR opening screen could you please attach the OR log file file?
                    regards.
                    ............Vince ..............
                    ...... Author NECv4 .......
                    .... LIRR BUILD PHOTOS ....
                    ...... Eschew Obsfucation ......

                    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
                    "Give me your tired, your poor, your huddled masses yearning to breathe free,
                    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
                    I lift my lamp beside the golden door!"

                    Comment


                      #25
                      I had the timing set wrong. I can't believe I was that stupid.

                      However, I have another issue. My track speed is 0mph even though I have green signals. AI traffic have appropriate speed limits. Is this a path issue, or should I try to log the activity? I have logging checked but I don't know where the log file is.

                      I want to say I am really enjoying working with Trackviewer and TSRE Activity editor. Populating yards is easy and fun. I'm still learning, but I haven't been this interested in activity building in ages.

                      I also appreciate the help I get. Forum members are still friendly and willing to help. That really helps, particularly when poor confidence and tend to do idiotic things.
                      Last edited by deltapooh; 02-16-2020, 08:25 PM.

                      Comment


                        #26
                        I have logging checked but I don't know where the log file is.
                        The OpenRailsLog.txt file should be on your desktop.

                        regards,
                        ............Vince ..............
                        ...... Author NECv4 .......
                        .... LIRR BUILD PHOTOS ....
                        ...... Eschew Obsfucation ......

                        On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
                        "Give me your tired, your poor, your huddled masses yearning to breathe free,
                        the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
                        I lift my lamp beside the golden door!"

                        Comment


                          #27
                          Originally posted by scottb613 View Post
                          Hi Hawk,

                          Very happy to help...

                          You guys are aware that’s there’s a ton of new features in with Advanced AI Shunting in ORTS - right ? This is all done in Track Viewer with [Wait Points]... You can have AI switchers working the yards grabbing strings of cars to assemble and break down trains - the main power trundles out from the service facility to grab its train and heads off to its destination - locals picking up and leaving cars at various sidings along its route - you can have helpers joining the end of the train for a shove over the hill then detaching at the top to head back down to its staging point - horns at crossings - play WAV files at events - - - doing real work - - - all WITHOUT user intervention... It’s pretty incredible when you take the time to set it up...

                          Regards,
                          Scott


                          Sent from my iPad using Tapatalk
                          Wow! Do you know of a tutorial on how to set this up? I'd love to be able to get an AI yard switcher to break-down trains and assemble new trains. I was able to have a new train pick up its set of cars on various tracks to assemble its train and even go pick up its caboose, but how do tell the train to uncouple from other cars, I'm not sure of. The way I did it was to create a path with a ton of reverse points to be able to go down various tracks. If you or anyone has a tutorial on advance AI train config, I would love to understand how to do this.

                          Comment


                            #28
                            creeddude98 .... recently asked and answered....please see this thread...https://www.trainsim.com/vbts/showth...n-Open-Rails-!

                            Open Rails manual >>>> http://openrails.org/files/OpenRails-Testing-Manual.pdf Manual Section >>> 10.13 Extended AI Train Shunting
                            Cheers, Gerry
                            "A mind is like a parachute. It doesn't work if it is not open." Frank Zappa
                            It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
                            Forever, ridin' drag in railroad knowledge.
                            Audi, Vide, Tace, Si Vis Vivere In Pace

                            Comment


                              #29
                              I had a problem with traffic in activities also...the only resolution I came up with was having to modify the activity file (adding 1 sec to start time and removing the traffic file) then save then modify the activity file a second time (subtracting 1 sec from start time and adding traffic file back to the activity) corrected the issue. Modifications to the traffic file don't automatically get put into the activity file...you have to force it. at least that was my experience....

                              Amtrak115

                              Comment

                              Working...
                              X