Announcement

Collapse
No announcement yet.

Compiling TSRE

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • yellowdog
    replied
    Great job, Eric and everyone! This is a big leap forward!

    Leave a comment:


  • kapitaen
    replied
    Thank you for the good work and for sharing the editor.
    I have a question about the line heights. During changes of the terrain.... entries in the settings.txt are applied in the TSRE, changes to the line heights for sectionLineHeight and wireLineHeight have no effect. I would like to have the sectionLine lower so that you can also look at the line when the camera is on the track.
    The entry oglDefaultLineWidth actually has an effect on the lines that can be made wider with it.
    Here in the picture: oglDefaultLineWidth = 2

    Click image for larger version

Name:	Screen Shot 02-21-24 at 10.16 AM.jpg
Views:	561
Size:	174.5 KB
ID:	2296247


    Greetings Jan

    Leave a comment:


  • eric
    replied
    Posted the new version to the file library: 88620

    yellowdog I found the fix for the command prompt, and added it to the upload.

    Include the word "START" ahead of the command being executed (e.g. "TSRE5.exe") and the command prompt closes after the commands are finished executing.

    Leave a comment:


  • eric
    replied
    I'll dig around a bit to see if there's a setting that would clear that window.

    Leave a comment:


  • yellowdog
    replied
    It looks like it stays even after the consist editor and shape viewer are loaded. It doesn't appear with the route editor.

    Yeah, the cerecent was the issue with the file directories. But I do appreciate the updated TSRE name being included in the .bat files of the consist editor and shape viewer

    Leave a comment:


  • eric
    replied
    Is the DOS box back only when the command line options get called in the batch file?

    I may have included my cerecent.... will get that addressed later this morning.

    Leave a comment:


  • yellowdog
    replied
    Looks like it's working on my end! 2 other notes right off the bat--1) the DOS box seems to be back and 2) 2 directories are already pre-loaded into the consist editor, that may or may not match the end-user directories

    Leave a comment:


  • R. Steele
    replied
    DDS is good to go...they show in ConEd and in TSRE-Shapeviewer

    Leave a comment:


  • eric
    replied
    Interesting....

    I'm running on the vanilla PC, and firing up the Starter route, I get track textures. If I rename acleantrack1.dds to something else, I get black track with regular rails. Rename it back, I get track textures, so I know it's rendering DDS's....

    In the first zip, I didn't rename the executable in the shapeview and consisteditor batch files, which I just fixed and re-uploaded above.

    With the batch pointed at the new exe ( TSRE5v8.001.exe ) it fires up just fine and renders DDS in both Shapeviewer and ConsistEditor for me.

    Last edited by eric; 02-20-2024, 01:40 AM.

    Leave a comment:


  • R. Steele
    replied
    Originally posted by eric View Post
    Please give this a try to see if DDS is now rendering OK or not. This is the 64 bit version compiled with TSRE 5.15.2, but with missing DDS plugin added (I hope).
    No. ConEditor does not show dds. Double checked with shapeviewer and dds textures appear.
    Let me clarify about shapeviewer. Using the Shapeviewer.bat file within TSRE the dds textures do not show.

    Using my stand alone shapeviewer they show.
    Last edited by R. Steele; 02-20-2024, 01:00 AM.

    Leave a comment:


  • eric
    replied
    OK... if I can ask again....

    Please give this a try to see if DDS is now rendering OK or not. This is the 64 bit version compiled with TSRE 5.15.2, but with missing DDS plugin added (I hope).

    TSRE5-64bit-v8.001 ----> TSRE-64Bit-v8.001.zip <-----
    Last edited by eric; 02-20-2024, 01:31 AM.

    Leave a comment:


  • eric
    replied
    Agree that it's not a showstopper issue for me with route editing, but it may make a difference with shape viewing, consist and activity editing.

    Leave a comment:


  • yellowdog
    replied
    Originally posted by eric View Post
    Well.... Turns out QT dropped built in support for DDS in version 5.8 and later.
    Seriously? This reminds me of why I got out of IT..... ha ha. I imagine this would impact track shapes, too, but I didn't open any.

    Originally posted by eric View Post
    I've been able to build the necessary DLL... Getting it to recognize the format though is a bit beyond what I've done so far.
    Nice!!

    Leave a comment:


  • R. Steele
    replied
    Originally posted by eric View Post
    Well.... Turns out QT dropped built in support for DDS in version 5.8 and later.
    meh, low priority stuff. imo --- I already know what the rolling stock looks like.

    Leave a comment:


  • eric
    replied
    Well.... Turns out QT dropped built in support for DDS in version 5.8 and later.

    I've been able to build the necessary DLL... Getting it to recognize the format though is a bit beyond what I've done so far.

    Leave a comment:

Working...
X