Announcement

Collapse
No announcement yet.

TSRE5 v8.x Bug Reports

Collapse
This thread is discussing the following file:

TSRE - Trainsim.com Fork v8.003

File date: 2024-04-05 19:00:00
Downloads: 208

>> Download Now <<

X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    TSRE5 v8.x Bug Reports

    Please report any bugs here. Bugs will be cleaned up from the thread as they're resolved
    If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

    #2
    Please start reporting issues with 8.003d
    If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

    Comment


      #3
      TSRE-Testing-8.003d.
      The double start bug of TSRE is still present. The route is loaded directly and the route selection also appears. Unfortunately my contribution to TSRE-Testing-8.003c was deleted, so I can't link it.

      The fact that the new symbols are directly on the rails surprised me. I would have expected them at a height of 1 metre. That might just take some getting used to.

      Screen Shot 03-05-24 at 08.04 AM.jpg

      Screen Shot 03-05-24 at 08.06 AM.jpg


      Greetings Jan​​


      Comment


        #4
        If you can, pm me the contents of your settings file... I have not been able to duplicate the double startup.

        Having the track item arrows a full meter above the track was making it difficult to see from a side view.
        If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

        Comment


          #5
          Originally posted by eric View Post
          Having the track item arrows a full meter above the track was making it difficult to see from a side view.
          I'm sure it's just a matter of habit. I've now placed a few signals and it works perfectly.
          Greetings Jan
          PM is on its way.​

          Comment


            #6
            Found the issue with the double-loading.... a misplaced bracket has been reunited where it belongs.

            New 8.003e being uploaded.

            As I've made some other edits since packaging, I want to give this a bit more of a shakeout before uploading the fix, and also see what other issues come in.
            If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

            Comment


              #7
              I have found that on several occasions, having selected an object and copied its Position and Rotation, when trying to paste the Position and Rotation on to another object TSRE 8.0003d crashes.

              Martin

              Comment


                #8
                OK, investigating. This is probably due to including the tile details to address another gap.

                The copy/paste function does use the Windows clipboard. Is it possible you've added something else to the clipboard between the copy and paste actions?
                If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                Comment


                  #9
                  Is it possible you've added something else to the clipboard between the copy and paste actions?
                  No, I'm afraid not.

                  One other point occurs to me which might be worth considering for the next iteration of TSRE. I find that on opening TSRE I always hit the period key in order to have the camera moving parallel to the ground rather than diving into it. If this experience is common among users, would it be possible to make the function toggle in the opposite direction, i.e. the camera moves parallel to the ground UNLESS you hit the period key?

                  Martin

                  Comment


                    #10
                    I found an index out of bounds issue on the paste position+rotation -- that's fixed and will be packaged up shortly.

                    Locking the camera elevation can be is now added as a pre-set behavior in the settings file: lockCamera = true

                    new version available in https://www.trainsim.com/forums/foru...testing-v8-003
                    Last edited by eric; 03-06-2024, 06:01 PM.
                    If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                    Comment


                      #11
                      Thanks for adding the camera lock option and for fixing the Copy Rot and Pos function, which I can confirm now works again as intended.

                      Am I correct in assuming that these setting entries:

                      season = "" // For editing winter/fall/spring/summer
                      seasonalEditing = false​

                      are as yet not implemented and that TSRE still does not support seasonal textures (not to mention night textures)? I have experimented with them but nothing happens. Or do I misunderstand?

                      Martin

                      Comment


                        #12
                        Hi Eric,

                        If you are inclined to work on the TSRE Activity Tool, it has some problems dealing with traffic definitions, although there is an awkward workaround.

                        I have attached a file containing a detailed description of the issues, some sample data, and a suggested solution.

                        TSRE-traffic.zip

                        If you could fix these issues, I would be eternally grateful (and of course I would volunteer to test the fixes).

                        Regards,
                        Dan

                        Comment


                          #13
                          I'm deliberately working in areas that won't cause corruption within a route. For now, it's writing to World files and parameters that affect GUI and startup.

                          I am intentionally not doing anything that touches the track database or Road database. Those types of changes have the potential to cause irreversible damage, and I really don't want to be responsible for that just yet.

                          Consists and Activities are a black hole to me - I don't use those features and really don't know the file structures well enough to start diving into them.

                          If someone who does understand those wants to suggest actual code changes, I'm happy to run with them, but it's probably going to take more guidance than just a sentence or two in a web post.

                          What Dan just provided is a lot of help in that regard.


                          If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                          Comment


                            #14
                            Well, I wanted to get in touch. I have now demolished half a branch with TSRE-Testing-8.003e. So far there has only been one problem, that I simply couldn't see the siding marker when resetting, although data for it was written in the left window. I was previously travelling under the terrain. The error cannot be reproduced.
                            All good, Jan

                            Comment


                              #15
                              Thanks for sharing the successes.

                              Painting the bottom of the marker objects can be added into next week's testing release.

                              I will also add a config setting to allow keeping the traditional pyramids for those who want that instead of the newer arrows.
                              If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                              Comment

                              Working...
                              X