Announcement

Collapse
No announcement yet.

BZZ_MSTS_RN_F94.s has an issue with TSRE

Collapse
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    BZZ_MSTS_RN_F94.s has an issue with TSRE

    Howdy y'all... I need a little help here. The scenery object, BZZ_MSTS_RN_F94.s does not want to appear when placed in TSRE 7.012. When I try to place it, it gives me all the information that it has been placed but no visual confirmation. It shows in the various shape viewers, so I know all the files are in their correct locations. I tried changing the "ESD_Detail_Level" from 0 to 5, but to no avail.
    If anyone has any ideas on how to resolve this, I would appreciate it.

    Thanks,
    Peter

    #2
    Double check for a typographical error in the shape file name listed in the .ref file, I've had that happen once or twice because I made such an error. If there's a space, the file name needs to be in quotation marks. Also make sure that the ".s" is present in the line.

    Comment


      #3
      It shows in TSRE v0.698.

      image widget

      Comment


        #4
        Originally posted by fleegle411 View Post
        Double check for a typographical error in the shape file name listed in the .ref file, I've had that happen once or twice because I made such an error. If there's a space, the file name needs to be in quotation marks. Also make sure that the ".s" is present in the line.
        Thanks, I copied the entry for the .ref file directly from the read me and it indeed has a space in the filename. Here is the script from the read me file (note the space between the 4 and the .s)

        Static (
        FileName ( BZZ_MSTS_RN_F94 .s )
        Shadow ( RECT )
        Class ( "Captain_Bazza" )
        Align ( None )
        Description ( "RN_Frigate_F94" )
        )

        Thanks again
        Peter​

        Comment


          #5
          Originally posted by rdayt View Post
          It shows in TSRE v0.698.

          image widget
          Interesting ... You must have fixed it at some point or there is some kind of difference between TSRE v0.698 and TSRE v0.7.012.

          Peter

          Comment


            #6
            I haven't touched it. It came with the Brest-Rennes route.

            Randy

            Comment


              #7
              Spaces in the filename are indeed supported.... If there's a difference between the name in the REF file and the name of the file in the SHAPES directory, nothing's going to fix that...

              If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

              Comment


                #8
                Hi,
                I have this model, as supplied with the Scottish Central Plus route.
                There is no space in the actual shape file name and I suspect that the FileName line in the .ref file quoted by peterman is the source of the error.

                After checking the currently available Brest - Rennes route (v2), the .ref file also doesn't contain a space in the FileName entry, although it's not the same as posted by peterman :
                Static (
                FileName ( "BZZ_MSTS_RN_F94.s")
                Shadow ( RECT )
                Class ( "Misc" )
                Align ( None )
                Description ( "BZZ_MSTS_RN_F94" )
                )​
                It appears that peterman may have downloaded the file from elvastower.com which includes a readme which specifies the required .ref file entries - these DO contain a space before '.s' in the file name.

                Cheers,
                Ged
                Last edited by slipperman; 02-27-2024, 05:00 PM.

                Comment


                  #9
                  I copied and pasted the name you pasted from your ,ref file.into Notepad.
                  bz.jpg
                  The actual shape doesn't have a space so it's a different entry and won't show.

                  Randy

                  Comment


                    #10
                    Hi Randy,
                    To whom are you addressing your last post?
                    If it's me, and you've copied and pasted from my quoted .ref file entry, then YOUR copy has added a space! There is NOT one in the original. If I copy and paste, using NotePad, I DO NOT get the space.

                    Cheers,
                    Ged

                    Comment


                      #11
                      Doesn't matter where or how the space got into the REF file... if it's there, the shape won't render because the shape with the space doesn't exist.

                      Two fixes involved here...

                      1) Update the REF to eliminate the space so it doesn't mess up in the future....

                      2) Go into the W file and locate the Static() with that filename, and remove the space so that you can get the objects to render, and delete any dupes you might have placed.
                      If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                      Comment


                        #12
                        Originally posted by slipperman View Post
                        Hi,
                        I have this model, as supplied with the Scottish Central Plus route.
                        There is no space in the actual shape file name and I suspect that the FileName line in the .ref file quoted by peterman is the source of the error.

                        After checking the currently available Brest - Rennes route (v2), the .ref file also doesn't contain a space in the FileName entry, although it's not the same as posted by peterman :


                        It appears that peterman may have downloaded the file from elvastower.com which includes a readme which specifies the required .ref file entries - these DO contain a space before '.s' in the file name.

                        Cheers,
                        Ged
                        Hi Ged,

                        You are correct that I downloaded this file from ET. I have to assume that the original shape was created by "Captain Bazza" in 2010 and the .ref file entry in the read me is the original, therefore I would guess that it was corrected when used in the Brest-Rennes and Scottish Central Plus routes during the route building process. It looks like something only route builders would pick up on. However, all is well now.

                        Thanks again,
                        Peter

                        Comment

                        Working...
                        X