Announcement

Collapse
No announcement yet.

Testing v8.004

Collapse
This topic is closed.
X
X
Collapse
First Prev Next Last
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Testing v8.004

    For those interested in trying an unstable version of TSRE, the following is available.

    Be sure to have backups of your Trains and Route folder before testing with it. TDB corruption may occur with testing versions.

    I also recommend isolating this version from your regular version in a separate folder. Copy over settings as needed.​

    Newest version: -----> TSRE-Testing-V8.004e.zip <------




    Feedback is important -- please share your experience here, especially if it's working as expected.
    Attached Files
    Last edited by eric; 04-25-2024, 10:22 PM.
    If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

    #2
    8.004a adds the following:

    Offset from track centerline added for signal and milepost placement (sigOffset setting)
    Reload Marker Files (file menu)
    Show Speedposts in Marker dropdowns automatically (similar to Sidings and Platforms)​
    Adds all shapes in Route\Shapes directory to an "Non-Indexed" category on the Objects pane
    Last edited by eric; 04-11-2024, 11:08 PM.
    If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

    Comment


      #3
      It works for me! 👍

      Screen Shot 04-12-24 at 08.07 AM.jpg
      Jan

      Comment


        #4
        Originally posted by eric View Post
        Offset from track centerline added for signal and milepost placement (sigOffset setting)
        Thank you! My friends were amazed by this update and said, "OMG! If I had known this earlier, it would have been much easier." However, the downside is that the offset needs to be set in settings. txt, which also means that when I need to change the offset settings (such as placing them on the other side of the track), I must close TSRE and modify the settings before reloading. Can I change these settings within the application (such as in the automatic placement settings)?

        Comment


          #5
          Originally posted by denglihong View Post
          when I need to change the offset settings (such as placing them on the other side of the track), I must close TSRE and modify the settings before reloading.

          After thinking about this some more, I'm adding a "Reload Settings" function which will reload most of the Settings.txt options.

          capture_500576.jpg


          There are some that need to stay once-and-done with the editor running. Changing anything related to the TDB, file paths or 3DGraphics rendering could have really nasty side effects.

          But editing preferences and presets (including the offset for the signal/speedpost offsets) can be safely changed.
          Last edited by eric; 04-13-2024, 11:35 PM.
          If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

          Comment


            #6
            Just a thought that occured to me Eric.. Maybe add a UI in TSRE where you can edit the settings file instead of having to manually go in and find the line you need and change it.
            Don't tell me the sky's the limit, when there's footsteps on the moon..

            --Josh--

            Comment


              #7
              Yep, already considering that as well, but adding new windows into the UI is a little more complicated using QT then it would have been using visual studio. It's definitely not a drag and drop experience to create. It's all code driven, not that I mind that but this is one place we're having a GUI to be able to design the UI and its interaction with the other windows / modules really makes a difference. The netbeans compiler really isn't made for that, and setting up the QT equivalent of Visual Studio is something I just have not had time or patience to invest in.
              If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

              Comment


                #8
                Eric, would it be easier to have the OS launch notepad.exe with the ini filename and path?
                It wouldn't be as simple as Josh's suggestion, but would at least make it easy for people to find the file to edit?

                Comment


                  #9
                  Eric, If I edit the route "Europa2" with "TSRE5v8.004" as a test and then start it with "OR_T1.5.1-925-g1c557094e", OR crashes. If I then save the route again with "TSRE5_v0.7.012", the route is started. How can I solve the problem?
                  Attached Files

                  Comment


                    #10
                    The 8.004 log is coming up invalid -- can you re-attach?

                    Also please include the logs from TSRE.
                    If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                    Comment


                      #11
                      I will send you the files as requested. If you have any further questions, please do not hesitate to contact me.
                      Attached Files

                      Comment


                        #12
                        Not sure what the deal is, but the OpenRails log isn't uploading. Paste the contents you can into a post. You might need to break into a couple separate posts.
                        If you like what you see here at Trainsim.com, be it the discussions and knowledge in the forums, items saved in our library or the ongoing development of our TSRE Fork, I hope you'll consider a paid membership to help support keeping the site operating.... Thanks!

                        Comment


                          #13
                          Originally posted by weichenpfleger View Post
                          If I edit the route "Europa2" with "TSRE5v8.004" as a test and then start it with
                          Open Rails, NewYear version Rev.151.2 all is O.K.

                          There are differences in the sorting, but the route works with the usual errors in the log.
                          Remember that this route requires the original tsection.dat with 156 kb and date May 08, 2001.​

                          Screen Shot 04-16-24 at 07.43 PM.jpg
                          ... Jan
                          Attached Files

                          Comment


                            #14
                            Next attempt. I have converted the file as "*.pdf".
                            Attached Files

                            Comment


                              #15
                              Hallo Jan, die "newYear" versionen laufen bei mir leider schlecht, weil die Züge wie von einem Gummiband gezogen, fahren. Deshalb muß ich auf die "unstablen" zurückgreifen. Dort habe ich durchgehend 60 Hertz und gleichmäßiges Rollen.

                              Hi Jan, unfortunately the "newYear" versions don't work well for me because the trains run as if they were being pulled by a rubber band. That's why I have to fall back on the "unstable" ones. There I have a continuous 60 Hertz and even rolling.

                              Comment

                              Working...
                              X