Problem: Another MSTS Bug?

  1. rdamurphy
    rdamurphy
    I won't bother with pictures, I don't think they're needed.

    OK, stop at a siding, let opposing AI pass, signal changes to CLEAR and switch lines up. Proceed past signal, since I gave up on RESTRICTING, the signal acutally uses the MSTS STOP_AND_PROCEED aspect, but displays Restricting on the in-game signal.

    Speed limit in the F4 display drops to 15 and stays there until I pass the next CLEAR signal, and stays at track speed. WHY is the speed limit showing 15 after passing the Interlocking? The red diamond is past the signal, it shouldn't be an issue. BUT, when the signal drops when the train passes, so does the speed limit!

    Aggravating, to say the least...

    Robert
  2. jovet
    jovet
    Only another signal can change or cancel a signal speed restriction in effect.

    The speed limit is determined by the highest speed limit of all NORMAL heads of a signal shape. If no speed restriction is setup, then track speed is restored.

    Unless there's a signal at the exit of an interlocking, no change in speed restriction can occur.

    This is prototypical, because once passing the Restricting signal, your train should be going at Restricted speed until it passes a less-restrictive signal, anyways.
  3. rdamurphy
    rdamurphy
    I'm afraid I really didn't explain that very well...

    I have a CLEAR signal ahead, speed limit in F4 shows track speed, all is good.

    I pass the signal, and it drops to STOP&PROCEED, as it should, but the F4 speed limit drops to 15, AFTER I've passed the signal.

    I moved the diamonds further away from the signal, and tried them right next to the signal, no difference. After the train passes the CLEAR and the signal drops, the speed limit drops on the F4 for the block I just entered.

    Weird, huh?

    I can take some screenies if that would help?

    Robert
Results 1 to 3 of 3