Results 1 to 8 of 8

Thread: Train Store Trouble After Reinstall Berlin Subway

  1. #1
    Join Date
    Nov 2003
    Location
    Wilmette, Illinois
    Posts
    127

    Default Train Store Trouble After Reinstall Berlin Subway

    Funny thing happened on the way to un- and re-installing Berlin Subway (seeing if some glitches could be corrected). All my stored Train Store files are missing in action, except one activity on one route (the last non-Berlin activity I ran and left unstored).

    Before I uninstalled and reinstalled Berlin I unstored everything in Train Store. Based on previous posts here, I repaste the original Global, Driver Aid and 3 general MSTS files whenever I exit Berlin Subway.

    I've checked the Train Store manual, looked online, can't find anything that can tell me how to restore Train Store to it's natural state with all my non-Berlin routes and activities. I'm not sure where the stored eng and other files go when they're stored in Train Store and how to get them back in a case like this. Is it possible the uninstallation and reinstallation of the Berlin Subway wiped out the Train Store folder with all the save MSTS files???

    Any help would be greatly appreciated. Obviously, I could simply (simply??) reinstall all my backup Train, Consists, etc. If someone has a simpler plan, I'd very much appreciate hearing it.

    I've been TSing for nearly 4 years. Just when you think you have it under control, the boiler explodes.

    Barry

  2. #2
    Join Date
    Nov 2003
    Location
    Wilmette, Illinois
    Posts
    127

    Default RE: PS for Train Store Trouble After Reinstall Berlin Subway

    One additional note. It may be that I had everything stored in Train Store except the one route and one activity. That might make explain why only that activity is unstored and any attempt to unstore everything gets me nothing more than that one activity.

    Either way, it ain't good.

    Barry

  3. #3

    Default RE: PS for Train Store Trouble After Reinstall Berlin Subway

    Hi Barry !

    The TML-Berlin Underground uses it's own folders in MSTS, routes_ugb, consists_ugb & trainset_ugb, TRAINSTORE should not concern itself with, their presence not affecting the running of MSTS and vice versa and TRAINSTORE having been created before the release of the UGB would not know how to deal with anyway.

    I have backed-up these three folders in any case so that I can restore them, having messed with both it's routes, replacing it's switches and adding some of my favourite track joint sounds.

    This is something you may have to wait for Tony to comment on !

    O t t o

  4. #4
    Join Date
    Nov 1999
    Location
    Huntsville, AL
    Posts
    4,659

    Default RE: Train Store Trouble After Reinstall Berlin Subway

    Need a better description of what your problem is.

    What folders are in your C:\Program Files\Microsoft Games\Train Simulator\ROUTES folder?

    What Routes are Shown in Train Store with Everything Unstored?

    What Routes are shown in the MSTS GUI to choose from?
    Charles

  5. #5

    Default RE: Train Store Trouble After Reinstall Berlin Subway

    This is what you should have in your Train Simulator folders if the TML-U-BAHN has been installed correctly !

    O t t o



  6. #6
    Join Date
    Nov 2003
    Location
    Wilmette, Illinois
    Posts
    127

    Default The Fat Lady Sang In Spite of Tony's Best Efforts

    JUST A HEADS UP. Tony Formoso has been an absolutely gem in trying to help me through the problem. And it is my problem. A perfect storm of puttering in places only fools will go. Tony will probably be posting later explaining what happened and why.

    Simply put it's the vagaries of Berlin Underground, not Train Store. And I'm well aware of the file swaps Berlin UG causes and I'm careful to swap the vital files everytime I exit.

    My problem was trying to use the Activity Editor with Berlin Underground. It's easy enough to do. But then came some uninstalling and reinstalling of Berlin and storing and unstoring of Train Store and voila! -- implosion. Ironically, the problem I was trying to isolate - activity U2 RL_PA_MO-FR_12;35 which has red lights that get stuck and won't unstick with the fix was NOT helped by my tinkering. So I'm 0 for 2.

    It's now time to access my backups and recopy a whole bunch of stuff. Keeping perspective, imagine if I ran an acutal railroad. Come to think of it, this IS how some of the railroads are run...

    Thanks to each of you for trying to help,
    Barry

    Thanks for all your help.

    Barry

  7. #7

    Default RE: The Fat Lady Sang In Spite of Tony's Best Efforts

    Hi Barry !

    Just one tip, If you want to tinker with the UB activities then all of the UB folders need to be transferred into the proper MSTS ROUTES and TRAINS folders and than after having worked on the activities, all their folders, i.e. ACTIVITIES, PATHS and SERVICES and if you have changed AI trains also their TRAFFIC folders, need to be copied back to their own US2 / UB8 folders.

    I thought that this red light problem has been fixed, a download for it being available somewhere, I think mrmike Mike Rothenberg told me about and I forgot, having downloaded it.

    Which on is it, it's name and the UB route it is for. Can check mine and if it has been fixed can let you have a copy of it.

    E-mail me at: [email protected]

    O t t o

  8. #8
    Join Date
    Apr 2003
    Location
    .
    Posts
    240

    Default RE: The Fat Lady Sang In Spite of Tony's Best Efforts

    Thanks Barry, you are too kind. I hope we can get things back safely from your backups without to much ado.


    So . . . What Happened?

    After some thoughts and testing, I think what happened is this.

    [ol][li]There was just the 1 Activity unstored.[/li]
    [li]Berlin Subway was run.[/li]
    [li]Either MSTS crashed or MSTS was closed, and then the Berlin Subway loader was minimised, but left running.[/li]
    [li]Then Train Store was started, and the 'Unstore Everything!' function was used.[/li]
    [li]Then the Berlin Subway loader was closed, or the machine was rebooted.[/li]
    [li]Then Berlin Subway was uninstalled.[/li][/ol]

    [ul]The problem is that in step 4. Train Store saw almost everything from your ordinary MSTS installation in its storage folders, and obediently unstored them, as requested, into the MSTS folders (which at this time were currently containing the Berlin Subway folders).

    When the Berlin Subway loader was then closed, the folders would have been swapped back (to their current state). All of the ordinary MSTS items are now 'lost' in the Berlin Subway folder structure, apart from the files from the original MSTS folder which were unstored at the time. At this point nothing is missing. Everything is still there, albeit in the wrong place. Train Store has not, and does not, delete or change any files.

    When Berlin Subway was uninstalled, it (understandably) deleted everything in its own folders. BUT, unfortunately this now included almost all of the ordinary MSTS items inserted from Step 4.[/ul]

    Unfortunately the Berlin Subway add-on modifies MSTS files and the MSTS file structure whilst it is in use, and it is potentially dangerous to make any changes to MSTS files or folders whilst the loader is still running, or if the loader has crashed and the machine has not been rebooted.

    This problem was highlighted when the add-on first became available. [Link Expired]
    [ul]"Whilst Berlin Subway is active, you don't need to run Train Store, and you should not run Train Store whilst Berlin Subway is active. If you do so, you risk storing/unstoring files to the wrong MSTS system. As long as you have exitted the Berlin Subway program, and Berlin Subway has restored the MSTS files that it had changed, there is no interaction with MSTS, and you can use Train Store normally."[/ul]


    Tony

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->