Results 1 to 9 of 9

Thread: Random signalling

  1. #1
    Join Date
    Apr 2003
    Location
    Cheesecity, drunken? ;-), Netherlands.
    Posts
    62

    Default Random signalling

    Dear BVE-ers,

    I have a question about the signals in BVE. As some of you might know, I wrote the S75 BVE-route from Wartenberg to Mullerhof. This route contains also some routes which have random signalling. But...since I have the newest version of BVE, the signals don't work properly anymore! :-(

    What I mean is that if I see a red signal, the signal doesn't become yellow signal after a while, but becomes green! So the block system doesn't work anymore and the whole effect of a train in front of you is gone! You should try the route for yourself and see what happens.

    The problem I write about, does only happen when I stop at a station. So I stop at a station with a red signal in front of me. After a while, the signal doesn't become yellow (like it should do because the phantom train in front of me has cleared the block), but it becomes green. I haven't got this problem with an older version of BVE, so it must be the program.

    Can anybody help me? I'm about to release an updated route with realistic track and an extension of the route with 4 stations and two depots. But first I want this problem to be fixed.

    For the signals I use the code:
    .signal 3;name of the signal;1.68;1,

    Thanks for your help!

    Regards,

    Bas.

  2. #2

    Default RE: Random signalling

    I have testet the route-files, and the signals are working.
    I have the newest version:2.53

    I have found no errors.

    greatings
    Martin Finken
    http://BVE-Train.de

  3. #3

    Default RE: Random signalling

    All signals in BVE are Japan's system, even if they look like europeans.
    I don't know the block system you are using, but in France, there are many differents blocks systems, from mecaniks to without signal on track (TGV).
    I think system you talking about is like a manual block, with red signal on station exit. The train must stop on station. So, there is no train in front, but only the needing of make a stop. And signal change to green when the train may leave the station.

    All the best.

  4. #4

    Default RE: Random signalling

    If you work with @pretrain,than you can simualate a blocksystem as the european system, and it is working.The signals are from red over yellow to green.

    greatings
    Martin Finken
    http://BVE-Train.de

  5. #5

    Default RE: Random signalling

    I don't think I have ever seen a signal go from Red to Yellow When at a station. I always seen it go from Red To Green. Even the station command when tied to the signal command using a type 3 signal on goes red to green. I have only seen signals go thru all colors when using a type 1 block signal, and sometimes with a type 2 entering station signal.

    Jason

  6. #6
    Join Date
    Apr 2003
    Location
    Cheesecity, drunken? ;-), Netherlands.
    Posts
    62

    Default RE: Random signalling

    First of all: thanks for your help. Secondly: I find it strange that Martin had no problems at all with the signals. If I understand it properly he never has the "problem" that signals change from red directly into green at a station.

    To makes things clear: I also have seen signals change from red to green in other routes, but that's when you drive into the station and reach the stop marker. When you reach the stop marker, the signal will change from red to green. That's the so called "stop prevention". But that's not the problem I'm facing.

    However, the suggestion of Jason is a good one. Maybe I should change the type of the signal in 1 or 2, instead of 3. I'll try this option this weekend (because I only can play BVE during the weekends at my parents: the computer I have at my room isn't fast enough... :-( )

    I'll let you know if this works out fine!

    Bye,

    Bas.

  7. #7
    Join Date
    Apr 2003
    Location
    York, N.Yorkshire, UK.
    Posts
    303

    Default RE: Random signalling

    Got a suggestion. Maybe if you all could create an update. Mine remains red all throughout!

  8. #8
    Join Date
    Apr 2003
    Location
    Cheesecity, drunken? ;-), Netherlands.
    Posts
    62

    Default RE: Random signalling

    >Got a suggestion. Maybe if you all could create an update.
    >Mine remains red all throughout!

    Ehh, what exactly do you mean Hongjian? Create an update of what?

  9. #9
    Join Date
    Apr 2003
    Location
    Cheesecity, drunken? ;-), Netherlands.
    Posts
    62

    Default RE: Random signalling

    Yippie!!!! I've found out what is the problem: it's in the station-command! It really makes a difference if you use .station or .sta

    If I use .sta the signals are messing up and therefore the block-system doesn't work anymore, well, not properly. But if I use .station it works fine!

    Maybe this can help other devellopers. I'm glad I've solved this problem! In a few weeks there will be an update of the S75 route with smooth curves and switches and new stations plus depots.

    Cheers! :7

    Bas.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •