Results 1 to 5 of 5

Thread: Ground Texture Application

  1. #1

    Default Ground Texture Application

    Whenever I apply a ground texture to my route, it gets stretched. I even tried applying premade textures but they still get stretched. Any ideas? Here's an example, with a texture off of SRv2 that should look like ballast:

    http://route.virtual-rail.co.uk/imag...somstnwip1.jpg

  2. #2

    Default RE: Ground Texture Application

    Hi Damon,

    Try tiling the texture:

    SetTextureCoordinates, n, {tile: x-axis}, {tile: z-axis},

    Example (240m wide, 25m deep, 4 vertices):

    CreateMeshBuilder,
    AddVertex,-120, 0, 0,
    AddVertex,-120, 0, 25,
    AddVertex, 120, 0, 25,
    AddVertex, 120, 0, 0,
    AddFace, 0, 1, 2, 3,
    GenerateNormals,
    LoadTexture,Ground.bmp,
    SetTextureCoordinates, 0, 00, 00,
    SetTextureCoordinates, 1, 00, 10,
    SetTextureCoordinates, 2, 10, 10,
    SetTextureCoordinates, 3, 10, 00,

    Change the '10' to other values and you should see how useful tiling is, and where it can be used.

    Hope this helps!

    Robert.

  3. #3

    Default RE: Ground Texture Application

    All that seems to do is upset BVE & Track Viewer. I think I require the help of an object creating tutorial, hehe! The thing is I copied the file straight from SRv2 with no modifications.

  4. #4
    Join Date
    Apr 2003
    Location
    Grimsby, N.E Lincs.
    Posts
    295

    Default RE: Ground Texture Application

    I'm working on one at the moment.

    View the object in structure viewer and make sure that all the vertices are working properly. It sometimes helps to make a bitmap containing text so you can see that everything is in order. The tiling factor is undoubtedly the problem here for a ballast texture use something like a tiling factor of 2 going forwards and 20 left and right and it will begin to resemble what you wanted.

  5. #5
    Join Date
    Nov 1999
    Location
    Planet Stooopid.
    Posts
    3,712

    Default RE: Ground Texture Application

    >All that seems to do is upset BVE & Track Viewer. I think I
    >require the help of an object creating tutorial, hehe! The
    >thing is I copied the file straight from SRv2 with no
    >modifications.

    I used trial and error for them if I can't be bothered to calculate properly or if the object's too complicated and has an odd number faces going everywhere. ;)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •