Results 1 to 6 of 6

Thread: Vista Support

  1. #1

    Default Vista Support

    Are there any plans to support this OS?

    MSTS2 is year(s) away. XP sales are due to end in June.

    Is Raildriver to be considered to candidate for the landfills once we are forced to move to Vista?

  2. #2
    Join Date
    Nov 1999
    Location
    Fife,Scotland
    Posts
    32

    Default

    A question I too would like an answer to.

  3. #3
    Join Date
    Apr 2008
    Location
    Williamston, Michigan
    Posts
    14

    Default

    The RailDriver is currently compatible with a number of games on Windows Vista. When MSTS2 is released RailDriver will be compatible with it on Windows Vista.

    For a full listing of games and operating systems we are compatible with please refer to the following page of our web site: http://www.raildriver.com/products/r...#compatibility
    Best regards,

    Brandon - P.I. Engineering Technical Support Specialist

  4. #4
    Join Date
    Nov 1999
    Location
    Fife,Scotland
    Posts
    32

    Default

    But not Kuju Rail Simulator?

  5. #5

    Default

    Quote Originally Posted by RailDriver_Brandon View Post
    The RailDriver is currently compatible with a number of games on Windows Vista. When MSTS2 is released RailDriver will be compatible with it on Windows Vista.
    As you can imagine, I am rather disappointed with the lack of any plans to support customers with RD and having to move to a new PC with an OS that causes an otherwise excellent device to be turned into a doorstop.

    My attempts to install RD with Vista seems to indicate that if the single dll is updated, permitting it to be functional as a fully registered driver, all would be well. I guess that it is not as simple as tweaking and recompiling.

    Thank you for the insight.

  6. #6
    Join Date
    Apr 2008
    Location
    Williamston, Michigan
    Posts
    14

    Default

    Quote Originally Posted by johnan View Post
    But not Kuju Rail Simulator?
    RailSimulator will be supported on both Windows XP and Windows Vista.

    Quote Originally Posted by ckawahara View Post
    As you can imagine, I am rather disappointed with the lack of any plans to support customers with RD and having to move to a new PC with an OS that causes an otherwise excellent device to be turned into a doorstop.
    I'm not sure what you mean by this. The RailDriver supports many different games on both Windows XP and Windows Vista.

    If you are referring to our decision to not support the original MSTS on Windows Vista then please refer to the following article in our Knowledgebase for more information:
    Will the RailDriver Work With Microsoft Train Simulator on Windows Vista?

    Quote Originally Posted by ckawahara View Post
    My attempts to install RD with Vista seems to indicate that if the single dll is updated, permitting it to be functional as a fully registered driver, all would be well. I guess that it is not as simple as tweaking and recompiling.
    Although we would like it to always be so simple, we often face challenges that are outside of our control. For example, MSTS does not offer an API that would allow us to directly interface with the game.

    Also, if a game is not supported on Windows Vista, then the RailDriver can not support that game on Windows Vista. This is a limitation of the game itself, not the RailDriver.
    Best regards,

    Brandon - P.I. Engineering Technical Support Specialist

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •