Results 1 to 5 of 5

Thread: Rail Simulator wont startup

  1. #1

    Default Rail Driver wont run for Rail Simulator

    Rail Driver wont run for Rail Simulator, however I can calibrate it from its .exe in the installation folder.

    Iím sorry for the lomg post but I want to include everything so you understand it better.

    I'm running XP Pro.
    nvidia 8800BTS
    4gb corsair Ram
    ASUS P5 mobo
    Antec 650watts PSU
    Intel Duo 8500

    I use a removable Hard Drive Caddy so that I can use drives for :-

    1) Vista for my "Normal" computing
    2) a HD with XP Pro for my Video work
    3) another HD fir XP Pro and MSTS and Rail Simulator.

    There is not a tray in this caddy, I just open the small door, slide out the drive, slide in another drive, close and lock the door. All of about 8 seconds. Guaranteed 10.000 drive swaps. Theres also a fan in it.

    If anyone is interested in them, these are links to them in my dealers.
    I am not connected with the dealer except as a customer.

    Metal version :-

    Plastic version :-

    So, I have both MSTS & Rail Simulator installed, that is, only the sims are installed,
    no routes or anything because I want to get everything running before I install routes.
    XP in Partition C:
    MSTS in partition D:
    Rail simulator in partition E:
    Last release of Rail Driver for Rail Simulator.

    I have just installed the Rail Driver for MSTS successfully and Rail driver for it in
    its default location in C:\Program Files\PI Engineering\MSTS\, all is working OK.

    I have Rail Simulator installed and working.
    I installed the rail driver in its default location but in its own folder.
    That is, C:\Program Files\Pi Engineering\Rail Driver\
    During the install I get an error that a file requires modyfing or altering or a word like that,
    yes will modify it for all users and no will modify it for one user, there no other choice,
    I tried one in this install and the other in the next install.

    When I click on the Sys tray icon I get this error :-
    MacroWorks II error
    Invalid configuration for selected XKey device.

    I restarted the PC, and modified the "ReportConfig.txt" as follows.

    #path to RailDriver.dll using the Path system variable. No need to modify.
    moduleFunction E:\Rail Simulator\plugins\RailDriver.dll
    moduleFunction void SetRailDriverConnected(const bool)
    moduleFunction bool GetRailSimLocoChanged()
    moduleFunction float GetRailSimValue(int, int)
    moduleFunction bool GetRailSimCombinedThrottleBrake()
    moduleFunction void SetRailSimValue(int, float)

    When I click on the Rail Driver icon on the desktop it flashes very briefly and nothing happens.
    I went in to the Rail Driver install forder and double clicked on it with the same result.

    I uninstalled Rail Driver and used my trusty RegSupreme Pro to remove any possible leftover entries in the registry,
    I rebooted and installed Rail Driver again with the same result.

    I don't know what to try next, any ideas.

    Many thanks in advance.
    Last edited by Dinny; 11-09-2008 at 10:57 AM. Reason: an error in the Title

  2. #2


    I again uninstalled Rail Driver for both sims, this time I installed the Rail Simulator first, I got it calibrated OK and the option in Macroworks in the sys tray works, but the Rail Driver mm11 (may not be the correct name, Iím not in the train sims drive) but its something like that, does not do anything except flash something for about 1/4 of a second.
    I also was given the option to Calibrate after the install which I did not get before.

    I get a popup that a file is corrupt, cant recall the name and I can get it onscreen but I havent a clue what it is about.

    I again got the popup in the install saying it cannot write to the .DLL file in the Rail Simulator installation. I did amend the necessary file to point RailDriver to it.

    It seemed that I could maybe Rail Sim running and Rail Driver too, but it will not work.

  3. #3


    If you go to your RailSim installation and go to:

    \Rail Simulator\plugins

    Is there a RailDriver.dll file there?

    Also do you have the MK1 and MK2 updates installed?

  4. #4


    Exactly the same problems as Dinny - driving me mad!

    Have reinstalled etc etc.

    I have the dll you mention in the correct direxctory - I also have the Mk1 and 2 patchs that you mention applied.

    Where next?

  5. #5
    Join Date
    Nov 1999
    Stevens Point, Wisconsin, USA.

    Default Speculation

    I had the script error after changing ISP and installing new McAfee anti virus, solved that one by uninstalling and reinstalling the RD software (Railsim v. After that, clicking the run/stop button didn't work - until it did, then it turned it on and off. Turned out to be a delay of 5-8 seconds or so between hitting the run/stop button and getting the "On" display, solution was to hit the button once and wait. After that, altho there was no lag in the controls, the digital speed display lagged five seconds or so behind the F5 HUD.

    Today, while cleaning out orphans on my HD, I noticed I had a C:\Program Files\Railsimulator\Plugins\raildriver.dll (My installation is C:\Railsimulator, not in \Program Files) file dated from the early beta releases last year. After deleting that, it now works perfectly. So one more suggestion FWIW, hunt for orphaned old raildriver.dll files that might be loading instead of the correct ones.

    BTW, I also downloaded and installed the RD SD-40 for railsim, executable installed that to \Program Files\Railsimulator (creating the directory cuz that's not where I got it) and I had to move it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts