Results 1 to 6 of 6

Thread: Conbuilder consists and traffic patterns

  1. #1

    Default Conbuilder consists and traffic patterns

    I am using Conbuilder 2.4.3. When I try to add a service item to a traffic pattern item to my activity, the consists that I have created with Conbuilder do nor show up in the consist drop down menu. If I choose NEW and build a consist in the service section, no problem. I can't see any difference in the actual files, but the files don't appear. However the Conbuilder consists appear if I choose an engine in the explore the route option when running the program. Any help or suggestions?
    Last edited by oldfrozencanuck; 10-31-2009 at 10:54 AM.

  2. #2
    Join Date
    Nov 1999
    Location
    North Port, Florida.
    Posts
    2,412

    Default

    Would you by chance be using Train Store in conjunction with your setup? If so, you have to add any consist created by Conbuilder into the Global and Route folders within Train Store using the Train Store provided means. However, all Consists created by the Activity Editor will automatically be placed there if you are using the Maintenance section of Train Store.

    Bob Edwards

  3. #3

    Default Not using TrainStore

    Thanks for the suggestion, but to my knowledge I am not using Train Store. I say "to my Knowledge", because I have no knowledge of what it is.

  4. #4
    Join Date
    Jun 2009
    Location
    Penticton, BC, Canada
    Posts
    446

    Default

    If you don't know what Train Store is, then it can't be your problem. As an aside, however, when MSTS opens it loads information from all your installed routes. That's why MSTS can take a while to fire up. Train Store is a wonderful little freeware program that "stores" (by your choice) the .trk files and the rolling stock required for the routes that you won't be playing at the moment, thus significantly reducing the time MSTS needs to load. You can obtain the Train Store program by searching the TrainSim.com file library for trnstr32.zip. You will also need the update, trnst322.zip, as well. I see now that there is also an update for compatibility with Windows 7.

    Now, about your consists...

    I had a similar issue when creating a consist in Conbuilder. It occurs to me that, in "explore route" mode, all the consists in your Trains/Consists folder become available. It also seems that when creating an activity, the consist created by Conbuilder won't show up in the list of available consists because it isn't in an activity of the route already.

    I have no idea if my hypothesis is correct, but a found a workable solution to the problem, as follows:

    Rather than using Conbuilder to create a consist from scratch, I first use AE to add the consist to the available services of the route by creating the consist in AE with only one locomotive. This somehow tells the route that the consist exists. I save the new activity and close AE. I then open Conbuilder and edit the consist to my liking. I save the edited consist, open up my activity in AE, and I'm off to the races.

    This may not be the best way to work around your issue, but I found it works for me.
    RoadMaster259
    "I love steel thunder"
    Blogspot: https://rockymountainsimulations.blo...mulations.html

  5. #5
    Join Date
    Sep 2004
    Location
    San Jose, California, USA.
    Posts
    286

    Default

    Quote Originally Posted by RoadMaster259 View Post
    It also seems that when creating an activity, the consist created by Conbuilder won't show up in the list of available consists because it isn't in an activity of the route already.
    I don't believe the consist needs to appear in any particular activity. I believe what happens is when the AE starts up it reads all the .con files currently present in the CONSISTS directory and those are the only ones it "knows" can be added to new services. If the AE itself is used to create a new consist, then it will add the new one to its internal list. Adding consists while the AE is open, however that is done (i.e. copy one from another source into CONSISTS), and it will not be noticed by the AE.

    I would classify it as yet another MSTS bug since one can use CB (or any other mechanism to get consist files) to create loose consists while the AE is open and it will notice these new consists.

    In the meantime, do as RoadMaster suggests. Using a tool to create consists outside of AE for use in services requires you do so either before you start the AE or, at least, close AE and reopen it after you've created your new consist.
    Dave

  6. #6

    Smile I'll go with this solution

    Roadmaster's suggestion works fine, so I will go with that, while all the time cursing the MSTS gremlins. Thanks for the info.

    Martin

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •