Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: RW_Tools and Railworks 2

  1. #1
    Join Date
    Nov 1999
    Location
    Penrith, Australia.
    Posts
    2,994

    Default RW_Tools and Railworks 2

    Please note that there have been changes in the Scenario.bin files in Railworks 2 which renders earlier versions of RW_Tools incompatible with the new version.

    I have posted an update on my site to RW_Tools v2.1.55 which fixes all the discrepancies I have found so far (but there may still be others).

    Please advise of any further problems found.

    The following are known problems which I have fixed:-
    1. In 'List Stock used...' options, you were advised of missing items '//' - now fixed
    2. Edit scenarios, clicking on a Consist would produce lists of missing files named Assetsbin - now fixed

    Both above occurred because of a new entry in some of the Scenario.bin files named <ReskinBlueprintID> - RW_Tools was getting this confused with the original <BlueprintID> sections.

    Mike

  2. #2

    Default

    Thanks for the prompt response, Mike !

    So far so good.

    CHEERS, O t t o.

  3. #3
    Join Date
    Apr 2010
    Location
    Cymru Gorllewin
    Posts
    377

    Default

    Quote Originally Posted by MikeSimpson View Post
    Please note that there have been changes in the Scenario.bin files in Railworks 2 which renders earlier versions of RW_Tools incompatible with the new version.

    I have posted an update on my site to RW_Tools v2.1.55 which fixes all the discrepancies I have found so far (but there may still be others).

    The following are known problems which I have fixed:-
    1. In 'List Stock used...' options, you were advised of missing items '//' - now fixed
    2. Edit scenarios, clicking on a Consist would produce lists of missing files named Assetsbin - now fixed

    Both above occurred because of a new entry in some of the Scenario.bin files named <ReskinBlueprintID> - RW_Tools was getting this confused with the original <BlueprintID> sections.

    Mike


    I had those problems yesterday, but knew you would fix them Mike.

    Thank you.

  4. #4

    Default

    I tried to update to the 2.1.57, and it won't let me do so. It says that in your notes on the website that you need a prior to the Version 2.0.96. I have 2.0.84 but it is licenced. Do I need to buy the licence again.
    David

  5. #5
    Join Date
    Dec 2006
    Location
    Leeds, England.
    Posts
    1,115

    Default

    Download the full installation version 2.1.41 from the site, along with the 2.1.57 update.

    Copy your Licence file (RS_Tools.lic) from the RW_Tools programme folder to somewhere safe.

    Install 2.1.41, followed by 2.1.57, and copy your licence file back into the RW-Tools folder.

    That should do it.

    Alan
    See this thread for my railway photos https://www.trainsim.com/vbts/showth...78#post1935978

  6. #6

    Default

    Alan I got the 2.1.41 copied and 2.1.57, But when I click on my icon on the desktop it still shows 2.1.41. I have to go to the 2.1.57 folder inside on my program files and click on the RW_tools.exe icon and then I get the box that says I have 2.1.57 licenced. Did i installed some wrong. I instaled 2.1.41 and 2.1.57 to the program files, with 2.1.57 going into the 2.1.41 folder.

    David

  7. #7
    Join Date
    Dec 2006
    Location
    Leeds, England.
    Posts
    1,115

    Default

    It sounds like it is just the label on the short cut that is still saying 2.1.41 - are you saying the splash screen says 2.1.57? If so, that is the version you are running.
    Alan
    See this thread for my railway photos https://www.trainsim.com/vbts/showth...78#post1935978

  8. #8

    Default

    Alan: The icon on the desktop. when I clicked on it, and the screen opens it says 2.1.41. The only way I see 2.1.57 i have to go into the folder in program files, and click on the exe files that is in the 2.1.57 folder.

    david

  9. #9
    Join Date
    Dec 2006
    Location
    Leeds, England.
    Posts
    1,115

    Default

    I'm not sure what you mean by 'the 2.1.57 folder'. The version 2.1.57 download is a zip file - you have to extract the contents from that file into your RW_Tools programme folder, wherever that is, overwriting any files that it wants to replace. What programme do you use to open and extract zips?
    Alan
    See this thread for my railway photos https://www.trainsim.com/vbts/showth...78#post1935978

  10. #10

    Default

    Alan: I use winzip. I installed 2.1.57 into it's own folder. Should I have put it in RW_Tools folder, and over wrote any files when asked to.

    David

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •