Results 1 to 4 of 4

Thread: MSTS Not Recognizing Brake Key Commands

  1. #1

    Default MSTS Not Recognizing Brake Key Commands

    Hello all,
    Ever since I installed MSTS years ago on my new computer the Default Key Commands for applying the brakes (both the Independant and Train Brakes) have not worked. As far as braking with the keyboard, all I can do is release them. Since I am running Vista, and couldn't use RailDriver, I just dealt with it and used the mouse as the only way to apply brakes without remapping the commands. They work when they are remapped to different keys but the two key commands used by default to release them dont respond in the game at all. Now that I have discovered RDTrain_Fix and am now able to use RailDriver, I discovered that these Key Commands have become an issue again because RDTrain_Fix uses the default key command scheme to talk to MSTS. I have tried resetting my keyboard (Key Command) settings in MSTS to default numerous times, I've tried re-installing the game, and tried looking at some keyboard settings from my control panel and still haven't figured out anything. Any information, help, or possible leads to where I can get more information about this is greatly appreciated.
    Thanks
    -Grant G.

  2. #2
    Join Date
    Nov 1999
    Location
    Another Planet
    Posts
    8,619

    Default

    Just a thought - have you tested this on another (new) keyboard? It might be the hardware.
    3DTrains - Home of the Feather River and Sherman Hill routes for MSTS

    Signature

  3. #3

    Default Permissions Denied by Vista

    If you didn't install MSTS on a Vista (or Win7) system according to the tutorials it will cause the problems you are experiencing.
    The turorials are here in the PCTech section of this forum and also at Steam4Me.

    Also true if MSTS was copied from another system as opposed to an 'install' from the two MSTS Install CD's.
    Last edited by Vince; 03-30-2011 at 01:26 PM.
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  4. #4

    Default

    Thanks for your help, I looked through the PCTech section and discovered an old post about the same issue. Turns out its interference with my infared reciever for my tv tuner remote. Weird how something so unrelated to trainsim can give it so much trouble, anyway Ive got all my key commands working again, thanks for the advice.
    -Grant G.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •