Results 1 to 2 of 2

Thread: RailDriver Not Connected?

  1. #1

    Default RailDriver Not Connected?

    Howdy All, I'm the new guy in town and also new to this whole train simulator world. I've looked for my situation and couldn't find anything on this forum so, if this is a repeat issue, please forgive me.

    I recently purchased the RailDriver controller, as well as MSTS to add to my hobby interests in everything train related. I'm also a model railroader who has been into the hobby since the early 70's and also became interested in the RailDriver when I learned it can be used with model railroading in DCC operations? Anyway, I have an issue with the RailDriver that I'm hoping someone can assist me with or point me in the right direction?

    I downloaded my RailDriver software to my recently refurbished Gateway computer w/Windows XP OS and ran into a problem when it came to connecting the controller? As is typical of my Gateway with Windows XP, the computer knows when you have connected hardware and will automatically pick up the hardware and finish the download process on those systems that require the hardware to be connected to complete the download 100%. After downloading the software disk and waiting for the prompt to connect the controller, this is where I ran into my problem?

    The software download never prompted the command to connect to controller so, I uninstalled the RD software and reinstalled it once more. Once I restarted the computer after the point in the software tells you to do so, I then connected the controller just like you would when prompted to do so. The computer aknowledged the hardware being connected by the sound tone that is typical with Windows XP however, I get an error message that reads "Files Corrupted" when connecting the controller? I click on the error message which closes the window, then I click on the RD start-up icon on my screen and when the RD Manager window opens to start playing, every time I click on "Play", I get an error message that reads "No Controller Connected".???

    I tried to uninstall the software once again to start from scratch and now it won't let me uninstall the software now matter what I do? It's been quite frustrating and I'm out of ideas on what to do? This is my first attempt at doing anything of this nature on my computer and I'm wondering if I'm doing something wrong or if there's a problem with the RailDriver controller or software? Like I said earlier, the RailDriver is a used unit and I'm now wondering if the unit itself is defective from being damaged by the previous owner? I'm not real educated when it comes to these computers but I am educated enough to know not to connect any hardware to a computer without first reading all the instructions that comes with these sorts of things. It was suggested by a friend who's an experienced gamer that the previous owner may have connected the controller to a computer prior to installing the software which could have very well damaged the controller itself? Is that a possibility???

    Thanks in advance for any insight/imput into my situation and hopefully someone can help me with this issue?

    Thanks, Walker.

  2. #2
    Join Date
    Nov 1999
    Stevens Point, Wisconsin, USA.


    ". It was suggested by a friend who's an experienced gamer that the previous owner may have connected the controller to a computer prior to installing the software which could have very well damaged the controller itself?"

    Whatever you do don't take advice from that guy. Software drivers or the absence of software drivers can't damage interface hardware. The raildriver itself could be damaged by dropping it from a bomb bay at 30,000 feet, but unless there's obvious cracks in the casing it's unlikely.

    Lower left corner of the desktop, START, CONTROL PANEL, ADD REMOVE PROGRAMS. Look for Raildriver in that list, uninstall however many are there. After that;

    Make sure you have the correct file for MSTS, it works with other train sims which require different interface software. Full instructions that came with it originally can be had in a PDF file;

    Also a link there to contact tech support if you can't get it running, if the Windows hardware wizard picks it up as a USB human interface device the problem is most likely software rather than hardware. If the hardware wizard is not recognizing it, try plugging into a different USB port, and if all else fails START, CONTROL PANEL, ADD HARDWARE, see if you can kick start the wizard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts