As published, the default AEM-7 engine that comes with the Northeast Corridor, does not work with Rail Driver.

I have created a clone of that engine and revised some bin files that will allow that engine configuration to be used with Rail Driver.

The three files included in the rwp are:

Assets\RSC\NorthEastCorridor\RailVehicles\Electric \AEM7\Default\Engine\AEM-7 Engine - RD.bin
Assets\RSC\NorthEastCorridor\RailVehicles\Electric \AEM7\Default\Simulation\AEM-7 SimScript - RD.lua
Assets\RSC\NorthEastCorridor\RailVehicles\Electric \AEM7\Default\Simulation\AEM-7 Simulation - RD.bin

They will not overwrite any existing files. They will create a new engine called "EMD AEM-7 RD". You can use RW_Tools to substitute this engine in a scenario in place of the default "EMD AEM-7 Amtrak 5"

NOTE: You must already own the EMD AEM-7 for these files to work.

I would appreciate any comments about what does and does not work with this engine.

AEM7-RD.zip