Results 1 to 5 of 5

Thread: Screenshot feature not working for me in OR

  1. #1
    Join Date
    May 2010
    Location
    St Paul, MN
    Posts
    117

    Default Screenshot feature not working for me in OR

    I hit PRINT SCREEN and nothing really happens. The game pauses for a second but no pictures ever show up anywhere. What the heck am I doing wrong? Print Screen works fine when running the Normal MSTS but not when I run OR.

  2. #2

    Default

    Look in your My Pictures folder for an OpenRails subfolder... at least that's where mine have been going.

    Something else to consider is a third party app. I've been using Wisdom-soft's Screen Hunter (free version) for a while, and am quite happy with it. You can set up a hotkey combination to work in any application, and it writes out to a single directory for screen grabs. There's a choice of grabbing the full screen or just the active window, with or without mouse.

    There are dozens of other apps that do the same thing... this is the one I stumbled upon for work, and it carries over quite nicely for play.

  3. #3
    Join Date
    May 2010
    Location
    St Paul, MN
    Posts
    117

    Default

    After some digging I found out that I needed to hit the 'Windows' button and the Print Screen button at the same time. Now I have an Open Rails folder in my Pictures folder. Maybe this needs to be made note of on the F1 screen?

  4. #4
    Join Date
    Oct 2009
    Location
    United Kingdom
    Posts
    444

    Default

    Open Rails takes the screenshot when you press Print Screen on its own; it does not need a modifier. However, it seems that in fullscreen there is reasonable of interference from something else (I'm not sure what yet, it might vary by Windows version or graphics card/drivers) which prevents Open Rails even seeing the key press, even though Windows still takes the screenshot (and puts it on the clipboard).
    James Ross
    Open Rails Management Team

  5. #5
    Join Date
    Oct 2009
    Location
    United Kingdom
    Posts
    444

    Default

    Having spent a few hours fiddling with various keyboard things, I believe I have fixed the problem with Print Screen in fullscreen. I still don't know what's eating the key through the normal input channels, but I have added a special check just for Print Screen using a different API that seems to be unaffected. The fix is in V1375 and should be in the next experimental build.
    James Ross
    Open Rails Management Team

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->