Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: MSTS menus scrambled (Windows 8)

  1. #1

    Default MSTS menus scrambled (Windows 8)

    Hello, hope this has not been covered, did a search and did not see anything. I installed MSTS as per the instructions at Steam4me, and the program seems to work fine save one crippling issue - the menu screens are covered with various characters (letters, numbers, accent marks, etc) in black and white, rendering them unusable. If I manage to wade through the unreadable screens and actually try to run a train/activity, the sim works fine, so I believe this is just an issue with the way the menus are displaying. I can run the MSTS content in Open Rails but am hoping to get MSTS itself working so I can use the activity editor, etc. I have attached two screenshots to give an example of what I am describing. Many thanks for any tips!

    System specs: Windows 8 (64 bit), intel i5-3230M, Intel HD4000 graphics
    Attached Images Attached Images

  2. #2


    Hi Andy !

    I got a feeling that it is the integrated Intel graphics which are causing this which are not really suitable for graphics intensive games and simulators.

    Reading this might help:

  3. #3


    Hi Otto, thanks for the tip! I want to upgrade but can't quite afford it at the moment. I realize that the integrated graphics are not really desirable for simulators but the thing is my experience with this system (mainly with Railworks to this point) has been that it performs better than it *should* given the specs. I don't know why exactly this is. But I can run many Railworks routes at medium settings with TSX on and still get a usable frame rate. So I figure I should be able to at least run MSTS. The couple times I managed to sort of blindly get through the menus to the gameplay itself it did in fact run with no problems (same thing when I try it with Open Rails). That makes me think the issue might be specific to the way the menus are displaying.

  4. #4


    Msts graphics utilize computer resources differently. So even though you can run railworks on a system is no guarantee that same system will run msts.

  5. #5


    I now see that someone else has posted a thread reporting the same issue and also with an intel integrated graphics setup, leading me to believe that may indeed be the issue. It's possible I'll have to run MSTS content using Open Rails and stick to Railworks for activity creation, route building, etc. But if anyone has other suggestions by all means let me know!

  6. #6


    Hi Randy !

    First run the mprofile.exe in your Train Simulator folder which records the graphics used, making sure sure it has been set to run as Administrator. It does not appear to be doing much !

    That not having fixed your MSTS Menu screen then after un-zipping this:
    paste its GUI folder into your Train Simulator folder and WIN must ask you for permission to do so.

    If you are using moded files in your GUI folder then back it up first !

  7. #7


    Thanks for uploading the additional folder Otto, tried it and no dice unfortunately!

  8. #8


    Quote Originally Posted by Randy S View Post
    Thanks for uploading the additional folder Otto, tried it and no dice unfortunately!
    Run the Launcher.exe in your Train Simulator folder and try some of its options !


  9. #9


    It's your integrated graphics. You can try all these doodads, but bottom line is, integrated intel graphics produce weird MSTS graphic anomalies, that can only be fixed by updated graphics card. Avoid ATI/Radeon cards, they have released two new drivers, but I've not been able to download them to see if MSTS will work on my W8 computer with ATI video. But everyone that has gone Nvidia the true windows 8 Nvidia graphics cards, report msts works flawlessly.

  10. #10


    I'm starting to think that's probably the case. Thanks to folks for the help, will just have to upgrade eventually! At least I can run MSTS routes if I use Open Rails.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts