Results 1 to 8 of 8

Thread: Two questions

  1. #1
    Join Date
    Oct 2006
    Location
    Lancaster, Pennsylvania
    Posts
    2,206

    Default Two questions

    One, the reverser lever on my RD unit has lost it's 'notches' so to speak, been so used that the lever just slides all the way instead of clicking in to forward, neutral, reverse, etc.. Any way to fix this? Two: I've lost the cord for the speaker and what not. Where might I find a replacement power cord?

  2. #2
    Join Date
    Feb 2005
    Location
    Cinnaminson, New Jersey, USA.
    Posts
    596

    Default

    Question 1 : Mine does the same thing, no notch on Reverser. But, ( and I've had mine for years ), I don't remember it ever having notches, but could be wrong on that.

    Question 2: I would contact P.I. Engineering to see what a replacement costs.
    Glenn Duba
    Cinnaminson, NJ

  3. #3
    Join Date
    Oct 2006
    Location
    Lancaster, Pennsylvania
    Posts
    2,206

    Default

    Yo RD guys, I've left ya a message, tried calling a few times.... You intend to get back to me or what?

  4. #4
    Join Date
    Nov 1999
    Location
    Another Planet
    Posts
    8,609

    Default

    IIRC, their hours are M-F, 8am to 5pm Central.
    Cheers!
    Marc - 3DTrains - Home of the Feather River and Sherman Hill routes for MSTS

    Signature

  5. #5

    Default

    Quote Originally Posted by Komachi View Post
    Yo RD guys, I've left ya a message, tried calling a few times.... You intend to get back to me or what?
    Hi, maybe there is a problem with one or both of our phone systems, because we've received no messages from you at all. If there is a phone problem then I'd suggest sending us an email us at [email protected] .
    Kind regards,
    -Liam

  6. #6

    Default

    Did you resolve this? I too had the same problem. PI would not even quote me a price to repair. They stated that the repair cost would be greater than buying a new RD unit. A replacement throttle would not fit due to an apparent change in the design of the connector rods. I just used a label maker to put a mark by where MSTS said the throttle changed.

  7. #7
    Join Date
    Oct 2006
    Location
    Lancaster, Pennsylvania
    Posts
    2,206

    Default

    Quote Originally Posted by LiamRailDriver View Post
    Hi, maybe there is a problem with one or both of our phone systems, because we've received no messages from you at all. If there is a phone problem then I'd suggest sending us an email us at [email protected] .
    Kind regards,
    -Liam
    I've phoned you guys again during the course of September and October, and used your email. Still nothing. Do you guys really care -that- little for your customer base?

  8. #8
    Join Date
    Feb 2005
    Location
    Cinnaminson, New Jersey, USA.
    Posts
    596

    Default

    I recently had to contact PI for a price on a USB cable, as mine broke. Contacted PI using the [email protected], received an answer back same day. Took a few days to get a price quote, but after only about 10 days had the new cable. I think their customer service was very good.
    Glenn Duba
    Cinnaminson, NJ

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •