Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: TS2014 Benchmarking

  1. #11

    Default

    The game is absolutely compatible with radeon cards. I have no problems whatsoever with my 5 year old HD 5770.

  2. #12

    Default

    Quote Originally Posted by skaliwag66 View Post
    The game is absolutely compatible with radeon cards. I have no problems whatsoever with my 5 year old HD 5770.
    But do you have a AMD processor 8320? I bet I know the problem. This program is not compatible with AMD multicores and poorly optimised for AMD processors in the threading. Thats why its not using all my processor. I guess. FSX, Men of War runs like **** on this monster rig of mine. Then I can max out everything pretty much on Arma 3.
    Last edited by marx_lenin_mao; 06-19-2014 at 10:27 AM. Reason: language

  3. #13
    Join Date
    Jun 2013
    Location
    Home Of The Americas Cup
    Posts
    1,167

    Default

    No it is not optimised for multi cores as it only uses one on my Intel machine.
    Intel i5-2500K 3.3GHz Quad Core, Asus P8Z 68-V LE MB, Asus GTX 960 Strix OC 2gb graphics card, Windows 10 Home 64 bit, 8gb Corsair Vengeance DDR3 ram , Viewsonic VX2452mh LED 1080P HD Monitor. Seagate Barracuda 1 TB 64MB Sata3 HD. Computer Gamer Since 1985

  4. #14
    Join Date
    Jan 2009
    Location
    Winnipeg,Manitoba, Canada
    Posts
    647

    Default

    I have a monster gaming computer that I built
    Pray tell, what is this monster gaming computer you built? The specs please.

  5. #15

    Default

    Quote Originally Posted by krellnut View Post
    Pray tell, what is this monster gaming computer you built? The specs please.
    AMD FX8320 8 core 3.5 ghz
    FX990 Sabertooth R2 motherboard
    1tb 7200 RPM hard
    1 Chronos SSD 120gig
    16 gig 1600ghz DDR3 Ram Duel Channel
    Radeon R9 290 4 gig DDR5 Video Card
    CoolMaster Hydro 120 Liquid Cooling
    Last edited by marx_lenin_mao; 06-20-2014 at 01:04 AM. Reason: details

  6. #16
    Join Date
    Jan 2009
    Location
    Winnipeg,Manitoba, Canada
    Posts
    647

    Default

    Nothing wrong with your computer. This is my machine, and it still studders;

    http://railworksamerica.com/forum/vi...p?f=33&t=11128
    Last edited by krellnut; 06-20-2014 at 10:58 AM.

  7. #17
    Join Date
    Nov 2007
    Posts
    2,633

    Default

    Quote Originally Posted by marx_lenin_mao View Post
    I have 16 gigs of DDR3 RAM. And on default routs i get max 21 FPS
    Doesn't matter. It's a 32Bit application. You get 2GB physical RAM use and up to 4GB of VAS (on a 64Bit OS) or the game takes a crap. It's relying heavily on the pagefile (your HDD in laymans terms) to buffer assets before sending them to the framebuffer of your video card. TS14 easily eats up 2GB of your physical RAM then turns to VAS (paging) for the rest. Any time it stutters you can look at your HDD and watch it light up because it's loading assets straight off the drive (pagefile) instead of RAM before sending it to the frame buffer.

  8. #18

    Default

    I really don't think your processor is at fault.
    Can you overclock your CPU? You have water cooling. I dunno about that chip but if you can get it up to 4 or higher you'll experience a vast improvement. Upgrading my CPU from 3.2 to one that I got to 4.7 doubled my frame rates.

  9. #19
    Join Date
    Jun 2013
    Location
    Home Of The Americas Cup
    Posts
    1,167

    Default

    You can delete from the edit your post page.
    Intel i5-2500K 3.3GHz Quad Core, Asus P8Z 68-V LE MB, Asus GTX 960 Strix OC 2gb graphics card, Windows 10 Home 64 bit, 8gb Corsair Vengeance DDR3 ram , Viewsonic VX2452mh LED 1080P HD Monitor. Seagate Barracuda 1 TB 64MB Sata3 HD. Computer Gamer Since 1985

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->