Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: Adjacent Track pieces are not loaded

  1. #11

    Default

    I'm saying Platform as a scenary object. I've not added Platform interactive object (where we need to give Platform name, No. of pax etc).

  2. #12

    Default

    Actually, what happened to me was:
    I was building the yard consists as many as 19-20 tracks. The yard was nearly completed. After adding 5 tracks in my route, I always saved it. All things were going good. I added two "Platform Scenary Object" (not Platform interactives). And saved it also. After sometime, I put a 100m track to one end of the track at the yard. Oh! My RE hanged. Without showing any error, it crashed. I again re-opened RE, all tracks were present except the "19 tracks with many switches" at the yard area. The "Platform Scenary Object" also vanished. The blue poles, red poles at the track points and the white lines which are normally visible above the tracks were present. But, track pieces were not shown at the yard. I selected the tracks (after it, all tracks were not visible) before the yard, it showed "Adjacent track pieces not loaded. Can not select the track". Then, I checked the integrity of route. It showed some 3019 errors, which was posted in the same blog earlier. What should be the error?

  3. #13

    Default

    Making a simple mistake like saving with a track or road section selected will give these results.

    When I was building the NEC4, in complex areas I backed up the route every 2 to 3 hours of editing. It take 15 minutes and that includes getting a cup of coffee to enjoy while watching the backup run.

    How to backup? Just compress the route folder using WinZip of WinRar. So simple and so safe!
    I'm able to burn 4 route backups on a DVD but that will vary with route size.

    You may ask how often to backup? The answer to that leads to another question . . .
    'How much work are you willing to have to repeat?'
    regards,
    Last edited by Vince; 01-13-2016 at 12:35 AM.
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  4. #14

    Default

    Yes sir. Same tile. -2102,13361

  5. #15
    Join Date
    May 2010
    Location
    Spurgeon,TN
    Posts
    672

    Default

    Hi,

    I still think it was the tile object count, though when it happens to me, the RE just keeps going and going instead of hanging. I don't find the missing stuff until I come back much later. Then its replace the 4 TDBs with a backup, as well as the w tile. A couple of times it corrupted the (hexadecimal).t file as well.

    Large Yards are possible, in the one in the screen grab I used the widest piece possible. A single A10t100m instead of 10 A1t100m, A9t25m instead of 9 A1t25's, etc. This will help lower the object count in the tile. There are some A10t250m in there.
    scrgrb0.jpg

    Everything east of the 2 track with stone ballast is the East half of the Erie Railroad's Croxton Yard in Secaucus NJ, around 1919. The light gray are Icing platforms for the wooden, bunker type refrigerator cars of the period.

    Doug Relyea
    Making stuff that works, using outdated Software on outdated Hardware.

  6. #16
    Join Date
    May 2010
    Location
    Spurgeon,TN
    Posts
    672

    Default

    Hi,

    Just saw your post about the tile. That would be the tile object count that caused the problem. What I suggested about the widest track piece possible should help. Take your last backup, and where you can, use wider, and/or longer pieces. When you have changed all you can, save that and exit the RE.

    Reopen the RE, jump to that tile and the object count will be lower than when you left.

    The last pieces in my screengrab were added about 100 pieces at a time, as I got close to the tile object limit on my machine.

    Doug Relyea
    Making stuff that works, using outdated Software on outdated Hardware.

  7. #17

    Default

    How can I know the object limit for a tile?
    Just opened RE, jumped to Tile x: -2102 Tile z: 13361. In Placement box, it is shown Tile Objects: 0. And only in this tile, no tracks are visible. But, blue pole, red pole visible.

  8. #18
    Join Date
    May 2010
    Location
    Spurgeon,TN
    Posts
    672

    Default

    Hi,

    The object limit can only be found by bad experiences like what happened to you. And others, including myself.

    The object count will be zero because the .w file has become corrupt.

    Before you do the steps below, ensure you have a backup from before the corruption.

    Close out the RE. Open the Trainsim folder, go to the route folder, open the World folder. Find w-002102+013361.w and its ~w.bk. If you open the .w file with notepad, it will be empty except for the header.

    Delete or move the .w file, and rename the ~w.bk to .w. Go back to the Route folder. Delete or move the .tdb, .rdb, .rit, .tit files. Rename their backups ~rit.bk to .rit, ~tit.bk to .tit, ~tdb.bk to .tdb, and ~rdb.bk to .rdb.

    This should work as long as you did not do a save while the tile was corrupt. If you did do a save while the tile was corrupt, it would be safest to remove the current route folder, and replace it with a backup.

    This type of fail was the weakest point in MSTS, and is why a lot of people departed it for another Sim.

    Doug Relyea

  9. #19

    Default

    While running "back up route" in RE, I found 904 tile objects for that tile (-2102,13361). If, I remove all the tracks from that tile, and save the route, will it be create a problem? Can I remove all items from that tile in a single click? As, to delete 904 items from that tile, I will have to click and press delete button for 904 times.
    Last edited by Prakash2020; 01-13-2016 at 02:57 AM. Reason: To ask another question

  10. #20
    Join Date
    May 2010
    Location
    Spurgeon,TN
    Posts
    672

    Default

    Hi,

    It should not cause a problem, removing the track from the backup. When I have to do that, I remove 3 to 5 pieces at a time, then save. This makes for smaller changes to the w file and TDB, and is less prone to errors.

    By the way, I would guess the world object limit on your machine to be around 3100. Given the fail turned up 3109 errors in the TDB, I would be cautious placing anything past 3100.

    Doug Relyea

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •