Results 1 to 7 of 7

Thread: Invisible cars in consist

  1. #1
    Join Date
    Apr 2005
    Location
    Sacramento, CA, US.
    Posts
    30

    Question Invisible cars in consist

    This is a new issue for me but I'll bet some of you more program savy folks can point me in the right direction!

    I have searched for a fix to this problem but didn't find anything that seemed to match.

    Using the MONON17YARDS template i created an activity. I'm using the latest "stable" OR version.

    Backing up to the initial string of cars I noticed two long gaps within the consist. There are three cars that do not appear visually. Shift+F7 shows the car UIDs, right where they should be. The consist is intact. Pulling out of the yard, the gaps move right along with the rest of the train.

    I checked the consist with Route-Riter and the cars are there. I compared the spelling of the ace and wag files for each car and they match.

    What is my next step in fixing this?

    Bill

  2. #2
    Join Date
    Nov 1999
    Location
    North Port, Florida.
    Posts
    2,411

    Default

    You are not connecting to a string of LowPoly cars are you? I have seen LowPoly strings that have gaps placed between cars. On the Monon route, Rick Berg has a lot of LowPoly cars placed all over his yard tracks. LowPoly car strings are meant to stay where they have been placed. In the activity editor they are not shown, but are placed where the track does not show either.

    Bob Edwards

  3. #3
    Join Date
    Aug 2004
    Location
    Yonkers, New York, USA.
    Posts
    82

    Default

    Take a look at the OR log that will appear on your desktop after loading the activity. It will tell you all of the problems that the program encountered during loading. A simple mistake in the shape file will cause the car not to appear in OR.

  4. #4
    Join Date
    Nov 1999
    Location
    Huntsville, AL
    Posts
    4,177

    Default

    Quote Originally Posted by arremm1 View Post
    Take a look at the OR log that will appear on your desktop after loading the activity. It will tell you all of the problems that the program encountered during loading. A simple mistake in the shape file will cause the car not to appear in OR.
    Arremmm1 is correct. Just a simple spelling error will result in what you describe.. Compare the shape line in the WAG/ENG file and the filename. As bhartson said running ConBuilder's Wagon test will result in a Shape File error report. MSTS will give a Failed to Shape error, then a Can't add ____ to World error, and then MSTS will crash to desktop. OR will just display nothing except if it is an ENG in a Player or AI consist you will see the exhaust. And OR will have an Warning in its log about a missing shape.

    BTW this should have been posted in the OR forum.
    Last edited by crstagg; 02-07-2016 at 02:13 PM.
    Charles

  5. #5

    Default

    Use Archibald to look for an error in the Shape file. Lots of rolling stock have them. Usually, it's an extra slash or other character in the file, or a missing parentheses. 90% of the time, that is what will cause the behavior that the OP has described.

  6. #6
    Join Date
    Nov 1999
    Location
    North Port, Florida.
    Posts
    2,411

    Default

    wwhall,
    Yes and the lines that one needs to check first is to look for the brackets that form the Name line along with the quotation marks, and there is often a double ) ) at the end of the InertiaTensor line (about six lines from the top) instead of those close parens being seperated by an enter character. I don't think that kicks in as an error until that car is actually used in a consist.

    Bob Edwards

  7. #7
    Join Date
    Apr 2005
    Location
    Sacramento, CA, US.
    Posts
    30

    Default

    Thanks for all the input guys!

    Bob, you nailed it! The "car" Activity Generator placed in the consist is a yard string. Thanks!!

    Bill

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •