Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Signal problems on the Leeds-Settle-Carlisle by Renzo Grassi

  1. #1
    Join Date
    Nov 1999
    Location
    New York City
    Posts
    354

    Default Signal problems on the Leeds-Settle-Carlisle by Renzo Grassi

    I understand that the signals on the Settle-Carlisle route were... "unique". But usually I've been able to fix "clearance to proceed" problems by simply increasing the SignalNumClearAhead (x) parameter in the sigcfg.dat file (or by making sure that each signal HAD that parameter!). But this route, the Leeds-Settle-Carlisle in 1910-1920 route by Renzo Grassi has got me stumped, so I wonder if anyone has any ideas.

    Heading north from Leeds in an activity with absolutely NO OTHER traffic in the whole route, I am simply unable to clear a signal midway between Calverly and Apperley. I'm running in autopilot in ORTS. I have all signals set in the sigcfg.dat file to SignalNumClearAhead(6). But nothing budges the signal. Any suggestions of things to try? I tried setting the signal count to 2 less than the number of signals defined, in the hope of simply "commenting out" the virtual signals, but that threw a fatal ORTS error... so no go.

    Thanks!

    Jeff.................................

  2. #2
    Join Date
    Jun 2013
    Location
    Minnesota
    Posts
    1,574

    Default

    If the number of types at the top of the file is not the actual number of signal types, it will not work. Have you checked to see if there is a script section for this signal types in the sigscr file? That would cause a signal to invariably show its most restrictive aspect. Have you had success clearing it in dispatcher mode?

  3. #3
    Join Date
    Nov 1999
    Location
    New York City
    Posts
    354

    Default

    There are scripts for these types in the sigscr file, but I'm not knowledgeable about them and how to adjust them. I did go into manual mode and attempted to clear the signal, but the signal didn't respond, nor was the train able to proceed. Any suggestions on when I can find out details about how to modify the sigscr file?
    Thanks for the input!

  4. #4

    Default

    G'day Jeff, I am sorry I cannot assist with your problem, but I was trying ti find this route without success. Could you please tell me where to find this route.
    Regards
    Barrie

    Jeff, I have found it, all good. now to do some driving.
    Last edited by gremlin1812; 07-25-2017 at 05:55 PM.

  5. #5
    Join Date
    Nov 1999
    Location
    New York City
    Posts
    354

    Default

    For others who may be looking for his beautiful routes, here: http://www.ildeposito.net/

    Jeff...................

  6. #6
    Join Date
    Jun 2013
    Location
    Minnesota
    Posts
    1,574

    Default

    I'll download it and see what I find. I have had some trouble with signals inexplicably not clearing, but dispatcher mode has always fixed that. I was in explorer mode at the time, so maybe that was my problem

  7. #7

    Default

    Jeff, I can duplicate your problem in MSTS. Even pressing the tab key does not let me pass. In explore mode, both arms stubbornly stay at stop and cannot be moved. I did find another signal of the same type further down the route and that signal works as expected. So it seems unlikely that there are any problems with the sigcfg or sigscr files.

    Does the OR log give you any clues?

    In RE I removed the signal, made a save, reinstalled the signal, made a save and the problem disappeared.

    If anyone is reluctant to use RE, pm me your email address and I'll send you a zip file of the five altered files - the four databases and one world file.

    Regards,
    Chris

  8. #8
    Join Date
    Feb 2005
    Location
    Hartshill, N. Warks, UK.
    Posts
    12

    Default

    Quote Originally Posted by tonyhap View Post
    Jeff, I can duplicate your problem in MSTS. Even pressing the tab key does not let me pass. In explore mode, both arms stubbornly stay at stop and cannot be moved. I did find another signal of the same type further down the route and that signal works as expected. So it seems unlikely that there are any problems with the sigcfg or sigscr files.

    Does the OR log give you any clues?

    In RE I removed the signal, made a save, reinstalled the signal, made a save and the problem disappeared.

    If anyone is reluctant to use RE, pm me your email address and I'll send you a zip file of the five altered files - the four databases and one world file.

    Regards,
    Chris
    Same for me; I marked the signal as failed in the Activity Editor and was able to pass it. Also I selected track Apperley 4 in the Activity Editor and was able to run past the location at MP202 on the extreme left track.

    John

  9. #9
    Join Date
    Nov 1999
    Location
    New York City
    Posts
    354

    Default

    Great find! Thank you!! I really thought it was some esoteric control function in the signal settings.

    Jeff......................................

  10. #10

    Default

    Quote Originally Posted by tonyhap View Post
    Jeff, I can duplicate your problem in MSTS. Even pressing the tab key does not let me pass. In explore mode, both arms stubbornly stay at stop and cannot be moved. I did find another signal of the same type further down the route and that signal works as expected. So it seems unlikely that there are any problems with the sigcfg or sigscr files.

    Does the OR log give you any clues?

    In RE I removed the signal, made a save, reinstalled the signal, made a save and the problem disappeared.

    If anyone is reluctant to use RE, pm me your email address and I'll send you a zip file of the five altered files - the four databases and one world file.

    Regards,
    Chris
    Dear friend,
    I'm the author of this route and I did not see this bug.
    Can you send me the five zip files? I will also add a patch on idelposito.it
    Thank you.

    bye, renzo.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->