Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Rotate and Translate Don't Visually Appear to Work

  1. #1
    Join Date
    Jan 2007
    Location
    Just south of NYC
    Posts
    1,474

    Default Rotate and Translate Don't Visually Appear to Work

    Have the settings set to: usenNumPad = true

    If I choose an object via SELECT and ROTATE commands, then try to use any arrow or numpad arrow keys (or any keys), I cannot get the highlighted object to visually show any movement - around, up down or sideways. However, when going to exit TSRE, the window shows the tile name as if I had made changes to the object - even though visually nothing happened.

    Any suggestions? Am I missing something really obvious? Like is the spelling of the command switch correct??
    Thanks in advance
    Chris
    "True rail fans have two favorite railroads. The B&O and one other."

  2. #2
    Join Date
    Jun 2013
    Location
    Minnesota
    Posts
    1,135

    Default

    I will assume 'usenNumPad = true' is a typo in the post, and not in the config file.

    Is NumLock on? If it isn't, the num pad arrow keys won't work

  3. #3
    Join Date
    Jan 2007
    Location
    Just south of NYC
    Posts
    1,474

    Default

    First, I'm using v6956. I'd like to get this working properly. BTW, Terrain editing works fine as does track placement and TDB modifications.

    "usenNumPad=true" is not a typo, without that typo NONE of the arrow keys work (Home, PgUp, etc) four arrow keys and arrow keys in NumPad - for even navigation.

    I've attached a screen shot to show that I've activated the Rotate mode - but nothing happens no matter what key I press
    TSRE_NoRotate.jpg
    Chris
    "True rail fans have two favorite railroads. The B&O and one other."

  4. #4

    Default

    Hi Chris
    I have never had the problems you are finding. I have not used v6956, I went from v6951 to v6963. Also I have learned something new looking at your image, I have never rotated this way. I select the object, press R to rotate or T to translate on the keyboard, and use the numbers above the letters to get the object to move. The objects move on screen each time a key is pressed.
    I have just found that it also works using the numberpad as well, and also by the method you show in the image!
    As to why it doesn't work for you, I wonder what happens in other versions of TSRE, have you got an older version that worked OK? It might be worth giving that another go. If it works you know it is a problem with your current version, either in the program or the installation.
    Garry

  5. #5
    Join Date
    Jan 2007
    Location
    Just south of NYC
    Posts
    1,474

    Default

    just backdated to v6946 and rotation and translation work fine. So now I need to see which update broke things for me.
    Chris
    "True rail fans have two favorite railroads. The B&O and one other."

  6. #6
    Join Date
    Jan 2007
    Location
    Just south of NYC
    Posts
    1,474

    Default

    Just tested each version moving backwards - v6955 is the last version that numpad arrows or any other arrows work on objects for me.

    Running Win7 SP! + latest updates. Until Goku suggests some course of action I will be staying with the functionality at that release.
    Chris
    "True rail fans have two favorite railroads. The B&O and one other."

  7. #7
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    530

    Default

    Try .6963 first.

  8. #8
    Join Date
    Jan 2007
    Location
    Just south of NYC
    Posts
    1,474

    Default

    Unfortunately, I get this image using that version:
    TSRE_6363.jpg
    Chris
    "True rail fans have two favorite railroads. The B&O and one other."

  9. #9
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    530

    Default

    This version has a difficult installation method. It is explained somewhere at this forum.

  10. #10
    Join Date
    Jan 2007
    Location
    Just south of NYC
    Posts
    1,474

    Default

    Got v6963 installed correctly. All is not well. Rotate and Translate do NOT work via numpad arrows or any other arrows. Rotate does not work with mouse, but Translate does work with mouse. Go figure. Love the additional features, so I'm bummed that I have to keep to v6955
    Chris
    "True rail fans have two favorite railroads. The B&O and one other."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •