Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Just my thoughts

  1. #1

    Default Just my thoughts

    Hello,

    I have been using TSRE for a while to make a test route. I think that a few changes should be made to this program.

    The things listed here are only my own ideas.
    1 – Make the pointer (cursor) change looks with each different application. The same as Microsoft Route Editor. (RE) It is so much easier to tell what is going on that way instead of looking for a button that has been pushed.
    2 – I like the use of 'F' keys instead of hunting for a button to push for different application. Quicker and easy to do with out chasing a mouse pointer around the screen.
    3 – I can't find 'Forests' in the TSRE but they show up alright in RE. What do you think is wrong with that?
    4 – Don't see the need to control whether track is applied to the data base. Do the same as RE and on a save put info in TDB. I have never had a problem with going back to delete or change track in RE.
    5 – It appears the Control + Z (undo) only works with objects that have been placed. Tried this with a change to terrain with no success.
    6 – How can you make the cursor go to deselect mode. Seems that no matter where you click it is still active and you never know what might happen next click on the mouse.
    7 – How can you change the default setting for Terrain Collision mode? Crazy to start out able to go below the surface. I think you can change to this mode as you need. Most likely if you lost something below the surface or want to see the wire form when setting the terrain to different elevations.
    8 – The printed information is rather vague. I have most of the Book printed and 14 pages of info that Vince gave in his postings. Still a lot of questions come up.

    I feel it's a good think I can still use RE because it has got me out of trouble with this test route. Actually I ended up using RE to make the test route I am working with. Just this morning I was changing some terrain texture and got a white tile (don't know how) and had to use RE to get some texture on it. I could not select that tile, in TSRE, to make any changes to it.

    I realize this is a 'work in progress' so there will be improvements to TSRE over time, I just wanted to express my thoughts at this time. I made a route many years ago with RE and it was uploaded here. Just getting back into MSTS after a long stretch of other interest.

    All of my thoughts printed here …....... are just that.

    Glenn

  2. #2

    Default

    Hi Glenn

    3. Forests are listed under Other
    5. CtrlZ works for me to undo terrain. Just raised a bit, CtrlZ and it was back where it started.
    7. There is a line in settings.txt that does this -- cameraStickToTerrain = true

    I use TSRE exclusively now. I can't remember the last time I opened a route in MSTSRE
    Garry

  3. #3

    Default

    Quote Originally Posted by Magoo View Post
    Hello,

    I have been using TSRE for a while to make a test route. I think that a few changes should be made to this program.

    The things listed here are only my own ideas.
    1 – Make the pointer (cursor) change looks with each different application. The same as Microsoft Route Editor. (RE) It is so much easier to tell what is going on that way instead of looking for a button that has been pushed.
    2 – I like the use of 'F' keys instead of hunting for a button to push for different application. Quicker and easy to do with out chasing a mouse pointer around the screen.
    3 – I can't find 'Forests' in the TSRE but they show up alright in RE. What do you think is wrong with that?
    4 – Don't see the need to control whether track is applied to the data base. Do the same as RE and on a save put info in TDB. I have never had a problem with going back to delete or change track in RE.
    5 – It appears the Control + Z (undo) only works with objects that have been placed. Tried this with a change to terrain with no success.
    6 – How can you make the cursor go to deselect mode. Seems that no matter where you click it is still active and you never know what might happen next click on the mouse.
    7 – How can you change the default setting for Terrain Collision mode? Crazy to start out able to go below the surface. I think you can change to this mode as you need. Most likely if you lost something below the surface or want to see the wire form when setting the terrain to different elevations.
    8 – The printed information is rather vague. I have most of the Book printed and 14 pages of info that Vince gave in his postings. Still a lot of questions come up.

    I feel it's a good think I can still use RE because it has got me out of trouble with this test route. Actually I ended up using RE to make the test route I am working with. Just this morning I was changing some terrain texture and got a white tile (don't know how) and had to use RE to get some texture on it. I could not select that tile, in TSRE, to make any changes to it.

    I realize this is a 'work in progress' so there will be improvements to TSRE over time, I just wanted to express my thoughts at this time. I made a route many years ago with RE and it was uploaded here. Just getting back into MSTS after a long stretch of other interest.

    All of my thoughts printed here …....... are just that.
    Glenn
    C1. I have no problems with pointer. Only change is 'Stick to Setting' ( Shift+Q) Easily seen . . . with experience.

    C2. Agree.

    C3. Select Forests in the "Other" menu where signals are listed also. Use the search function.

    C4. Safety my friend is why! You certainly DO NOT want track database automatic when you are changing and fitting track, trying different sections for a good fit. You're going to have one in the TDB and you'll move it without pressing 'Z' and then you ARE screwed big time. Leave this alone, it's a safety net for you.

    C5. It's stated somewhere in the documentation that Undo is NOT for terrain. For me, It works for everything else, works backward from your last placement. It also works when adjusting terrain to track with the 'F' key. BTW, The 'F' key, "ADJ Terrain to Object works for ANY object. Be warned though some shapes are faulty and produce VERY strange results if you tru to adjust terrain under them using the selected object. (all un-doable tho')

    C6. Press the [SELECT] button. This toggles select on/off.

    C7. The exact same way you did in the MSTS editor!

    C8. Like you said; "It's a work in progress."

    Additional info.
    If you are modding a route with interactives installed some cautions.

    A Track Vector is all the track between:

    a. Two Track End Nodes. ie 2 Blue Poles.
    b. A Track End Node (Blue Pole) and A Junction Node (Red Pole)
    c. Two Junction Nodes (Red Poles)


    Now the RULE:
    When modding track Interactive Objects MUST be removed (deleted) from ANY track vector between Nodes as described above.

    Ignore this and you WILL destroy any signal links and probably introduce corruption into the database files.
    Speedpost and Mileposts seem particularly affected throwing all sorts of bad stuff at you.

    Use a marker object to mark deleted interactive objects. I use a big 'ol smokestack or a animated smoke object. Easy to see. Of course you need to actually write into a notebook what each marker is standing for.

    Bottom line: TSRE is light years ahead of the MSTS editor but it DOES have it's little quirks. Practice and learn.

    regards,
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  4. #4

    Default

    Hey thanks for the info to some of my questions.

    C4. Safety my friend is why! You certainly DO NOT want track database automatic when you are changing and fitting track, trying different sections for a good fit. You're going to have one in the TDB and you'll move it without pressing 'Z' and then you ARE screwed big time. Leave this alone, it's a safety net for you.

    Vince, why does this work in RE without pressing any keys. I have not had a problem with RE and I have changed track to find what works for the space etc. I just don't understand the need to decide when a track piece should be entered in the TDB. May be in this program it is different.

    I know it will take a while to get used to a new program with all of the different ways to accomplish something.

    Thanks again for the help.

    Glenn

  5. #5

    Default

    Garry,

    I looked at the Settings file and it has the 'cameraStickToTerrain = true' all ready but the camera goes right through the surface terrain into 'no man's land'. If I set it in the menu inside of the program it is then OK. Don't know why?

    Another thing I would like to see is a display of the direction and Lat. & Lon. location. I'm never happy!

    Glenn

  6. #6
    Join Date
    Jun 2013
    Location
    Minnesota
    Posts
    1,084

    Default

    Quote Originally Posted by Magoo View Post
    ...

    Another thing I would like to see is a display of the direction and Lat. & Lon. location. I'm never happy!

    Glenn
    That exists. In one of the drop-down menus is an option for a compass

  7. #7

    Default

    Quote Originally Posted by Magoo View Post
    Hey thanks for the info to some of my questions.
    I just don't understand the need to decide when a track piece should be entered in the TDB. May be in this program it is different.
    Glenn
    Hi Glenn,

    Okay, say you're putting in various size track sections looking for a good fit. In automatic add to TDB as soon as you de-select a track it gets a TDB vector assigned.If you re-select the track section and move it without removing the yellow TDB line you will corrupt the TDB/World file synchronization and that is a problem. The thing is, trains don't run on the tracks.They run on the TDB.
    Here are a couple of tutorials that say it better than I.
    http://msts.steam4me.net/tutorials/h...ders_work.html
    and http://msts.steam4me.net/tutorials/rt_fold.html

    Leaving Automatic Add to TDB off removes the risk by leaving you in control as to when you want to add the new track section to the database. Not when you just de-select the track.

    You'll be doing a lot of swapping track in and out and the last thing you want is mistakenly moving a track while the yellow line is still associated with that track section.

    regards,
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  8. #8

    Default

    Hi Glenn
    Lat/long values of the camera are shown in the small Navi Window.
    Compass is the last option in the View drop down menu.
    Garry

  9. #9

    Default

    Quote Originally Posted by peacockg View Post
    Hi Glenn
    Lat/long values of the camera are shown in the small Navi Window.
    Compass is the last option in the View drop down menu.
    Garry
    I don't see any Compass listed in the View drop down menu. I assume I have the current version of TSRE, #5. In the NAVI window the text is very small and numbers change so fast to indicate the pointer position. I only use that to enter Lat. and Lon. numbers to jump to a start point on a tile. The numbers listed by Camera don't change while moving the camera. What do you think I am doing wrong?

    Thanks for all the help and suggestions.
    Glenn

  10. #10

    Default

    Hi Glenn,

    If you don't see a [Compass] listed in the >View< menu you are using a obsolete down level version.
    As Garry posted the Latitude and Longitude, Tile address and positions are all shown in the small NAVI window that opens when you start TSRE.

    The OpenRailsLog.txt file that is created on your desktop IF you have the [LOGGING] box checked on the OR opening screen.
    We absolutely need this log to fix your problems.
    Please attach the test file log to your answering post and we can help.

    regards,
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •