Results 1 to 4 of 4

Thread: Train exe not working

  1. #1
    Join Date
    May 2003
    Location
    Saint John, NB, Canada.
    Posts
    371

    Default Train exe not working

    Hi Folks. I have two computers with windows 7 on one and windows 10 on another. Both had train simulator on them and they worked. Now some time ago Microsoft up dated both machines and killed the simulator. I was wondering if anyone had found a work around to get it running again so I can use the activity editor for maps. I have an xp unit but it will not run the newer routes. Any help would be appreciated. Thankyou Greg

  2. #2
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    1,729

    Default

    Hi Greg,
    There is nothing in either Win 7 or Win 10 updates which will affect train.exe in that way. My PC runs both, which are completely up-to-date.

    What do you mean "killed the simulator"? Is train.exe still in the correct place? Are you using the Deesktop icons created by the MSTS installer? If so, they use launcher.exe instead of train.exe - if you'd followed the Steam4Me tutorial, you would have already changed them to train.exe!

    If you've done everything the recommended way, the only thing I can suggest is that you go to the Steam4Me site and download and install the v1.4 update - at the bottom of this page : http://msts.steam4me.net/MSTS_Updates/index.html

    Cheers,
    Ged

  3. #3
    Join Date
    Apr 2007
    Location
    Swindon, England
    Posts
    4,281

    Default

    Greg, I do sympathise with you and with respect to Ged's view there *are* things going on with background processes updated by Windows and/or GPU drivers that will kill MSTS stone dead on a system where it was working perfectly alright the day before. To recap, I recently upgraded the GPU in my main PC to a GTX 1050 (okay not much of an upgrade, but what the budget allowed) and treated myself to a UHD (3840 x 2160) monitor. The next time I went to run MSTS either sim or editors - nothing. It would start to execute but almost instantly CTD. I've played around with DPI settings, I've tried train.exe and launcher.exe neither of which work. I tried reducing the desktop resolution but at 1920 x 1080, the Editor still helpfully failed to start with a message it needs a resolution of at least 1024 x 768 to run, er - duurr…

    For the time being the G.O.O. Jail free card is that I can still run on my laptop but the time is fast approaching when MSTS will really be extinct, absolute End Of Life, so to speak. Already decided so far as route building is concerned it's either got to be Trainz or DTG TS. Open Rails is available to run old MSTS stuff but you still really need the MS Tools to set up Activities. Although TSRE has a fledgling activity editor it is still unfinished - as I posted separately (without garnering any response) it doesn't seem to cater for changing calling patterns and updating the timetable though hopefully that will come.
    Vern.

  4. #4

    Default

    Quote Originally Posted by ideaman View Post
    Hi Folks. I have two computers with windows 7 on one and windows 10 on another. Both had train simulator on them and they worked. Now some time ago Microsoft up dated both machines and killed the simulator. I was wondering if anyone had found a work around to get it running again so I can use the activity editor for maps. I have an xp unit but it will not run the newer routes. Any help would be appreciated. Thankyou Greg
    I had something similar happen to me once. A windows 10 updated reduced MSTS (and ORTS) framerates to a crawl. I suspect it was a video card driver. I did a system restore to before the update and things were back to normal. Strangely, they remained OK later on when the update installed anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •