Results 1 to 7 of 7

Thread: Editor Modes: Select (E) or Place New (Q) Commands

  1. #1

    Question Editor Modes: Select (E) or Place New (Q) Commands

    HI Goku,

    I don't know if you remember a request I made about 4 months ago:
    When in Place New mode and after placing a new track section I want to switch to Select Mode.

    I press the 'E' key but the editor DOES NOT switch to Select mode, staying in Place New mode.

    The Manual says I may use the keyboard by Press 'E' to choose Select Mode and Press 'Q' to enter Place New mode. I feel that keyboard input should take priority and do the command but it seems the editors focus is elsewhere, not accepting the keyboard command.

    ++If I am in Place New mode, and place a track section, then pressing the 'E' (select) Key does not work!
    ++I get another track section that I now have to delete. The 'E' STILL will not let me select the misplaced object as I MUST use the mouse to press the Select Button to select the already selected new track section (blue outline) track!

    It seems that the editor once in Place New mode will not accept input from the keyboard.
    Pressing 'E' key does not switch to Select Mode;
    I have to use the mouse to press the Select Button. Quite annoying.
    I feel the editor should respond to keyboard input command, pressing the 'E' key, no matter what mode the editor is in.

    ++ Another (minor) gripe.
    The Copy Rotation set of buttons on the left side panel for objects is a VERY handy tool but it is not available if I select a Dynamic Track piece.
    Can you please make the Copy Rot buttons available for Dynamic Track? We don't need anything special for DynTrk, just the base rotation and elevation would be much appreciated.

    And a request:
    The ability of your editor to display TrackDB (view menu) Items is a good start.
    If you could provide the Object Properties and location information would be a huge help to advanced users correcting the database problems that exist in many current routes.

    I wish to thank you for providing elevation information for multiple signal objects and the ability to make a global elevation change.
    Makes installing multiple signal heads on a gantry an easy task now. I had hundreds of these to do and they were all done quickly and easily. Thnx....

    ++And finally a report on the experimental release TSRE5_v0.6963 you provided me.

    You hit the ball out of the park with this!!!! A grand Slam we call it on this side of the pond!

    TSRE made it possible to repair the PRR huge amount of database errors and corruption.

    Your editor, with information provided by the Open Rails Log and the DBTools program (author=ChiFan) made it a cakewalk to eliminate ALL the database errors including the isolated Blue Poles which you so correctly described as "an ugly bug."
    Yes, ugly was a very good description but no longer an issue with this route thanks to you. I also think I noticed that the Open Rails Log is now providing location information for these TDB problem items. Thank you OR Team!

    Hope you and family are well and have a calm new year.

    best regards,
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  2. #2
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    602

    Default

    Quote Originally Posted by Vince View Post
    I press the 'E' key but the editor DOES NOT switch to Select mode, staying in Place New mode.

    The Manual says I may use the keyboard by Press 'E' to choose Select Mode and Press 'Q' to enter Place New mode. I feel that keyboard input should take priority and do the command but it seems the editors focus is elsewhere, not accepting the keyboard command.

    ++If I am in Place New mode, and place a track section, then pressing the 'E' (select) Key does not work!
    Works fine for me. What version do you use. Windows version? Does it happen also in a new TSRE installation?
    Can you show me a very detailed way how to reproduce this bug?
    E key should always work, if 3d view is in focus.

    The E key is crucial for comfortable TSRE use, so I'm surprised that you live without it so long.
    In new TSRE version you can also use right click context menu to enable select tool. It is not as handy as E key, but better than "select" button.

  3. #3

    Default

    Hi Goku,

    I can reproduce bug.
    Windows 10 Pro 64bit

    1. Select an object.

    2. De-select the object. click on ground or sky, no matter.

    3. Click on an item in the Objects Menu to select an item, say a track section. Does not matter what.

    4. The Objects menu I click on hi-lights orange showing me it's selected and ready to be placed . . .

    5. I press the 'Q' key . . . Nothing happens. Again . . . nothing.

    6. I have to click again on sky or ground again before the editor responds to the 'Q' key press.
    I feel the keyboard should have absolute priority over any mode the editor is in.

    I think the switching the editor from Place New mode to Select mode via the keyboard also may have a problem also but as of this time I have not been able to define it.

    best regards,
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  4. #4
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    602

    Default

    5. I press the 'Q' key . . . Nothing happens. Again . . . nothing.
    6. I have to click again on sky or ground again before the editor responds to the 'Q' key press.
    Ok, that is known issue. The Q,E and all other keys doesn't work when you are in tools or in properties. Only in 3d view.
    You can use single right click to focus on 3d view. First single right cilck gives keyboard focus to 3d view and does nothing else.
    I could try to enable Q and E keys to work in tools too. If you want this, make new topic in Ideas / Feature requests on my new forum, so that it won't be forgotten.

  5. #5

    Default

    Thanks for confirming.
    If you want you may copy any of my posts you feel may help TSRE users to your Tips sub-forum.

    My tip of the day:
    When placing and deleting lots of track sections as when you lay out a yard, it's a safe idea to shut off automatic adding to the Track Database ( Ctrl + Q )

    regards,
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  6. #6

    Default

    Hi Goku
    In an earlier reply you said, "The E key is crucial for comfortable TSRE use, so I'm surprised that you live without it so long."
    I use your TSRE every day but I did not know the E key did anything, and I can also say I will not be using it.
    Try this. Put the mouse in your left hand, and look at the keyboard for every letter you type (on a good day I can make many mistakes using 2 fingers). if you use the mouse on screen it is much easier to stick with it to go to the Select/Place New buttons, compared to trying to find the E key with either hand.
    Your editor is GREAT. I would not be trainsimming without it.
    Many thanks
    Garry

  7. #7
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    602

    Default

    Try this. Put the mouse in your left hand, and look at the keyboard for every letter you type (on a good day I can make many mistakes using 2 fingers). if you use the mouse on screen it is much easier to stick with it to go to the Select/Place New buttons, compared to trying to find the E key with either hand.
    TSRE is designed to use mouse with right hand and keyboard with left hand on AWSD keys. When fingers are placed there, everything is nearby.
    Ofc using mostly mouse is a good idea too. That's why I'm slowly adding more and more features easily accessible with mouse.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •