Results 1 to 3 of 3

Thread: Route building became very hard

  1. #1

    Default Route building became very hard

    Hello Everyone.

    Yes I am still around for anyone who remembers me. I just don't do trainsimming much anymore, as I've made trains my career now, doing the sims no matter which one, is a lot less fun for me than it was years ago. I still boot them up once in a while when I'm bored, but for the most part I don't participate in route and scenario building much anymore, for the few things I actually was able to post.

    I'm posting here now and emerging out of lurking, because I've run into a problem with TS2019. It seems whatever file is in charge of track rules has become badly corrupted within my game. I can't select anything for track rules, and the tracks themselves are too close together. I have no idea what happened, and verifying game file integrity through steam doesn't seem to work.

    I would post pictures, but I'm not on my main computer right now, and it's easter. Later in the week I will post a pic or two if anyone sees this and might know what the problem is.

    I only do this for fun now, and I really don't have any intentions of ever releasing anything again, so there is no rush to solve this problem.
    I am no longer active.
    PM me if you have a specific question.

  2. #2
    Join Date
    Apr 2017
    Conrwall, New York


    Tom, Don't despair this is a known issue with the 64 bit version of TS2019, if you edit track, track markers you will in lose the frogs in crossovers. Placing siding markers will also cause the same corruption. While you can continue to edit scenery and roads in 64bt, use the 32bit version for track editing.

    If you have issues all you need to do is restore the track.bin file. You will, of course lose any trackwork done after the backup.

  3. #3


    Actually my problem wasn't related to that. I was trying to lay track down in a route and the track pieces were too close. I look under the track rules window and find no track rules at all. Then i go into the box with all the dlc i've downloaded and i discover the route template i'm using was disabled somehow. Re-enabled it, problem solved. And in the 64 bit version is what I'm doing this in. I don't know if I'm going to be going back to an old project I've tried working on before. Using premade station buildings for what I've wanted to use for my routes has never been easy for me, and I doubt I will release anything I build unless I really believe it's a good item, whatever it is.

    That being said, I am going to work on a route for my own entertainment via the NJT Midwest Division, an emulated transit system, based on my home railroad, NJ Transit, which I've also fulfilled my dream of making a career out of. I hope it works out ok.
    I am no longer active.
    PM me if you have a specific question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts