Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: MSTS Activity editor

  1. #11

    Default

    BTW did you quote those Sound line correctly? as in
    Sound ( "..\\..\\3DTrains_FPack\\Sound\\3DTrains_FTUni t_Ca b_ATSF.sms" )

    There is no space between
    FTUnit_Ca and
    b_ATSF.sms.

    Charles

  2. #12
    Join Date
    Feb 2008
    Location
    Lexington, Ky
    Posts
    2,502

    Default

    Yes Charles, thx................

    This is my fault, at sometime years ago, about 100 lines missing. I must have been mass editing and messed up 20 or so, at least I have the originals, thanks for the pointers............................
    Rick

    http:\\mononrr.com

    MONON-2


  3. #13
    Join Date
    Feb 2008
    Location
    Lexington, Ky
    Posts
    2,502

    Default

    Charles

    Re-download the pack and check eng file: AUnit_ATSF_152CAI

    It is missing all kinds of stuff, this is what must have messed me up years ago and never caught it.

    I reinstalled the FT pack from my saved download and went through the installer, missing probably 100 lines: AUnit_ATSF_152CAI
    and there are many others.
    Rick

    http:\\mononrr.com

    MONON-2


  4. #14

    Default

    Not really missing. Designed as an AI only. Not drivable. Notice there is no cabview line. Same with the 152CR or 152C reversed unit. Other main difference is the lights.
    Charles

  5. #15
    Join Date
    Feb 2008
    Location
    Lexington, Ky
    Posts
    2,502

    Default

    True, but that is why MSTS Activity Editor displays the wrong name, on all of them, OR and Consist Builder reads the Name line.
    Got to be an easy fix for this......
    Rick

    http:\\mononrr.com

    MONON-2


  6. #16
    Join Date
    Feb 2008
    Location
    Lexington, Ky
    Posts
    2,502

    Default

    well, your initial thought was right
    it seems to be only these 2 sets

    3DTrains_FTUnits_ATSF
    3DTrains_FUnits_ATSF

    Your right, the ) is out of place, needs to be after the Name line.
    Is only the reverse and AI engines.................
    Rick

    http:\\mononrr.com

    MONON-2


  7. #17

    Default

    Quote Originally Posted by Rick-MONON View Post
    True, but that is why MSTS Activity Editor displays the wrong name, on all of them, OR and Consist Builder reads the Name line.
    Got to be an easy fix for this......
    Ran a Match braces test.
    All the AI and R engs have an extra ")"
    The extra one is causing the CE to stop reading the Engine section before the Name line so the Name line is not read.
    The extra one that should be deleted is just before the Name line.

    As for an easy fix. Tried my app Search and replace but could not get a unique Search Criteria that would find the correct line.

    Only way I see to fix is to edit each AI and R eng file.
    Charles

  8. #18
    Join Date
    Feb 2008
    Location
    Lexington, Ky
    Posts
    2,502

    Default

    Thanks

    Agreed, well its not much and not too many...............

    At least I finally have the fix, always wondered , tried and failed till today.........
    Rick

    http:\\mononrr.com

    MONON-2


  9. #19

    Default

    FYI. Just checked the other CEs '
    MSTS CE > problem: Display appears as if no Name line
    ConBuilder > not affected.
    TSRE-CE > not affected.
    Convoi > problem: Display appears as if no Name line
    Charles

  10. #20
    Join Date
    Feb 2008
    Location
    Lexington, Ky
    Posts
    2,502

    Default

    BTW

    the GM&O pack has the ai and rev eng files like this

    DieselEngineMaxRPMChangeRate( 50 )


    Name ("GM&O F3A 801A Reversed 3DTS")
    )
    Description (
    Rick

    http:\\mononrr.com

    MONON-2


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •