Results 1 to 3 of 3

Thread: MSTS Black screen then closing upon launching

  1. #1
    Join Date
    May 2019
    Location
    North Island, New Zealand
    Posts
    1

    Default MSTS Black screen then closing upon launching

    I've been having trouble running msts when i open the launcher and click play train simulator a black screen appears then closes i'm running windows 10 with an intel R core I5-3470 on an hp PC

  2. #2
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,351

    Default

    Hi TrainsOfNewZealand,
    Welcome to the Forum

    I'm assuming you have followed the Steam4Me tutorial (http://msts.steam4me.net/tutorials/i...g_msts_w7.html ) EXACTLY! NOTE : although entitled for Win 7, it's also applicable to Win 8/8.1 and 10.

    If not, please uninstall your current installation and follow the tutorial. You need to uninstall MSTS so that the current Registry entries are removed.

    With MSTS installed according to the tutorial, set launcher.exe and train.exe to "Run as an administrator" using their Properties > Compatibility tab. No other compatibility settings are required.

    Cheers,
    Ged

  3. #3
    Join Date
    Apr 2011
    Location
    New England
    Posts
    883

    Default

    Another possibility is monitor resolution set too high -- all too possible on modern hardware. MSTS, with the BIN patch installed as described in the Steam4Me tutorial, can only handle screen resolution up to 1600 x 1200. Any more and MSTS will crash to the desktop.

    Check your screen resolution setting in Windows, and manually lower it temporarily while running MSTS if the default (marked "Recommended" by Windows) is too high.


    MSTS-Roundhouse

    On hiatus and moving to a new host -- Probably in 2021
    (Because 2020 has turned out to be b0rked beyond belief...
    )

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->